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We’ll begin the report by creating a basic outline of its overall 
structure. This helps to set the layout, and to place the words in 
the correct place when we come to writing them. To start with, 
just create a blank new document. In our example we’re going to 
add a title for the report, along with sections headings for each 
part of our example document. For instance, put the document 
title on a single line (we’ve used ‘Structuring a scientifi c paper’), 
followed by several section headings. Our complete list of 
sections includes ‘Preface’, ‘Conventions’, ‘Introduction’, ‘Chapter 
X’, Appendix X’ and ‘Index’, which covers the vast majority of 
cases. We’ve also followed the title for each section with a few 
lines of text to describe the contents of the section. 

Applying style
Now that we’ve created the basic outline of a report, the fi rst 
step in formatting is to add style to distinguish between the 
various sections we’ve just created. Applying a style is akin to 
marking a section of text with a hidden label. If you’ve ever edit 
HTML pages, you’ll be used to his idea. You can mark a section 
as a heading, for example, and then tell Writer how you’d like 
headings to appear in your document. If you change your mind 
about the appearance of headings, all you have to do is change 
the formatting of the style, and all the text marked as headings 
within the document will alter to refl ect the changes without any 
further manual intervention. Writer provides an array of default 
styles that control the appearance sections of text, as well as 
applying the hidden label. Let’s use one of these default styles 
by triple-clicking the name of your report to highlight it and then 
selecting Format > Styles and Formatting. The Styles and 
Formatting window appears, populated with a list of all Writer’s 
built-in styles, including ten different kinds of heading (these 

 The Styles list attempts to guess which kind of text you’re editing automatically, but you 
can also choose from the drop-down list at the bottom.

When you start to use Writer for documents a little longer 
than a quick few paragraphs, structuring becomes important.

Structuring 
Content

Whether you are embarking on writing a college paper, 
scientifi c report or entire book, Writer provides all the 
necessary support to help structure your content. 

Structuring content using style and basic navigational aids 
removes some of the learning pain for whomever your reader 
may be. It can also help you, as the writer, to keep on top of the 
various aspects of a multi-page document, and save time when 
you need to change things that are common to the entire 
document. For anything that’s more than a couple of pages, 
basic structure and style is going to help. To show off some of 
Writer’s structuring features, let’s get stuck into a chunky project 
by structuring a basic scientifi c report. But don’t worry if you’re 
not a scientist – everything we’ll cover in the fake report is 
completely relevant to nearly any document style: it’s just a good 
place to start. We’ll use this as a working example to guide you 
through the main functions you need to consider when applying 
structure to a report.

 Editing the way Header styles appear using the Insert Index/
Table window shows a real-time update to changes you make.
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vary the prominence of the heading text, just like with HTML). 
But these are only a fraction of the styles available, and Writer 
has actually tried to guess what kind you’ll need. In the small 
drop-down menu at the bottom of the Styles and Formatting 
window, you’ll see that is says ‘Automatic’. If you select this, you 
will see a smaller list of subcategories for the remainder of 
Writer’s styles. We’re looking for ‘Chapter Styles’, and when this 
is selected, you can then choose the Title style for the text we’ve 
highlighted. Excellent! You’ve just applied the Title style to the 
title sentence in your document. The name of your report is now 
the title of the book, and the title style has been added to the 
style menu in the formatting bar in the main Writer window. This 
is often the easiest way to work with styles after you’ve created 
a few defi nitions, and you can use this drop-down menu to apply 
Heading1 style to the section headings in the document outline.  

Table of Contents
To help your reader jump to the information they need, we’re 
going to add a table of contents. Traditionally, this would have 
been one of the last jobs to do when working on a document 
because you might think you’d need to fi nish writing your text 
before a table of contents makes any sense. But thanks to the 
wonders of computing, it actually makes a lot of sense to create 
a table of contents early on. You can then use this to jump 
around your document as you’re writing it. Writer will keep on 
top of the page numbers and where everything lives. 

We’ll start with the document title. Position the cursor after 
your title and select Indexes and Tables > Indexes and Tables 
(that’s not a typo!) from the Insert menu. The Insert Index/Table 
window will appear. By default, this window is confi gured to 
create a table of contents and we just need to press OK. A block 
of grey text will appear after your title – you have just inserted a 
table of contents into your document! This block of grey will not 
be editable, and has automatically included each Heading style 
section of marked text in your document into the contents, 
along with a link to the page that each heading is on. As you add 
more sections and subsections to your report, you can update 
the table of contents to refl ect these changes. To demonstrate 
this, add a subsection to one of your sections and format it 
using the Heading2 style. Now update the table of contents by 
right-clicking on the table of contents and selecting Update 

Index/Table. Your new section will be added to the chapter that 
proceeded it, and more importantly if you used Heading2 style, it 
will be indented further into the page to show that it’s a 
subsection within a chapter. You should be able to see now how 
useful styles are for structuring your document. Not only will 
they give a consistent look to the same elements within your 
document, they let you create things like the table of contents 
with very little effort. 

You can’t edit the table of contents directly, but you do have a 
good degree of control over what it looks like and you can change 
the format of the table of contents using the same right-click 
menu we used to update the table earlier. Let’s say you want to 
increase the indent of all Heading2 entries. To do this you need to 
right-click the table of contents and select Edit Index/Table. This 
will open the Index/Table window we used to create the table of 

1  Document-wide changes 
Either select the styled text you want to edit or just 
open the Styles and Formatting window directly 
from the toolbar or the Format menu as above. 
This window lists the available styles. Make sure 
you select the one you want to edit and right-click 
to select Modify.

2  Paragraph style window title
This will list the style you’re editing in the title of 
the window. The main thing you might want to 
change about a style is the font. Switch to the Font 
tab, and change the font and the size according to 
your wishes. You might also want to change the 
alignment of your style.

3  Add your own styles
When you’re satisfi ed with the changes you’ve 
made, just click on OK to apply the style. Any 
sections of text in your document that have had the 
style applied will change according to the changes 
you’ve made. You can also add your own styles if the 
default ones don’t suit your needs.

 Don’t forget that you need to update the dynamic contents of your document to reflect 
any changes that result from further edits to the document text.
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contents earlier. Next, select the Entries tab, select Level 2, and 
click Tab Stop to insert a tab. Enter 1.00cm as the Tab Stop 
Position. The real-time preview in the left of the window will 
update to show you the consequences of your changes, moving 
Heading 1.1.1.1 and Heading 1.2.1.1 (both defi ned as Heading2 
styles) further into the document. Clicking on OK will apply the 
same changes to your original document, and don’t forget you 
can Undo and Redo those changes to make sure you get the 
effect you were looking for.

Indexing
Now that you have a table of contents and the main sections in 
place, you can add an index. Indexing is an art in itself: many folks 
argue that it’s the index that makes or breaks a good book. We 
feel that the only rule worth working to when building an index is 
that you either do it well, or not at all. There’s nothing more 
frustrating than a thoughtless index that has been included in a 
book to simply tick a requirement rather than add an extra layer 
of value.  When an index is implemented well, they’re the closest 
you’re going to get to an internet search engine in a printed 
medium; we think that’s A Good Thing. In Writer, indexing works 
by marking key words within the body of your content. These key 
words then get built into a fi nal index. This means that before you 
can add the index itself, you need to create at least one index 
entry within your report fi rst. To make this clearer, let’s create an 
index entry by marking a key word within our text. Start by 
selecting a word that summarizes what a particular paragraph or 
page is all about. Now select Indexes and Tables > Entry from the 
Insert menu. The Insert Index Entry window appears, containing 
the word you highlighted in your document. Click on the Insert 
button to add this to the index. As with the table of contents, you 
will now fi nd that Writer has added a section to your document 
that contains the new index along with the single entry you’ve just 
added. It will have added the index at the point where your cursor 
was. Befi tting an index, this should be at the end of your 
document, and the single entry will include the page number of 
your highlighted word. Also like the table of contents, you need to 
remember hen you’ve made further edits to your document and 
right-click in the index section and select Update Index/Table to 
automatically update the index with any changed page numbers. 

This should all sound fairly straightforward. But Writer can’t 
help with the most important part, and that’s the usefulness of 
the words you select to be in the index. You need to consider how 

helpful the key words you are adding to your index really are. You 
don’t want to send readers into your text only to fi nd a passing 
reference to the subject they are really interested in. This is a 
common problem with documentation. Whenever you add an 
index entry, try to imagine your reader desperately scanning 
your index in order to fi nd the information in that paragraph or 
page. Friends and colleagues are the perfect testers of a 
document’s index, as they’re likely to think in ways you don’t 
expect. Get them to try out your index, and if there are any words 
your readers are scanning through the index for, add another 
index entry in the appropriate place in your text to help them out.  

The index entry window remains open so that you can add 
multiple entries without having to keep opening the window. This 
is useful if you prefer to index your work in one go towards the 
end of development when the bulk of content has been created. 
By this time, you will be familiar with where the key words will be 
most useful. If you have closed the window, you can update or 
delete an index entry by simply right-clicking over the index 
entry, as we did when updating the index earlier. To change the 
format of the index, go to the end of you report, and select 
Indexes and Tables > Indexes and Tables from the Insert menu 
again. In the Type drop-down list, select Alphabetical Index, 
delete the title of the index and click OK. 

Bibliography
Bibliographies may sound rather specialist, but they’re the last 
requirement for the structured scientifi c paper we’re using as 
our example. If you do any academic work, for example, then a 
bibliography is essential. It’s basically a list of references at the 
end of your document linked to the sections within your words 
that use information from the reference to make a point. 
Keeping a bibliography u- to-date can be an arduous and time 
consuming job, but Writer can take much of the pain away. Just 
don’t leave all your references to the last minute. When you’re 
writing your document and you’d like to include a reference you 
want to add to your bibliography, select Bibliography Database 
from the Tools menu. This opens an impressive window that 
should already contain a group of references. This is actually a 
window running the OpenOffi ce.org database, as the developers 
would rather use the features provided there than reinvent the 
wheel needlessly by hard coding another solution. 

This database is used to manage the references within your 
documentation, and it will already include plenty of examples 
that are used by the OpenOffi ce.org documentation team, and 
are included as examples of how to enter reference information 
for your bibliography. To add your own, select Insert > Record 
from the menu. A new line will be added to the bottom of the 
table. This database is quite comprehensive, and includes a fi eld 
for almost anything you might want to note about a publication, 
but you don’t need to fi ll every fi eld in. Just put something short 
and snappy to identify the book in the fi rst fi eld, labelled 
‘Identifi er’ – it’s this that you’ll use to insert your reference into 
your document, so it needs to be both unique and memorable. 
This short piece of text is also what’s going to appear in the 
body part of your document as the reference to the 
bibliography, so it also needs to be broadly understandable by 
your reader. Many scientifi c publications, however, will use a 
simple number for each reference, or even Roman Numerals, so 

 First position your cursor where you want your tables and indexes to be situated. 

You don’t need to highlight a word in Writer to be able to 
add an index entry, you can insert them wherever you have 
positioned your cursor within the text.

Quick tip
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1  Help readers… and Writers! 
Sometimes it’s useful to cross-reference text in 
the document, allowing you (and readers) to jump 
quickly from one point to another. First select the 
text that you want to target, then select Cross-
reference from the Insert menu. Type a name for 
your reference in the Name fi eld and click Insert.

2  Navigate your documents
The SetReference list will be updated with your new 
target. Move the cursor to the where you want the 
reference. Now change the Type from Set Reference 
to Insert Reference and make sure your target is still 
selected and change the format to what you need 
and click on insert.

3  Get connected
The cross-reference will appear as a block of grey 
text in your document, and it’s content will depend 
on the format you chose. It might be a page 
number, for example, or ‘above’ or ‘below. Clicking 
on the word will also skip to the target reference you 
created in the fi rst step of this mini-tutorial.

you may need to be guided by the target audience of your 
document. You can always change the identifi er later without 
going through each reference in your document. You can also 
use the fi elds as they appear in the lower half of the window, 
rather than the database table. The identifi er fi eld is listed as 
‘Short name’ here. You will also want to at least put in the 
authors of the book, the publisher and the ISBN code, so that 
your readers can fi nd the publication you’re referring to. Just 
close the database window when you’ve fi nished.

Now that you’ve added your publication to the bibliography 
database, you can insert it into your document by selecting 
Indexes and Tables > Bibliography Entry from the Insert menu. A 
small window appears from which you can select the short 
name identifi er you selected for your publication from a drop-
down list. When you’ve selected the one you want to reference, 
the other details from the database record will also display in 
the window, so that you can check you’ve got the correct 
publication. Clicking OK will insert the reference into your 
document at the point where your cursor was. A grey block of 
text with your short name identifi er will now appear, and clicking 
on this will open the Edit Bibliography Entry window again. This 
is a link to the publication in the database, and it can be copied 
and pasted along with the surrounding text it references. Now 
the only thing left to do to complete the bibliography is to add 
the actual table of references to your document. This works in 
exactly the same way as the for the table of contents and the 
index. Move the cursor to the position in the document you want 
the bibliography to appear, and select Indexes and Tables > 
Indexes and Tables from the Insert menu. This is the same 
window we’ve now used twice before for the index and table of 
contents, and the bibliography is just considered another table. 
Change the type to Bibliography and click on OK. You will fi nd 
the bibliography reference to the publication you just added. LXF

 Contextual menus change according to the type of objects you are 
editing within your document. In this case, it’s an entry for the Index.

 Writer uses the power of the OpenOffice.org database application Base 
to manage the bibliography references within your documents.

You can update the table of contents and index at the same 
time by selecting Update > Update All from the Tools menu.

Quick tip
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