
Writer: the basics

18     Master OpenOffi ce.org

Vive La Différence!
But there are differences. And you’re likely to come up against 
these whenever you want to try something slightly more 
interesting. You will see that the menu system feels totally 
unfamiliar, with a mass of options hidden away behind each 
menu. This is the most intimidating part of Writer and 
OpenOffi ce.org in general – the layout of the various menus and 
options windows take a little learning. But don’t let that put you 
off. It just means that Writer and its companions are capable of 
almost anything you might expect of the best commercial offi ce 
applications, even if it takes a little effort to fi nd the function 
you’re looking for. This is a good moment to mention the online 
help for Writer, as this is often the easiest way to fi nd what you’re 
looking for. Press either the F1 key, or select Openoffi ce.org Help 
from the Help menu, and the well-written user manual will 
appear. The best way to use this is to type something you’re 
interested in into the Search Term box. Try ‘dictionary’ for 
example, and the subject list is automatically populated with 
pages that can help you use the function you’re looking for. You 
can also use the What’s This? option in the help menu to switch 
to the info cursor. If you now hold your pointer over any of the 
buttons in Writer, a small yellow panel will provide further 
information on the functions behind the cursor. 

Options
The fi rst place to start is with a few simple user options that you 
will need for every document you work with. Open the Options 
window by selecting it from the bottom of the Tools menu. This 
Options windows is used across the entire suite of OpenOffi ce.
org applications, so don’t be too scared by the number of 
options. A good thing to do is add your name to the User Data 
panel under the top option. This information will then be 
embedded into every application you work with, making your 
changes easier to trace. The next thing you should check is the 
default language. This can be found under the Language 
Settings menu on the right side of the Options window. The 
Language Settings panel is where, as you might expect, you can 

The word processor is where most users spend much of their 
time; luckily, this important application is also the easiest to use. 

 Getting started 
with Writer

Word processors haven’t changed that much in the last 
ten years or so. At least not on the surface. 
OpenOffi ce.org’s word processor, snappily dubbed 

Writer, is no exception, and that is defi nitely a good thing. It 
means that if you’ve used a mainstream word processor in the 
last decade, you’re going to feel right at home with Writer. Just 
launch the application to see what we mean. 

You get a text editing window taking up the main part of the 
window, a ruler down the left and a scroll bar down the right, and 
in the ancient tradition of computerised word processing, a 
series of buttons, toolbars and font selector crowning the editing 
area at the top. From the visual point of view, Writer could be 
almost any word processor – and that’s the idea. If something 
works, there’s no point messing around with the formula and if 
you’ve worked with virtually any modern word processors before, 
you will already be able to rustle up  most documents with 
Writer. Just click on various parts of the user-interface exactly as 
you would with an alternative. 

 If you find that Writer is changing the meaning of your words, then the AutoCorrect 
function is the most likely culprit – change the options to better suit your way of working.

When Writer fi lls in a word you’re typing, press Enter to leave 

the word intact.

Quick tip
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change the default language used by Writer and all the other 
applications. You can also change the language used by the user-
interface, and for the text content in documents, and it’s Writer 
where the effect of this setting will be felt the most, as the 
dictionaries and word replacements you use while editing 
documents are all affected by the dictionary you’re using. But 
the most obvious place where you’ll see the effects of the 
language you choose is in spell-checking,

Essential information
Like nearly all word processors of the last 10 years, as well as 
presenting your text in a WYSIWYG (What You See Is What You 
Get) fashion, Writer uses a toolbar to provide quick access to all 
the most common options – for a quick reference to what action 
each item on the tool bar represents, see the Writer: the toolbar 
at a glance box at the bottom of this page . The small toolbar 
icons might not look familiar, but the functions behind them will 
be. For example,  the fi rst four icons on the top left of the display 
will let you create a new document (the image shows a letter), 
open an existing one (an arrow shooting out of a folder), save 
your current document or email it to a contact. Two of the most 
common special elements you may want to include in a 
document are tables and lists. It’s for this reason they both 
feature prominently in the main toolbars, but you don’t even 
need to resort to the user-interface to create lists. Starting a new 
line with an alphanumeric character followed by a full stop, or 
starting a line with a hyphen, and helpful Writer guesses you’re 
creating a list and switches mode accordingly. Not only will the 
Bullets and Numbering toolbar open, but your text will be 
reformatted and tabbed further into the document. Welcome to 
Writer’s auto-correcting function. 

Auto correction
You will fi nd Auto correction either incredibly useful or a real pain 
to deal with: it all depends on how you like to format your 
documents. If you’d rather just type and let the word processor 
correct spelling mistakes, create lists and bullets, hyphenate 
words and swap certain keywords with one another, then the 
default settings will suit your style. If you’d rather leave 
formatting and word replacement to a later read through of the 
text, or if you’d rather format your lists differently, then auto 
correction is going to drive you mad. Fortunately, there’s also a 
fi ne degree of control over which elements you want to be auto 
corrected, and which you’d rather leave. These settings, along 
with hundreds of others, can be found in the AutoCorrect 
window. This is opened from the Tools menu, and when fi rst 
opened it will default to the replace window. This lists a series of 
characters on a panel on the left, with a series of longer words or 
special characters that will replace them on the right. For 
example, the fi rst entry replaces (C) with the copyright symbol 
©, and there are hundreds of other predefi ned replacements, 
including common typographical errors like ‘yoiu’ for ‘you’ and 
correcting ‘insurence’ with ‘insurance’. For corrections that are 
most likely to annoy, simply switch to the Options page to stop 
automatic list formatting or hyphen replacement.

Writer: the toolbar at a glance

1  New document
2  Open document
3  Save current document
4  Email document using default email client
5  Edit read-only documents 
6  Export document as a PDF
7  Send to printer
8  Preview the printed pages
9  Manual spellcheck
10 Automatic spellcheck
11  12  13  Cut, Copy and Paste

14 Copy and Paste text formatting
15  16  Undo and Redo
17  Insert a web link
18  Create a table
19  Show drawing toolbar
20  Find and replace words
21  Jump to parts of your document
22  Insert clip art into your document
23  Merge other data sources
24  Show non-printing characters
25  Set zoom level

26  Open Help documentation
27  28  Style and Formatting list
29  Font selection
30  Font size
31  32  33  Bold, Italics and Underline
34  35  36  37  Text justifi cation options
38  39  Enable bulleted and numbered lists 
40  41  Decrease and increase indentation 
42  Font colour
43  Section highlighting
44  Background colour

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
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Select a section of text and drag it around by left-clicking with 

your mouse.

Quick tip

“Writer and its OpenOffice.org companions are able to 
produce documents comparable to commercial office 
apps, and are compatible with Microsoft Office too.”
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Writer: create a List

1  Enter the data 
Writer can create bullet lists and numeric lists 
automatically. First type each list item onto a 
separate line in the main document window. Each 
line will be used as a separate list item when Writer 
is instructed to format your list.

2  Select relevant text 
The next step is to select the exact section of the 
document that you want to be used as a list. You 
can do this either by dragging the mouse cursor 
over the text, or by jumping to the start of the list 
text, pressing Shift and jumping to the end.

3  Numbers or bullets 
Finally, select either the Bullet List icon or the 
Number List icon from the main toolbar (the latter 
has Roman numerals). Your highlighted text will be 
indented and either a number or a bullet is placed 
at the beginning of each line.

Writer: create a Table

1  Size IS important 
Click and hold down the mouse button on the table 
icon to open a small matrix representing the size of 
the table you want to create; eg if you want a 3x3 
sized table, drag the cursor until the size you want 
is highlighted, and then let go of the mouse button.

2  Enter the information 
The table will be inserted into wherever the cursor 
is positioned in the current document. Select each 
cell and enter the information you need, pressing 
tab to move from one cell to the next. Select the 
entire table by clicking on its border.

3  Cell formatting 
Select a cell, row or column and then use one of the 
text formatting tools. Try and add foreground and 
background colours using their icons in the toolbar. 
You can also drag the cell borders to stretch the 
size of the cells to the size you need.

Writer: format your table

1  Advanced options 
An advanced range of options for formatting your 
table can be accessed from the table toolbar, which 
is opened from the View menu. This, and other 
toolbars, will also open automatically when you 
select a table you’re already working on.

2  Automatic formatting 
The AutoFormat icon lets you scan through a list of 
predefi ned table formats you can apply to your 
own table, as well as add your own modifi cations. 
Clicking on the More button will let you limit the 
parts of the table affected by the AutoFormat style.

3  Appearance tweaks 
After changing the colours and text styles, you can 
change the borders that separate the cells. Holding 
the mouse button down on the Borders toolbar 
icon lets you choose between several Border styles. 
Experiment with the other icons for other styles.
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Writer: Microsoft Offi ce and PDF Output

1  Compatibility 
You can save your documents in a format that can 
be opened by Microsoft’s Offi ce apps. All your 
formatting, tables and lists are preserved. You can 
also load most Offi ce documents. Select Save As 
from the File menu to get to the Save requester.

2  Microsoft Word compatible 
By default, OOo uses an open format: ‘ODT’. For 
best MS compatibility, choose Microsoft Word 
97/2000/XP (.doc) for your document in the Save 
As Type drop-down list. You can then send this fi le 
to people using Word without any problems.

3  Adobe PDF creation 
Writer can export a document as a PDF – Adobe’s 
widely used format. Either use the PDF button on 
the toolbar, or select Export from the fi le menu and 
‘PDF’ as the fi le format. You can check the quality of 
the output using Adobe Acrobat Reader.

Writer: insert images

1  Adding graphics 
You often need to insert pictures or clip art into 
your documents, and this can be done by selecting 
Picture > From File from the Insert menu. There are 
plenty of other formats that you can insert too, but 
images are the most common.

2  Size and position 
After the image has loaded and been inserted into 
your document, resize it by dragging the edges of 
the image. You can also drag the image through 
your document. The image toolbar will appear too, 
and this can be used to fi ne-tune the image.

3  Attractive layout 
To get text to fl ow around images, right-click on the 
image and select Optimal Page Wrap from the 
Wrap menu to position text. If the image uses a 
white background, try the Contour option to wrap 
the text around the details within the image. 

Writer: create labels

1  Label it! 
Sticky labels save labour and make things more 
legible generally. Writer has hundreds of label 
templates built-in for things like envelopes and CD 
cases; just start a new document of the type Labels 
by holding down the New button in the toolbar.

2  Select a type 
It’s an address above, but it could be anything you 
want labels for. Select the type of label that you 
want to make from the drop-down Type list in the 
bottom right of the Labels window, then enter the 
text for the label in the area on the top right.

3  Generate automatically 
Click New Document: the template governs how 
many labels are created – useful if you want to print 
a few pages of return addresses. You can even use a 
database of addresses and merge those into the 
document from the previous window. LXF
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