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pages, each of which are made from other Writer fi les. In the 
lingo of master documents, these are known as ‘sub-documents’. 
The advantage with using a master document is that you can 
manage things like the index, contents and page number across 
many different sub document from a single document. This is 
essential with larger projects. The most important thing to bare 
in mind though, is that all the sub-documents are well formatted. 
This means marking up your text using styles as we covered in 
the previous section. But there’s one important difference. You 
should only use the styles that are defi ned in the master 
document. If you imported sub-document does use styles that 
are also defi ned in the master document, then the styles in the 
master document are going to take precedence over those 
defi ned in the original document. This restriction is designed to 
give complete control over formatting of documents to the 
person in control of the master document. For a team of writers, 
this form of standardisation is essential, and it also means that 
the master document understand the context of the text within 
each document.

To create a master document, use the New File drop-down 
menu and select Master Document . The only immediate 
difference between the new master document window and a 
regular Writer window is the addition of a small fl oating pane 
called Navigator. This smaller window will contain a single entry 
labelled ‘Text’ and the fi rst thing you’re going to want to do is 
import a document or two to manage from the master 
document. This is accomplished through the deceptively small 
icon in the navigator window with a small green ‘plus’ symbol in 
it. Click and hold down this icon and select File. You will then get 
the regular fi le requester, and be able to select the Writer 
document you want to insert into the master document. You can 
add as many fi les as you want, and they will each be loaded into 
the main window behind the navigator. If you want to change the 
order of this fi les within the master document, simply drag and 
drop their names within the navigator window. You will notice 
that you can’t edit the documents you’ve loaded into the master 

If you’re going to write more than a few pages, learning a few of 
Writer’s more advanced features could save you hours of effort

 Advanced 
Writer

So, you’ve mastered the basics in Writer and can easily tap 
out an email, a letter to your bank manager, and even a 
lengthy report. You are now ready to tackle some of the 

more specialist functions that Writer offers to the power user. 
These functions are advanced only because they’re specifi c. You 
don’t need to be any kind of genius to use them, just ready to 
fi nd out some of the more esoteric and fi ne-tuned features that 
Writer has to offer. Even if you’re only ever planning to use Writer 
for letters, you’re still going to fi nd some of these features useful. 
And when you’re ready to write that one novel that’s inside 
everybody, Writer is the perfect choice to catch your words.

Master Documents
Another reason for moving onto some of Writer’s more advanced 
features is that you’ve started to use it professionally. Writer is 
more than capable of providing the backbone to writing for 
business, with features that will suite the strict criteria of 
technical writers, as well as more general offi ce use. One such 
important feature is the use of master documents. Master 
documents can be thought of as containers holding other 
documents. They’re widely used on large documents as well as 
by small teams working together on the same project. You can 
almost think of a master document as the cover that bind the 

 The radio buttons let 
you access drop-down 
lists full of options that 
will help you in writing 
your letter; thankfully, 
there’s no irritating 
dancing paperclip!

Hold down shift when pasting and you can choose the format of 
the pasted text. Useful to avoid embedding HTML in your 

documents by accident.

Quick tip
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document – this is because they’re inserted as read-only. This is 
where the single ‘Text’ entry in the navigator comes into play. 
Using this text section within your master document allows you 
to add text in between the sub-documents, and it’s also this 
small section you use to defi ne your own styles for the entire 
master document. If you need more text sections, they can be 
added using the same icon you used to add documents. If you 
want to actually change the source document, rather than add 
text to the master document, then you have to edit the original. 
You can do this from the navigator by double clicking on the fi le 
you want to edit. This will then be loaded into a new Writer 
window where you can make the changes you need. This should 
be enough to get you started with master documents, but you 
can fi nd much more information in the OpenOffi ce.org online 
help, including a useful tip that will change the heading style to 
add a page break, so that each of the documents you import into 
the master document start on a new page. 

Templates
Similar to master documents, but on a much smaller scale, are 
templates. These are the outlines of documents you might 
frequently want to create, such as press releases, family news 
updates or tax returns. The great thing about templates is that 
only a small part of them can be modifi ed when you’re fi lling in 
the details. This gives them more consistency and is great for an 
offi ce environment where you want all faxes and letters to use 
the same formatting. If you want to edit the layout, you need to 
edit the template itself. Fortunately, Writer includes many pre-
designed templates for you to use, as well as a helpful wizard to 
guide you through the data entry stage. 

The wizard can be started from the File menu by selecting 
the type of document you want to create from the Wizards sub-
menu. There are standard templates to create a letter, a fax and 
an agenda. Each wizard is slightly different, but they typically 

enable you to change the style of the template and the wording. 
With the Letter Wizard, for example, you can select between a 
business letter, a format personal letter and a simple personal 
letter. Each style uses different images and different language, 
and you can even fi ne-tune each style with a further drop-down 
list. Clicking the Next button in the wizard will let you add and 
modify the various components in the letter, such as the logo, the 
return address, the type of salutation used (selected from 
another drop-down list) and the complimentary closure for the 
letter. When you’ve fi nished skipping through the wizard, you’re 
left with the letter template. You now only need to enter the bare 
text that you want to write – the template should already have 
everything else. But this is also a regular Writer document, and 
you can edit any part of it as you would a normal document. You 
might want to scale the logo, change the image, move the 
address, remove the page numbering for example. And when 
you’ve fi nished, you might also want to save your own template 
for future use. You could just save the fi le without the text you 
want to write, but these fi les are easy to lose, and you might also 
forget you ever made it. Far better to save the document as a 
template. To do this, just select Templates > Save from the File 
menu. This will open a small window which lists the available 
templates, as well as providing a folder for your own. Type a name 
for your new template into the New Template fi eld, and click on 
OK. You can now load your new template at any time by selecting 
Templates and Documents from the New fi le button/menu. Your 
template will be listed, along with all the internal ones. If you need 
to delete this template at any time, just go back to the original 
templates menu and click on Organize. The Template Manager 
window will appear. Templates are just specially formatted fi les 
saved to a specifi c location on your hard drive. You can either 
update them from this window, or delete them from the drop 
down list on the left. Select the template fi le you want to remove, 
right-click and choose Delete. Choosing Edit will open the 
template as writeable into the Writer window, from which you can 
save your modifi cations.

Keyboard shortcuts
Ctrl + O  Open document
Ctrl + S  Save document
Ctrl + N  New document
Shift + Ctrl + N New document from template
Ctrl + P  Send document to printer
Ctrl + Q  Quit OpenOffi ce.org
Ctrl + X  Cut
Ctrl + C  Copy
Ctrl + V  Paste
Ctrl + Shift + V Choose paste format
Ctrl + A  Select all
Ctrl + Z  Undo
Ctrl + Y  Redo
Ctrl+F  Find and replace
Ctrl + Shift + F Repeat last search
Ctrl + Shift +J Fullscreen view
Ctrl + Shift + R Redraw
Ctrl + I  Toggle italics
Ctrl + B  Toggle bold
Ctrl + U  Toggle underline

 At this point, it is 
likely that you will need 
to use the Navigator 
window to import text 
from other documents 
with which to construct 
your master document, 
like letter heads or logo 
graphics for instance.

For NeoOffice 
running on Mac 
OS X, substitute 
the Ctrl key for 
the Option key.

The Template Wizard saves the your settings as you type 
them, so that they’re already in the correct fi elds the next 
time you run the wizard.

Quick tip

“Writer is more than capable of 
providing the backbone to writing for 
business, including technical writing.”
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Writer: page numbering

1  First footing 
Page numbers are easy to add to your documents; 
the trick is to add a footer to your document. This is 
a section of fi xed formatting that will appear the 
same on every page. Select Page from the Format 
menu to open the Page Style window.

2  On me header, son! 
You can add all kinds of things to documents from 
the Page Style window, like picture backgrounds 
and headers (the opposite of a footer); we need to 
switch to the Footer tab and click on the Footer On 
check box. This will add a footer to your document.

3  Number and text insertion 
The footer is now at the bottom of any page in your 
document. If you place the cursor in this section, 
anything you type here will appear in every page in 
the same place. Add page numbers by selecting 
Fields > Page Number from the Insert menu.

Writer: mathematical formulas

1  Formulas or formulae? 
As our example is a scientifi c report,, it’s fi tting to 
add a mathematical formula. OOo has a mini 
programming language for handling the 
complexities of formulas; the editor is launched 
from the Insert > Object > Formula menu option.

2  Insert the maths 
The editor fi lls the bottom half of your document 
window. Right-click in this area to add the various 
parts that make up a formula. You can format these 
any way you wish, and the formula will be inserted 
into the document as you make changes. 

3  Special commands 
Complex rules govern formula formatting; they’re 
listed in the OOo documentation. Special 
commands like newline will change the way 
formulas will appear; there are other commands 
for placing symbols anywhere you need them.

Writer: illustrate your words

1  Speaks a thousand words… 
Even if you don’t have an appropriate image to 
import into Writer, you can still draw your own. 
Click on the small Pen icon in the toolbar, and a new 
drawing toolbar appears at the bottom of the 
document window.

2  Predefi ned shapes 
Several icons in this toolbar draw pre-defi ned 
shapes; drag these out of the toolbar and onto your 
document. Change colours with the drop-down 
colour menu, and stretch the images with the 
handles at the edge of your illustrations.

3  3D lettering and more! 
Fontwork is a powerful three-dimensional font tool. 
Click on the briefcase icon and change the default 
text to whatever you need. You can change almost 
anything about the font rendering, from the angle 
and lighting to the material fonts are made from.
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Writer: custom dictionary

1  Get recognition for words 
You often have words you want to spell your way, or 
those that are too new for the dictionary. To add  
words to a personal dictionary, go Tools > Options 
menu, and select Writing Aids from the list of 
panels on the left of the window.

2  make your own dictionary 
Writer already includes several dictionaries. Click 
the New button to add your own. Select the 
language for your dictionary and also name your 
dictionary relevant to the words you want to add, 
then enable it in the list.

3  Add words to the dictionary 
When you fi nd a word you want to add, right-click 
on the word and select ‘Add’. Your dictionary is 
listed with those already included in Writer; select 
yours from the list. You can take your dictionary 
with you when you move to a different machine.

Writer: columns

1  Desktop publishing – almost! 
Writer isn’t quite a DTP app, but it’s not far off. You 
can create columns of text out of any selected area, 
for example. Highlight the area where you want to 
create columns, select Columns from the Format 
menu, and a large window with options will appear.

2  Layout options 
Choose how many columns you want from the 
icons in the top left, change the spacing and width 
between columns collectively or individually. A 
separator line can be drawn between them; choose 
the weight of this from a drop-down menu.

3  Toggle new choices 
Click OK to apply the changes to a selected region 
of text. Change settings by opening the Columns 
window while the cursor is in the same area of the 
document, or undo/redo to preview changes. Use 
columns to break up huge chunks of text.

Writer: special characters

1  Stop hunting, save time 
Don’t spend ages looking for key combinations to 
insert a Euro or Sigma symbol. Writer has a better 
option – a window that lists them all so you can 
insert it into your document. Choose Special 
Character from the Insert menu.

2  Special characters limited 
Special Characters are limited by the font you’re 
using. Switch fonts from the special characters 
window, this won’t guarantee correct output if you 
share a document with people without the font. 
Just click on the characters you want to insert.

3  Spoilt for choice 
Special Characters can be copied and pasted just 
like any normal characters, and they can also have 
bold, italics and underline applied to them. The only 
problem is in the number of characters you have to 
sift through to fi nd the one you need to us  LXF
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