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You’ve already seen how Base can help you 
organise your data with the minimum of 
fuss, but although it’s easy, pretty and 

powerful, Base does have some limitations. The 
most noticeable of these is the fact that your data 
is stored in a file on your computer, which makes it 
rather hard to share with other people. Even if you 
did share it with other people, how would you make 
sure that everyone can make changes at the same 
time? The answer is that you can’t – Base files are 
only really meant to be used by a single person at a 
time, which is fine for things like CD collections and 
other simple tables, but rather useless for 
important things such as company-wide systems 
or websites. 

For these kinds of solutions you need a real 
database server like MySQL, Oracle or Microsoft 
SQL Server. Usually these are much harder to use 
than Base, because you need to delve into the 
world of SQL and often use task-specific tools such 
as Oracle’s form designer. But Base is able to work 
as a front-end to all of these databases and many 
others, which means you get all the attractive and 
easy user interface help that Base brings, while 

Base is capable of interfacing with remote database 
servers such as the popular and free MySQL. Try it!

Project 5: Using 
MySQL with Base

 MySQL monitor: text-based, tricky to learn 
and easy to make mistakes – use Base instead?

1  User account 
Base needs a user account on your MySQL server in 
order to connect, read and write data, so fi re up your 
MySQL monitor as the root user – mysql -u root -p 
ought to do it if you’re hosting locally.

2  Grant privileges
If you don’t have a database already, run the 
command create database mydb. Regardless, 
run this command: grant all privileges on 
yourdatabasehere.* to youruserhere@localhost 
identifi ed by ‘yourpasswordhere’;

3  Flush it away
Now run fl ush privileges to ensure your account 
data is saved, then type exit. Now double-check 
everything worked by running mysql -u 
youruserhere -p – if you can connect, then you’re 
now ready to go!

also getting the advantages of storing your data on 
a dedicated database server.

In this project you’ll learn how to hook MySQL up 
to Base so that you can work with your current 
tables, but also create new tables using Base. You 
can also add some Base-specifi c stuff to the table, 
such as saved queries, forms and reports – all 
relying on your MySQL database. The nice thing 
about this link up is that the MySQL database server 
is still able to respond to normal requests – if you 
have a PHP site up, for example, that can be writing 
to the database while you’re working with it in Base. 
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Base: understanding MySQL

MySQL connects to Base using the JDBC access 
layer, which is short for Java Database Connectivity. 
This layer allows any Java-enabled program to 
connect to any Java-enabled database, which might 
sound like it opens up a world of possibilities, but 
actually it’s pretty limited. There are quite a few 
programs out there that can read databases using 
Java, of which Base is one of the better examples. 
But there are remarkably few databases around that 
are open to Java as standard, which is why you 
usually need to install a special connector: 
something that sits between your database and 
Java, translating JDBC instructions into database-
specifi c instructions. MySQL makes one of these for 
its own database, known as MySQL Connector/J, 
which translates JDBC instructions into MySQL 
server protocol in the same way that MySQL for PHP 
translates PHP functions into MySQL equivalents.

If you’d rather use a database other than 
MySQL, you’ll need the specifi c JDBC connector 

for the database you choose. Alternatively, if you’re 
on Windows, you can use ODBC to join Base and 
your database together – this is a non-Java 
database connection layer that has been around 
for quite some time. However, using ODBC requires 
you to know the precise name of your data source, 
so you will need some previous ODBC experience 
to get it working.

Choosing your data source
Apart from MySQL, Base is also capable of hooking 
up to Microsoft Access, Oracle, Adabas B and 
dBASE databases, as well as Microsoft’s proprietary 
ADO data access system and many others using 
JDBC/ODBC. For more specialist uses, Base can 
also connect directly to various apps that store 
address books, including Mozilla/Thunderbird, 
Microsoft Outlook, Windows Address Book and – 
for corporate address books – LDAP servers. But 
keep in mind that these have specialist uses: we 

wouldn’t recommend trying to write changes back 
to your LDAP server if you’re accessing it from Base.

Once you’re hooked up to your data source of 
choice using Base, you have two options: use Base 
as a dumb front-end reader for the data, or create 
customised local access methods. The fi rst option 
means that anyone with Base can connect to the 
server, and read data as much as they like along 
with countless other users – Base just acts like a 
fancy version of the MySQL monitor. But if you want 
to use custom access methods such as queries, 
forms and reports, you should know that these are 
saved into the ODB fi le rather than into MySQL – if 
you make changes to those using Base, they won’t 
be synchronized to the other users unless you give 
them a copy of your ODB fi le. So, if you intend to 
create a little database access system for desktop 
users to read from your database server, create it on 
your machine fi rst, get it right, then copy it to 
everyone who needs it.

1  Get Connector/J 
MySQL hosts the download for MySQL Connector/
J itself at http://tinyurl.com/ymt6rb – download 
the “Source and binaries” .zip fi le from there.

2  Extract to directory 
Once the zip fi le is down, extract it into a directory 
of its own. There are lots fi les in there, but the one 
you’re interested in is called mysql-connector-
java-5.0.7-bin.jar.

3  Basic functionality 
That .jar fi le contains the MySQL functionality to 
connect Base to MySQL, so you’ll need to create a 
directory on your hard drive called “classpath” (eg 
c:\classpath) and copy the fi le there.

4   Java option
Now start Writer, and choose Tools > Options from 
the menu, then look in the OpenOffi ce.org settings 
and click the Java option. On the right of this 
window is a Class Path button – click that.

5  Customisation 
This screen lets you customise which .jar fi les are 
loaded into Open Offi ce.org. First of all, click the 
Add Archive button, then select the .jar fi le you 
copied into c:\classpath.

6  Supported databases 
Shutdown Writer and any other OOo apps, then 
launch Base. When the wizard appears, choose 
Connect To A Different Database, then choose 
MySQL from the list of supported databases.

Base: how to link to MySQL
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7  Use default 
This screen lets you choose between JDBC and 
ODBC – JDBC is the default, so leave it selected 
and click Next to continue on.

8  Enter name 
Enter the name of your database and server here, 
but leave the MySQL JDBC Driver Class fi eld set to 
its default value. If your MySQL server is on the 
same machine as base, use localhost for the 
server URL.

9  Test class 
Before you continue, make sure you click the Test 
Class – this ensures that the MySQL/Java 
connection system is working. If all is well, you 
should see this message!

10   Username entry
Now enter the username you set up on the fi rst 
page, and make sure you tick the Password 
Required box. As with before, make sure you click 
the Test button to make sure everything is working

11 Remember your password!
MySQL will prompt you for the password for your 
user account – make sure you tick the Remember 
Password option, otherwise it will harass you for 
the password again later.

12 Start MySQL 
If Base connected to MySQL using the username 
you enter, you’ll get a confi rmation message here. If 
not, make sure MySQL is started and, if the server 
is remote, that it is confi gured to allow remote 
connections.

13 Back to Base 
Now you come back to the normal Base database 
confi guration screen – you can safely ignore these 
options and click Finish.

14 Store information 
Base will prompt you to save your database now. 
This is because Base stores all non-table 
information in its ODB fi le, as well as connection 
information to MySQL – you’re not actually saving 
the table data.

15 Connect to MySQL server
After all that work, you should fi nally be able to 
connect to your MySQL server in Base. Here you 
can see we have one table already created. In the 
future, just open the ODB fi le you saved.
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Base: SQL primer

Just so that you don’t overwrite any data by 
accident, we would recommend you only read 
MySQL tables rather than write them, which 
restricts your uses to queries, forms and reports. 
The idea here is that your existing data access 
systems – eg a PHP web site, or custom-coded 
data access programs – continue to write data 
normally, and Base can only read. If this mental 
safeguard weren’t in place, you might open up a 
table for viewing while someone else makes 

changes, then overwrite those changes by accident 
when you save the table! Base does let you write 
data if you want to, but be careful!

If you’re already a veteran MySQL user, you’ll 
almost certainly be used to work inside the 
command-line MySQL monitor application – it lets 
you “talk” to the server and get responses almost 
immediately. Well, don’t fret: Base has an 
equivalent system both for creating queries and for 
typing in general commands.

Saved SQL queries
OpenOffi ce.org lets you type queries freely by 
choosing the Create Query In SQL View option in 
the Queries tab. In fact, this is the same query 
editor we used back on p66 (the Advanced Base 
tutorial), just with the wizard parts hidden. For 
instance, let’s for the moment say you have the 
database “employees” with fi elds FirstName, 
LastName and Age. You could write a quick query in 
Base with this SQL, thus:
SELECT FirstName, LastName FROM employees 
ORDER BY Age;

When you save that query (yes, you have to give it a 
name), you can right-click on it in the queries view 
and choose Edit. Except when you back to the 
editing view you’ll be in the standard query 
designer view where you can see all the employees 
table in the top part and the fi elds you selected in 
the bottom. What’s happened is that OOo has 
parsed your query and converted it into its wizard 
display. In fact, any changes you make to the query 
in this design mode will be written back to your SQL 
– try choosing View > Switch Design Mode On/Off 
from the menu, and you’ll see your modifi ed SQL 
query.

Free-form SQL queries
Base also lets you run SQL queries in the fl y, but 
this is (usefully) limited to queries that write data 
rather than read. To try it out, go to Tools > SQL 
from the menu bar, then enter a query. If your 
query executes without error, you’ll see a 
confi rmation message in the lower part of the 
screen. But no matter what kind of query you run, 
Base won’t print out the results for you – which is 
why the free-form query window is rather pointless 
for SELECT queries! LXF

Now that Base and MySQL are linked together as one, you can push your 
database skills even further...

 Base lets you enter your own SQL queries directly into the interface, 
but don’t try it with SELECT queries because you’ll get no results back!

Multiple masters
If you’ve been using MySQL for any length of time, 
you’ll know that any SQL statement in MySQL is 
called a “query” - whether it reads data, writes 
data, deletes data, or whatever. In MySQL, these 
queries are one-off affairs that you can run as you 
please by typing in some SQL and seeing the 
results, but in Base a query must be saved then 
viewed. Working the MySQL is nice because you 
can rattle off queries as and when you need them, 
making changes where needed just by amending 
your SQL. 

But equally, the OpenOffi ce.org Base way of 
working has its own big advantage: any query you 
write gets saved so that running it again is just a 
matter of double-clicking it. Of course, it also 
helps that you don’t need to understand SQL to 
read results from Base queries!
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