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Every proud parent or intrepid traveller loves 
to share their pictures with their friends, 
family and just about everyone who stands 

still long enough. But the age of the plastic photo 
album is long gone: if people are going to sit 
through 200 slides of your trip to Bognor Regis, 
they at least want to see them in vibrant colour 
with some explanation of what’s going on. This is 
the perfect use for OOo Impress, because it’s a 
presentation tool at heart, and has lots of clever 
ways to make your slides be more exciting.

In this tutorial you’ll learn how to create a photo 
slideshow using Impress, and also how to add text 
and animations to the effects to make them a bit 
more interesting. All you’ll need to follow along are 
some pictures of your own – any will do, even the 
wallpapers you use for your computer’s desktop 
are good enough for testing.

Although we cover good 
presentation design on p64, there are 
a few quick tips you should know 
before creating a photo slideshow:

1  Let the pictures do the talking. You don’t need 
lots of words on the screen – restrict it to a place 
name or the names of people in the photograph at 
the most.

2  Use your pictures at the largest size you can. 
They are the most important thing in this 
presentation, after all!

3  Don’t use a garish theme. Darker, more subtle 
tones are less likely to class with the colours of 
your pictures. The exception to this is if your 
pictures share a common colour tone (eg blue if 
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they are pictures from a sailing holiday). In this 
situation, a nice blue slide theme would 
complement the pictures.

Finally, if you are already an experienced 
PowerPoint user, don’t just skip over this 
introduction – you might find a few hints and tips 
in here that will help you migrate to OOo Impress! 
The techniques shown here are common to all 
Impress presentations: you’ll learn how to create 
slides, assemble text and pictures, add animations, 
and build up a finished presentation from scratch, 
which are the real fundamentals of OOo Impress.

With that out of the way, let’s get started...

Learn how to make a slideshow of your photos 
using OpenOffice.org’s presentation tool...

1  Create a presentation
When you start OOo Impress for the fi rst time, the 
Presentation Wizard launches. The default option is 
to create an empty presentation, but it’d be 
benefi cial to have Impress do some of the 
groundwork for us at this time. So, change the 
selected option to From Template, then click Next.

2  Appearance choices
On the second screen of the wizard, you can 
choose how you want your slides to appear. The 
selection of themes available is pretty weak by 
default, so just leave it as Dark Blue with Orange. 
However, you should change the output medium 
option to the way you intend to show your 
presentation – we chose screen, because this will 
be shown on a computer. Click Next.

3  Animation effects
If you want to set a default slide animation effect, 
you can do that now. But we’d recommend leave it 
off – it’s best to add effects as needed, rather than 
as a rule. However, if you ever want to create an 
automated slideshow that moves from slide to slide 
without your input, you can set that here. For now, 
just click Next.

Impress: create a photo slideshow
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4  The opening slide
OOo Impress can create a very basic opening slide 
for us, just as a starting point. To utilise that, enter 
some text in the company name and presentation 
subject fi elds, then click Next. The Further Ideas 
box is rather pointless, so you can safely ignore it.

5  Wizard results
OK, the OOo Impress presentation wizard has 
fi nished, and has magicked up this simple – but 
remarkably ugly – presentation, and inserted some 
basic text for us. It’s a long, long way from looking 
good, but that’s OK – we can fi x that pretty quickly.

6  Colour changing
To change the title colour from salmon to white, 
click on it. A box appears around the text, to show 
it’s selected. Click and drag over the text so it’s 
selected, then look for a toolbar button with an A 
underlined in salmon colour. Click the down arrow 
next to that, and click the white colour palette.

7  Changes to the master slide
If you try deleting the lines at the bottom, you’ll 
notice you can’t modify them. That’s because they 
are in the master slide, so that they automatically 
appear in all the slides you create. To delete them, 
click View > Master > Slide Master, then click the 
lines with your mouse and press the Delete key.

8  Setting defaults
While you’re here, you might as well set the default 
title colour to be white – use the same procedure 
from Step 6. If you want to change the background 
colour, click Format > Page, then choose the 
Background tab and select a colour you prefer. 
When you’re done, click the fl oating Close Master 
View button to go back to the fi rst slide. 

9  Type in your title text
This fi rst slide is going to hold a bit of text about 
this presentation, so click on the default text (it’s 
“Linux Format” for me) and type in some text of 
your own. When you press Enter, Impress creates a 
new bullet point automatically.

10 Add a second slide
There’s only so much you can do with a single slide, 
so let’s add a second one: right-click in the Slides 
pane on the left of the Impress window, and choose 
New Slide from the menu that appears. This will 
have the basic layout from the master slide, so it’ll 
be dark blue with a title and some text.

11 Title tweaking
Change the title to be a one-line description of your 
fi rst picture, then click the Centre button from the 
toolbar. Now, drag a picture from your computer 
into the Impress window, and it will appear in the 
slide. You can drag around the green boxes on the 
edges to resize the picture.

12 Removing text boxes
If you look carefully, you’ll see a thin grey box 
around your picture – that’s the text box behind it. 
As we’re just showing a picture here, that text box 
isn’t needed, so you can either delete it by selecting 
it and hitting the Delete key, or you can just click the 
Title Only slide layout from the right – it’s the fi rst 
one on the third row of layouts.
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13 The more slides, the merrier
Now go ahead and add a few more slides, giving 
each one its own title and its own picture. Don’t be 
afraid to try some of the other layouts from the 
Layout pane, because it adds some variation. For 
example, why not try making every third slide have 
text and a picture on?

14 Transitions
That’s the basic presentation made, so let’s make 
the slides blend together smoothly to result in the 
presentation looking a bit nicer. To do that, click the 
fi rst slide, hold down Shift, then click the last slide – 
this selects them all. Now click the Slide Transition 
arrow on the bottom right of the window.

15 Live preview
Clicking an effect shows a live preview of how it will 
look. Here’s where most people go wrong: once you 
see the list of slide animations, people seem to love 
making every slide have a different transition, 
making ugly presentations. Keep it simple: scroll 
down the list of options and choose Fade Smoothly.

16 Preview your slideshow
As you selected all the slides before applying a 
transition, that transition gets used for all the slides. 
If you press F5, Impress will launch your slideshow 
so you can see how it works – click your mouse to 
advance through slides. This picture was caught 
half-way through the fade transition.

17 Adding animation
Now let’s add some animations to individual 
elements. Again, you need to keep your “Tack Alert” 
set to maximum: no one likes tacky presentations, 
so keep it simple! Select something you want to 
animate, then click the Custom Animation arrow in 
the right pane. Now click Add.

18 The Star Wars-style wipe!
The default option, Appear, is dull in the extreme, so 
change it to Wipe. As with slide transitions, Impress 
automatically previews object animations so you 
can see how they will look – this is how the Wipe 
animation looks part-way through. Click OK to add 
the animation.

19 Wipe direction
The default wipe animation is set to From Bottom, 
meaning that the wipe moves from bottom to top. 
Click the “...” button to the right of that selection 
box, and a new window will appear where you can 
customise the animation.

20 Text animation options
From this window, change the direction to be From 
Left, then go to the Text Animation tab and choose 
By 1st Level Paragraphs for the Group Text option. 
This should make the text appear on screen one 
bullet at a time.

21 Precise adjustment
When you click OK to save the changed effect, you 
should see the single animation break into multiple 
smaller ones in the Custom Animation pane – one 
bullet for each line in your text box. This lets you be 
more precise if you need it.
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22 Text preview
Now that your presentation is done, you can 
preview all the text at once by switching to the 
Outline tab. These tabs are just above the slide 
layout, and you’ll be in Normal by default. The 
outline view lets you see your slides at a glance, as 
well as make changes if you want to.

23 Save your presentation
And now, you’re done: it’s time to save your 
presentation so that it’s safe on your hard disk. 
Click File > Save, then enter a fi lename. Remember, 
if you’re using OpenDocument Presentation fi le 
format (.odp fi les), Microsoft PowerPoint users 
won’t be able to view your work!

24 Convert to Adobe Flash
Impress can save your presentation as an Adobe 
Flash fi le; it doesn’t save any of the transitions, but 
it does store all your text and pictures, which makes 
it perfect for distribution to other people. To save as 
Flash, click File > Export, then choose Flash from 
the list of supported formats.

W e’ve only scratched the surface of OOo 
Impress in this short primer, but you’ve 
managed to make a slide show using a 

master slide, pictures, transitions and animations, 
and even exported it to Flash format! That’s not 
bad going for the work of 30 minutes, but there’s 
lots more you can do with this presentation if you 
want to learn through a little exploration – here are 
some ideas to get you started...

 Edit the master slide to make it more 
interesting. A plain dark-blue background gets no 
one excited – why not try some of the drawing 
shapes (see the toolbar at the bottom) to see if 
you can add a few dark boxes to break up the 
background a little?

 Add some other media to your slides. We’ve 
only looked at pictures here, but Impress can 
handle movies and sounds just as well. In fact, you 
can even add sounds to your animations, but the 
effect is usually quite off-putting!

 Impress gives your slides numbers for their 
names by default; it can be hard to remember 
which slide is which. But if you right-click on a slide 
you can rename it. This is useful when you’re in the 
middle of a presentation – you can right-click on 
the screen and jump to a slide by its name.

 Made a slide you’re particularly happy with? 
See if you can figure out how to duplicate it, then 
modify the duplicate.

 Make your slideshow automated so that it 
changes slide every 10 seconds. In our examples, 
all the transitions and animations happened 
through a mouse click, but if you were looking 
carefully through the options you would have 

noticed that Impress lets you activate transitions 
after a set time passes.

 The Color/Grayscale option under the Edit 
menu lets you preview selected slides in either 
colour (the default), grayscale or plain black and 
white. Can you think of when this would be useful?

 Experiment with style options. As with Writer, 
Impress has its own range of styles to choose from. 

Going further
These affect the way the text appears, but also 
how indented it is on the screen (ie how important 
it is). Choose carefully!

So, that’s you all up to speed with OOo Impress, 
but if you want to push your presentation skills 
further there’s more to come – read on to see how 
Impress can help you with business presentations, 
and also read our top tips for giving the best 
presentations! LXF

“In the middle of a presentation, 
right-click on the screen and jump 
to the slide of your choice."
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