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1  Styles on your keyboard
Diffi culty: Hard It’s one thing spending time 
adjusting the OOo styles to fi t your needs, but it’s 
quite another to be bothered to apply those styles 
everywhere they are needed! And admittedly it’s a 
bit of a pain to take your hands off the keyboard, 
point and click your mouse on a style, then carry on 
typing, so it might be surprising that OOo doesn’t 
allow keyboard shortcuts for styles. But here’s the 
thing: it does let you apply keyboard shortcuts, but 
it takes a bit of hacking. First, set up your styles just 
as you want them. Then go to Tools > Macros > 
Record Macro, and click the style you want to apply. 
Now click the fl oating Stop Recording button and 
save your macro as “ApplyingStyleXYZ” (you can’t 
use spaces in your names, remember!). You’ve 
basically made OOo write a little program to apply 
that style for you. Now for the magic: click Tools > 
Customize, select the Keyboard tab, then scroll 
down the list of shortcut keys until you fi nd one you 
like, eg Ctrl+Shift+A. In the bottom part of the 

window, choose OpenOffi ce.org Macros > user > 
Standard > Module1 from the Category list, then 
you should see your macro name appear in the 
Function list. Choose that, then click Modify – this 
assigns the selected macro function to the selected 
shortcut key, essentially making Ctrl+Shift+A apply 
your style immediately.

2  Per-word spell checking
Diffi culty: Medium This is another powerful OOo 
feature that’s hidden away in an unlikely place: per-
word spell checking means that you can mix and 
match languages in a single document, and, as long 
as you tell OOo which languages the words come 
from, it will spell-check them all at the same time. 
To set up a specifi c language for a word, sentence, 
paragraph or other section of a document, select 
the text you want to change then choose Format > 
Character from the menu. Under the Font tab of 
the window that appears, look for the Language 
selection box, and change it to whatever you want!

3  Quick picture fixes
Diffi culty: Medium Sooner or later you’ll fi nd 
yourself working in OOo and struggling with an 
image. Maybe its colours aren’t quite right, or it’s 
not sharp enough – it doesn’t matter, because OOo 
has simplifi ed image editing functionality built in, 
located under the Picture toolbar. If you don’t see 
the Picture toolbar when you drop a picture in your 
document, try choosing View > Toolbars > Picture 
from the menu. This toolbar has a small selection 
of fi lters (Sharpen, Blur, etc), but the most 
important bit of it is the Color dialog – its icon is a 
small rainbow with a hand over it. This lets you 
adjust the red, green and blue parts of your picture, 
but also the brightness, contrast and gamma 
values – it’s perfect for making quick tweaks!

4  Uninstall before upgrade
Diffi culty: Easy Although we’ve included a recent 
version of OpenOffi ce.org with this guide, the OOo 
developers release new versions quite frequently – 
usually at least once a month. These versions come 
in three main varieties: major releases (eg 1.0, 2.0 
and 3.0), minor releases (eg 2.1, 2.2 and 2.3) and 
point releases (eg 2.2.1, 2.2.2 and 2.2.9). Major 
releases contain the most new functionality, 
whereas point releases add nothing except bug 
fi xes and security updates. However, regardless of 
what version upgrade you install, it is generally 
recommended that you uninstall your current 

You’ve mastered the basics, now it’s time to acquire 34 good habits to work 
more effectively – get more from Writer, Calc, Impress and Base right away! 

Tips and tricks
OpenOffi ce.org suite

 If you installed OpenOffi ce.org using a Linux-
based package manager, there’s no need to 
uninstall it before upgrading.

 OOo checks all your words in your default language, but you can 
specify other languages for specifi c words, sentences and paragraphs.
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Diffi culty: Easy If you’re a happy OOo convert 
and want to see what others are doing with it, can 
we recommend you investigate OxygenOffi ce 
Professional fi rst? It’s a free rebuild of 
OpenOffi ce.org, except it merges in clip art, 
photos, templates, fonts and more – all for free. If 
you’d like to learn more and download it for 
yourself, go here: https://sourceforge.net/
projects/ooop/.

8  Get graphical!

 Once you’ve grown tired of OOo’s built-in 
selection of graphics, give OxygenOffi ce a try 
– it has much better clip art and photos on 
offer for Windows, Mac OS X and Linux!

release of OpenOffi ce.org before installing the new 
one – make sure and backup your fi les fi rst, 
though! The exception to this is if you installed 
using a Linux package manager, because you can 
use that to upgrade OOo without removing the 
current version fi rst.

5  Fancy FontWork
Diffi culty: Easy WordArt is the Microsoft Offi ce 
system for drawing fancy text in documents. Well, 
we say “fancy”, but really WordArt tends to be 
overused, and, let’s face it, no matter how you 
report Year End Revenue Report for FY06/07, it’s 
still going to put people to sleep!

Still, if you’d like to try the OpenOffi ce.org 
equivalent to WordArt, you should look for 
Fontwork – try going to View > Toolbars > Fontwork 
to bring up the toolbar. Click the small “A in a box” 
icon to choose what kind of Fontwork design you 
want to add to your document. Once added, 
double-click the text and replace the default with 
something else to see how it looks. Fontwork has 
some pretty impressive advanced options, 
including the ability to render fonts in 3D with 
accurate lighting! But remember this all needs to 
be weighed up against the question: is this piece of 
Fontwork actually making my documents more 
useful, or does it just look pretty?

6  Embedding complex objects
Diffi culty: Hard Reading through this magazine 
you’ll have seen how you can insert various types of 
media into your documents, but you might not 
have realised just how much media OOo supports. 
For example, did you know that you can embed live 
Java applets into an OOo document? It sounds 
crazy, but it’s true! Look under the Insert > Object 
menu to see a list of available media, but 
remember: most of those object types won’t 
appear when printed, so choose carefully!

7  Re-use good-looking 
templates
Diffi culty: Easy No matter how good you are with 
OOo – and let’s face it, if you’ve made it this far, 
you’re pretty darn hot – there’s always going to be 
someone better than you out there. Fortunately, if 
they send you a document with neat styling and an 
attractive layout, you can have a look in their 
document to see if they used a template, and 
download it yourself if they did! When people use a 

template for a document, it automatically shows up 
at the bottom of the File > Properties dialog. 
Sometimes you might also fi nd a telling comment 
in the Description tab of that same dialog box, so 
make sure and check it out!

9  Skip the branding
Diffi culty: Hard Sick of the way you get a splash 
screen every time you open an OOo program? Well, 
if you can fi nd the OOo confi guration fi le on your 
computer, you can disable it. Windows users should 
fi nd the confi guration fi le in their OpenOffi ce.org 
installation directory, under the ‘program’ 
subdirectory – look for soffi ce.ini. Linux users 
should look for the soffi cerc fi le. Open that using 
your text editor, and change this:
Logo=1

...to this...
Logo=0

OOo will now load faster, and take up less screen 
real estate while it loads – winner!

10 Make OOo feel like home
Diffi culty: Easy OpenOffi ce.org has more than 20 
toolbars full of buttons to press, values to change 
and thinks to fi ddle with, but most of them are 
hidden by default. If you fi nd there’s a particular 
feature you use regularly, try enabling the relevant 
toolbar – you might fi nd it fl oats by default, but if 
you grab a fl oating toolbar and drag it over the 
other toolbars, you can position it to be part of the 
main OOo window. Don’t over overkill, though – if 
you enable all the toolbars, OOo becomes rather 
hard to use!

11 Getting the most from PDF
Diffi culty: Medium A lot of people think of PDF as 
being “virtual paper” - it stores a picture of what a 
document ought to look, then prints it out. This 
isn’t strictly true: PDF contains a simple computer 
language that understands how to lay things out on 
a page, and the graphics are just stored as scalable 
vectors to save space. When you export to a PDF 
fi le, we recommend you at least look at the 

following four options:
1  Lossless JPEG compression JPEGs are by 

default “lossy”, which means they look OK in 
pictures, but as you ramp up the compression 
levels to save more space, the pictures look worse 
and worse.
2  JPEG compression is specifi ed in per cent, 

meaning that 100% means “use the original 
picture”. 90% is fi ne for most purposes.
3  Export Notes. If your notes are for internal use, 

you almost certainly don’t want them appearing on 
the PDF, so make sure this option is turned off.
4  Encryption. This is enabled under the Security 

tab, and lets you set a password that users must 
enter before they can read the document.

 Calc with all its toolbars enabled and neatly arranged: it’s usable, but why would you want to?

 Fontwork: a little restraint goes a long way.
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12 Easy Lorem Ipsum
Diffi culty: Easy OK, here’s a quickie for you: if you 
want to add some dummy text to your page, type 
“dt” (without the quotes) and press F3 – it’s not 
quite the traditional lorem ipsum text that 
publishers normally use, but it fi lls the gap nicely 
and should make your page look pretty complete. 
Note, though, that the dummy text OOo provides is 
real English text rather than a page full of XXXs – if 
you’re not careful it might easily be confused with 
fi nished text, and might get printed!

13 Fine-grained protection
Diffi culty: Medium You’ve probably already 
noticed that OOo can protect your documents with 
passwords, but did you know it also have much 
more fi nely grained protections available? Well, it 
does – but it’s hidden so cleverly that most people 
don’t know it’s even there. In Writer, you can make 
individual words password-protected if you really 
want to, although usually this facility is reserved for 
protecting whole paragraphs. When you lock down 
a paragraph in this way, the rest of the document 
remains editable by anyone – it’s only the 
protected section that becomes read-only – very 
handy for business documents. To add protection, 
select the text you want to keep safe and click 
Insert > Section. Under the Write Protection header 

options, choose Protect and optionally also choose 
With Password – and that’s it.

14 Make your spaces 
unbreakable!
Diffi culty: Easy To stop OOo wrapping your text at 
the end of a line, try inserting non-breaking spaces by 
holding down the Control key (Command on OS X) 
before pressing space. For example, if “Hello World” 

OpenOffi ce.org Writer

 The Styles and Formatting window has some 
page styles defined by default, such as index 
pages, left/right pages and first pages. Make sure 
you know what they are and how to use them!

appears at the end of a line, “Hello” will appear on the fi rst 
line and “World” will get pushed onto the second line. 
Adding a non-breaking space to that means that “Hello” will 
always be on the same line as “World”, even though there is 
a space between the two. Magic!

15 Add custom link text
Diffi culty: Medium Here’s one that annoys even the 
most veteran of OpenOffi ce.org users: when you type a 
link into OOo, it automatically turns it into a clickable 
hyperlink. So how can you go back and change the link 
text to something other than the URL? Most people try 
clicking on the link in various different ways, but all that 
usually does is open the link in your browser several 
times! The smart way to do it is to look down in the Writer 
status bar – do you see about two-thirds of the way to 
the right of the screen, it says “HYP”? Click that, and it 
will change to “SEL” – you can now select the text of 
hyperlinks and modify them to read whatever you want. 
Just click SEL again to go back to HYP mode.

16 First page headers
Diffi culty: Medium Ever found you’ve managed to get 
the styles for your Writer document just right, only to 
think “darn, I wish I could make the front page look a bit 
different to the others...”? Well, now you can! The Styles 
and Formatting window (press F11 to show or hide it) 
splits its styles up into various categories: Paragraph 
Styles, Character Styles, Frame Styles, Page Styles and 
List Styles. The Page Styles list can be accessed by 
clicking the fourth button in the Styles and Formatting 
window. The default page style is called Default, 
cunningly enough, but you’ll notice there’s also a First 
Page style in there that you can adjust to fi t your needs. 
To apply the style, place the system caret (that’s the 
name for the fl ashing text entry bar) on your fi rst page, 
then choose the First Page style. Your other pages should 

 You can set a password on an entire Writer document, or just one small part so that 

people can edit most of the document, but not the parts you specify.
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retain the Default styling, but if they don’t just 
select them all and choose Default.

17 Working with textual tables
Diffi culty: Medium If someone sends a table of 
data to you in text format, either as part of an email 
message or by using the plain-text .txt format, you 
need to call on OOo’s data conversion tools to help 
you out! OOo can convert text into tables 
depending on what characters are used to separate 
the data. To try it out, select your plain-text data 
and choose Table > Convert > Text To Table. This 
will prompt you to choose whether your data 
includes a header fi eld, whether it needs to be 
formatted, and so on – you can just ignore that. You 
can also create text from a table by reversing the 
operation, which is particularly helpful if you want 
to rearrange data quickly.

18 Back to imperial
Diffi culty: Easy Perhaps owing to its roots as a 
German offi ce suite, OpenOffi ce.org defaults to 
using centimetres for all its measurements in all its 
tools. If you’re more of an imperial measurement 
afi cionado, don’t fret: you can cast off OOo’s metric 
horrors and replace them with a measurement unit 
of your own choice – go to Tools > Options > 
OpenOffi ce.org Writer > General, where you’ll be 
able to dump centimetres forever!

19 Help the widows and 
orphans

 

Diffi culty: Hard OpenOffi ce.org, like most 
programs, has a Find & Replace dialog box that 
lets you search for one value in your text and 
replace it with another. Fair enough – that’s a 
pretty common feature. But OOo also lets you 
Find & Replace by style, which means you can say 
thing like “fi nd me all paragraphs with the style 
‘FizzBuzz’ and change them so they use the style 
‘Whizzbuzz’ right away!” You can also use the 
Find & Replace dialog to search for text using 
regular expressions and other advanced 
searches, but they are defi nitely out of this book’s 
remit! To search and replace by style, go to Edit > 
Find & Replace, click More Options, then choose 
Search For Style.

20 Style police

 Search and replace text, or, with a few extra 
clicks, styles – choose one old style you don’t 
want any more, and OOo will replace it with a 
new style for you!

 Writer uses the power of the OpenOffice.
org database application Base to manage the 
bibliography references within your documents.

Diffi culty: Easy There are two things that make 
magazine proofreaders pull their hair out: orphans 
and widows, and speeling erors. OK, so there are 
three things that make them pull their hair out. And 
late text arriving from writers. And stale style 
guides. And art staff’s inability to make the page 
design more fl exible to accommodate the written 
content. And... well, OK – all sorts of stuff makes 
them angry, but lets deal with the orphans and 
widows for now! An orphan in the publishing world 
is any word that appears on a line by itself at the 
end of a paragraph, and a widow is a part of a 
sentence that fi nishes a paragraph that runs over 
to the start of a new page or column – or indeed a 
title without any text beneath it, like the one for this 
very tip! Both look bad, but rather than making 
creative use of empty line breaks, you should let 
Writer do the hard work for you – go to Format > 
Paragraph > Text Flow, and make sure Orphan 
Control and Widow Control are both enabled.

21 Book page numbering
Diffi culty: Medium If you’ve tried adding page 
numbers to your document, you’ll have found that 
it’s pretty easy to make them appear in the bottom-
right-hand corner of each page automatically. But 
while that’s fi ne for stacked pages, what about if 
you want to show your document as if it were a 
book or a magazine, where there’s a left-hand page 
and a right-hand page? Yes, the easy fi x is just to 
make the page numbers centred, but a smarter fi x 
is to use the Left Page and Right Page page styles in 
the Styles and Formatting window. To get fully 
automatic results, modify the Left Page style so 
that the next page style chosen is automatically 
Right Page, and vice versa. To do that, right-click a 
style, choose Modify, then set the Next Style option 
under the Organizer tab.

 Make Writer take care of orphans and widows 
for you automatically by changing your paragraph 
text fl ow settings.

“OpenOffice.org lets 
you Find & Replace 
by Style, which 
makes formatting of 
documents a swift 
and straightforward 
process compared 
with having to do it 
all by hand.”
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OpenOffi ce.org Impress
27 Knock out the background
Diffi culty: Easy The business presentation we 
showed you how to make back on p54 had white 
text on a black background, which looks quite 
stylish on screen. But when printed, it looks poor – 
and wastes a huge amount of ink, too! So, when 
printing these kinds of slides, may we humbly 
recommend you try changing the print quality to 
black and white inside OOo? This forces Impress to 
use a white background with black text, overriding 
whatever values are used in the presentation.

28 Never-ending slideshows
Diffi culty: Medium You can get great impact from 
your presentations without even being there to 
present them! OOo Impress can automatically 
move between slides after a given time limit, and 
can even auto-loop your presentation with a delay 
at the end so it’s not repeating 24/7. To make slides 
transition automatically, change its Advance Slide 
option from the Tasks pane to read “2 sec”, then go 
to Slide Show > Slide Show Settings and set the 

 Sick of talking in front of an Impress presentation? Use the 
automatic slide changing system to present your talk without you!

OpenOffi ce.org Calc

spreadsheet that tracks the last 1000 days of 
employee absency for your 1000 employees, that’s 
a lot of data to have to check through by hand if 
someone asks the question “can you tell me how 
many days were taken off sick in total?” And yet 
Calc jumps to the rescue with the magic 
COUNTBLANK() function. To use this, just specify 
the cell range Calc should count, and it will return 
the total number of cells in that range that had no 
value provided. For example =COUNTBLANK(A1:
J10) will count all the rows and columns between 
A1 and J10 to see how many blanks there are.

24 Keep a note of it
Diffi culty: Easy Both Writer and Calc support a 
‘notes’ system where any document editor can 
leave little messages to others embedded into the 
documents. For example, a note in Writer 
automatically embeds your text as a small yellow 
box in the document – hovering over it shows the 
contents of the box in brief, whereas double-
clicking reveals all the text and lets you change it if 
you want to. In Calc, the note taking system is a bit 
more immediate – as soon as you click Insert > 
Note you’ll be prompted to type some text into the 
note. Notes in Calc are marked with a tiny little red 
colour in the corner of an annotated cell – just 
hover your mouse over there for a second or two 
and the note will appear.

25 Making a # of it
Diffi culty: Easy So, you’ve spent hours fi nely 
crafting your spreadsheet to factor in every 
possible expense for the next ten years. But 
suddenly some of your rows change from healthy 

values to be “###” - what could be wrong? Don’t 
worry, your data is safe – OOo shows ### 
whenever the size of a cell’s contents are too big to 
fi t into the assigned cell. To fi x it, just drag that cell’s 
column header so that it has more space, and you 
should see its normal number in there just fi ne.

26 Choose your alignment
Diffi culty: Easy The key to making your Calc 
sheets look perfect is to take full advantage of 
OOo’s feature set. For example, if you have one 
long, thin column that contains the occasional 
heading (eg January, February) for sets of rows, the 
best way to show that data is to have the month 
heading rotated vertically so it sits directly 
alongside the cells it’s referring to. To make that 
change, go to Format > Cells > Alignment, enter 90 
into the Degrees box and click OK.

22 Decoding messages
Diffi culty: Medium Your computer: “Error 
513: String overfl ow.” You: “What? I’ve 
installed dictionaries for 100 different 
languages and that’s the most helpful text 
you can give me?!” Yes, OOo’s error 
messages are cryptic to the extreme, with 
Calc’s being a particularly grim example. But 
never feature: your built-in OOo 
documentation has a complete list of error 
codes for your reference, should you ever 
succumb to one. But we hope you don’t...

23 Spot the blanks
Diffi culty: Hard Computers can fi nd, sort 
and juggle data easily enough, so it’s no 
surprise that they can also perform some 
visual inspections of data to make that even 
faster. Take Calc, for example. If you have a 

 Enter a text rotation value into the Degrees box, 
or just drag the dot around the circle to get a 

quick preview of how the text will turn.

 Search Calc’s help for “error codes”, then 
choose ‘list of’ to see plain-English translations 
of Calc’s error code numbers.
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34 Knee deep in SQL
Diffi culty: Medium Creating tables and queries 
using the designers and wizards is all very well if 
you are a desktop user without much in the way of 
requirements, but if you’re a demanding server 
admin who wants to treat Base as nothing more 
than a pretty front-end to your database server, the 
SQL view is perfect for you. To get to this, go to 
Tools > SQL from the Base menu bar, and you’ll be 
prompted to enter your SQL queries. You do know 
SQL, right? If not, this isn’t really the right place for 
you! This view is generally only for people who have 
SQL queries they made elsewhere and want to 
import into OpenOffi ce.org without having to use 
the fussy query editor.  LXF

OpenOffi ce.org Base

Type to be auto. That last part is the amount of time 
Impress ought to wait until it accepts a new client.

29 Grid lock
Diffi culty: Easy After using Impress or Draw for a 
few minutes, you’ll already have noticed that all its 
shapes are naturally placed onto invisible grid lines 
so they line up neatly. Well, if you’d like to see that 
grid so you know what OOo is up to, right-click on a 
blank area of your document, and choose Grid > 
Visible Grid. You’ll also see the option in there for 
disabling grid support if you really hate it!

30 Printing your handouts
Diffi culty: Easy Obviously worried that it wasn’t 
been as confusing as its OOo siblings, Impress 
makes it remarkably tricky to print out handouts 
without also printing out full copies of your slides. 
The magic options to fi x this annoyance lie under 
the File > Print menu – click the Options button, 
then disable Drawing and enable Handouts from 
the Contents menu. Yes, you can also override the 
colour option here to get black and white (see tip 
number 27).

 Aligning objects isn’t easy to do by eye, but if you turn on the grid in Impress or Draw as shown here, 
you’ll be able to see exactly where things are on the screen in relation to one another.

Diffi culty: Easy If you want to distribute some 
shapes equally over a drawing or an Impress 
presentation, select all the shapes, right-click and 
choose Distribute. The Horizontal – Center 
option should do what you’re looking for!

29 Lost in space

32 Toggle slide visibility
Diffi culty: Easy We’ve already seen how easy it is 
to create custom presentations showing off all of 
your slides except the few you’re not happy with. 
Well, if you want to remove a slide without out-right 
deleting it, here’s an even easier solution: select the 
slide(s) you want removed, then click Show/Hide 
Slide from the main menu.

33 Hang up some wallpaper
Diffi culty: Easy Irrespective of the way your slide 
design works with your master, you can override 
the master and customise your background colour 
until you heart is content! If your master has no 
background of interest, you can change the current 
background colour to fl at colours, cros- hatching or 
even a texture by using the Format > Page > 
Background menu. Textured wallpapers might look 
kinda cool at fi rst, but remember that you’ll be 
layering text over the top of it, and you want your 
presentation to look professional!

 If you’re using Base as a front-end for SQL or 
another database, you’ll need some additional 
knowledge beyond the scope of this guide.

“Still worried about giving that important 
presentation at work? Use our five steps to 
success on p58 and it will go just fine!”

 Textured slide backgrounds: good for you if you 
own shares in an opticians; otherwise, avoid them, 
and your audience will thank you heartily for it!
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