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Chapter 1
About Surround SCM

You have an important job to do - deliver a quality product on time and within budget. And, whether 
you are developing, testing, fixing bugs, or managing the team, you do not have time to learn another 
complex application.

Surround SCM manages all of your team’s digital assets, including source code, requirements 
documents, Web pages, image files, specifications, and more. With Surround SCM, your team can 
archive and version virtually any file and quickly locate and retrieve it at any time. Surround tracks 
who, when, and what changed for every revision, so you can always retrieve the best version of a file.

About the guide, 2

Documentation conventions, 2

Contacting Seapine support, 2
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About the guide
This guide provides step-by-step instructions for all the tasks you perform when working with Surround 
SCM. This guide is not necessarily meant to be read from start to finish. It includes information for users, 
and administrators, at a variety of levels. To get the most out of the documentation, start by reading the 
chapters that are most relevant to your use of Surround. Admin-related tasks are clearly marked.

Documentation conventions
There are a few conventions used throughout the guide that are designed to be completely predictable – 
making it is easy to understand what you are reading and what you’re supposed to do.

Many of the commands are available from menus, toolbars, shortcut menus, and shortcut keys. 
Throughout this guide, most commands are explained using the menu commands. As you become more 
familiar with Surround SCM, you may find shortcut menus and shortcut keys more efficient to work 
with. When you are instructed to select a menu command, you will find the menu name, followed by an 
arrow. For example, to add a defect, choose Activities > Get. Indented text is also used to draw attention 
to notes, tips, examples, etc.

Contacting Seapine support
Telephone: 513-754-1655

Email: support@seapine.com

Web site: http://www.seapine.com

Note:  Check our web site for the latest news and updates. You can also find help in our 
Knowledgebase!

Documentation feedback
Seapine Software welcomes your feedback on the documentation included with this product. If you have 
comments or suggestions about the documentation, please email: documentation @seapine.com. This 
email address is provided for documentation only. You may not receive a reply to your email. For 
technical questions or support, contact support@seapine.com.

© Copyright Seapine Software, Inc. 1996-2003

mailto:support@seapine.com
http://www.seapine.com
http://www.seapine.com
http://www.seapine.com/kb.html
mailto:documentation@seapine.com
mailto:support@seapine.com
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Chapter 2
Getting Started

After installing and starting Surround SCM take a few minutes to set user options, customize the 
main view, and change your password. You can also configure email notifications and set the 
working directory.

Customizing the Source Tree view, 4

Using the file details pane, 5

Filtering the files pane, 7

Listing files recursively, 7

Changing your password, 8

Setting general options, 8

Setting diff/merge options, 10

Setting view and edit file options, 11

Setting file dialog default options, 12

Setting source tree refresh options, 14

Configuring email notifications, 14

Setting the working directory, 17

Working directory editor, 18



4 Chapter 2
Getting Started

Customizing the Source Tree view
The Source Tree view displays information in a column format. You can customize the view and set up 
the columns to display the information you need.

Adding columns
You can customize list windows and add columns to display the information you need.

1 Right-click the column you want to add a column next to and select Insert Column.

An empty column is inserted.

2 Right-click the new column and select a field from the shortcut menu.

3 The column is added.
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Changing column contents 
To change column contents select a new field for the column.

1 Right-click the column heading you want to change.

The shortcut menu lists all the available fields.

2 Select a field from the menu.

The column heading changes to the field name and the selected field contents are displayed.

Changing column widths
1 Move the cursor to the divide bar located between the column headings.

The cursor changes to a resize cursor.

2 Click and drag the divide bar to change the width of the column to the left of the divide bar.

Sorting columns
1 Click a column heading once to sort ascending.

The column contents are sorted in ascending order. An up arrow is added to the column heading.

2 Click a column heading again to sort descending.

The column contents are sorted in descending order. A down arrow is added to the column heading.

Removing columns
1 Right-click the column heading you want to remove.

2 Select Remove Column from the shortcut menu.

Using the file details pane
The Surround SCM file details pane provides a convenient way to work with files and access file 
commands. It displays the selected file’s properties, history, check out status, and sharing information.

1 Choose View > File Details Pane to view the file details pane.
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2 Select a Surround SCM file.

The File Details Pane is populated with the corresponding information.

3 Click the Properties tab to view file property information.

This tab includes the following information: Branch, File, Size, Latest version, Last modified, Last 
checked in, File type, Status, Locked by, and Check out location.

4 Click the History tab to view a source file’s history and work with a historic version of the file.

You can view file details, get or check out a file, create a label, select two version of a file to see 
differences, and view or edit the file. You can also filter the history to display specific files. For more 
information see Viewing file history, page 83.
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5 Click the Check Out tab to view the check out information.

6 Click the Sharing tab to view shared file information.

Filtering the files pane
You can filter the SCM files list to display all files, all checked out files, your checked out files, or files 
checked out by a specific user. 

1 Select a filter from the menu.

Files that meet the filter criteria are displayed. The filter remains active, even if you select another 
mainline branch or repository. To view all files, select All Files from the Filter menu.

Listing files recursively
1 Select List recursively to recursively display all files in the selected repository and subrepositories.

All files are displayed. This option is helpful if you want to view all subrepository files together. 

Note:  For example, your Code repository includes 12 subrepositories. You need to view 
the files that JoeDeveloper has checked out from the repository and the subrepositories. 
Select Files Checked Out By User from the filter menu. Choose JoeDeveloper as the user. Then 
select List Recursively. All files JoeDeveloper checked out from the Code repository and the 
12 subrepositories are displayed.
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Changing your password
1 Choose Tools > Change Password.

The Change Password dialog box opens.

2 Enter the current password.

3 Enter the new password.

4 Confirm the new password. You must re-enter the new password.

Click OK to save the new password.

Setting general options
You can set user options to help you work more efficiently. For example, you can automate the process 
of logging in to Surround SCM.

1 Choose Tools > User Options.

The User Options dialog box opens with the General tab selected.
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2 Set the Server Connection options.

Select Always connect to this server and enter a server name and port number to automatically connect.

Select Always login with this username and enter a username and password to automatically login.

Note:  These are the same options you selected in Setting up server connections, page 23. 
Server connection settings can be selected using either dialog.

3 Select Enable compression of file transfers to compress data during file transfers.

Compress files if you have a slow connection to the Surround SCM server (e.g., connecting to the server 
via an ISP). Take the time to “play” with this option. Compression works best on certain types and sizes 
of files. This option may slow performance due to the time needed to compress and decompress files.

4 If Surround SCM is installed on a UNIX, Solaris, or Mac computer, click Browse to set the Browser Path. 
(This field is not visible to Windows users.)

For example, Netscape users set the browser path to /usr/bin/netscape.

5 If Surround SCM is installed on a UNIX, Solaris, or Mac computer, click Browse to set the Help Directory 
path. (This field is not visible to Windows users.)

The path is /var/lib/SurroundSCM/Surround Help for default installs. If you installed to a different 
directory, make sure you select the correct path to the help file.

6 Select a Text File Format option.

7 Select an option from the File comparison menu.

Surround SCM compares files before updating the status column (current/old/modified) or retrieving 
files from the server when a get or check out operation is performed.

Timestamp checks the timestamp to see if the file was modified after it was retrieved from the server.

Timestamp and CRC checks the timestamp and performs a CRC (Cyclic Redundancy Checksum) 
check. This option checks to see if the data in the file changed. For example, you open a file in an 
editor, make no changes, and resave the file. The modified timestamp changes even though the data 
did not change. This method is slower than the timestamp only option. The difference is noticeable 
when recursively getting or checking out all files from the server.

8 Click OK to save the settings or click another tab to continue setting user options.
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Setting diff/merge options
Guiffy Software’s compare and merge utility is integrated with Surround SCM. Guiffy is a cross-
platform utility used to compare and merge source files, with built-in support for UNICODE, MBCS, 
and over 150 file encoding formats. Guiffy also provides sophisticated folder and file compare and 
synchronization capabilities, making the task of merging, upgrading, and identifying changes as easy 
and as safe as possible. When setting diff/merge options, you can use Guiffy or select another utility.

1 Choose Tools > User Options.

2 Click the Diff/Merge tab.

3 Select Use integrated Guiffy diff/merge utility to use the Guiffy utility.

Click Browse to set the Java Runtime path or the Guiffy path.

4 Select Use selected diff/merge utilities to use another utility. 

Make sure you set the parameters. For more information see Diff/Merge parameters, page 11.

5 Select Allow diff/merge utility to compare binary files to compare binary files.

6 Click OK to save the settings or click another tab to continue setting user options.
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Diff/Merge parameters

Setting view and edit file options
Select the viewer, editor, and applications you want to use to view or edit text and binary files.

1 Choose Tools > User Options.

2 Click the View/Edit File tab.

3 Select a View text files with option.

Internal text viewer uses the default viewer.

Choose Selected viewer then click Browse to select a specific application.

Choose Associated application to launch the application associated with the file. (Windows/Mac only)

Diff %1 %2

file diff server file local file

history diff older file newer file

branch diff branch 1 branch 2

Merge %1 %2 %3

2-way merge server file (merge from) local file (merge to)

3-way merge server file (merge from) local file (merge to) common ancestor
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4 Select a View binary files with option.

Choose Selected viewer then click Browse to select a specific application.

Choose Associated application to launch the application associated with the file. (Windows/Mac only)

5 Select an Edit text files with option.

Internal text editor uses the default editor.

Choose Selected editor then click Browse to select a specific application.

Choose Associated application to launch the application associated with the file. (Windows/Mac only)

6 Select an Edit binary files with option.

Choose Selected editor then click Browse to select a specific application.

Choose Associated application to launch the application associated with the file. (Windows/Mac only)

7 Click OK to save the settings or click another tab to continue setting user options.

Setting file dialog default options
You can set default values used when getting, checking in, or checking out files.

1 Choose Tools > User Options.

2 Click the File Dialog Defaults tab.
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3 Select the Get File dialog default settings.

Select Recursive to include all child repositories in the Get.

Select Make files writable to leave the files in read-write mode.

Select Force file retrieval from server to get the server copy of the file.

Select Merge should first attempt auto-merge if you do not want to be prompted to merge files with 
conflicts. You are prompted to manually merge files if Surround SCM cannot auto-merge the files. 

Select Display “Advanced” Get File dialog to expand the Get File(s) options.

Select a Replace writable option. This option specifies what to do if a writable file is found.

Select a File timestamp option. This is the timestamp used when files are retrieved from the server.

4 Select the Check In File dialog default settings.

Select Recursive to check in files from the selected repository and all child repositories.

Apply comments to all uses the comment field data for each file being checked in.

Select Display “Advanced” Check In File dialog to expand the Check In File(s) options.

Select Skip server auto-merge to check in the files without merging changes. If you select this option, 
the file you check in becomes the new version in the archive, even if someone else made changes to, 
and checked in, the file after you checked it out.

Select Update version even if no change is made to check in a file even if changes were not made.

Select Make files writable to leave a read-write copy of the files in the working directory.

Select a Handle local files after check in option.

5 Select the Check Out File dialog default settings.

Select Recursive to check out files from the selected repository and all child repositories.

Select Exclusive Check Out to prevent other users from checking out the files.

Select Force file retrieval from server to check out the server copy of the file.

Select a Replace writable option. This option specifies what to do if a writable file is found.

Select a File timestamp option. This is the timestamp used when files are retrieved from the server.

6 Click OK to save the settings or click another tab to continue setting user options.
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Setting source tree refresh options
1 Choose Tools > User Options.

2 Click the Source Tree tab.

3 Select Automatically refresh view every xx minutes and enter the refresh interval in minutes.

You can enter from 1 to 999 minutes. If you do not select this option, you can manually refresh the view 
by choosing View > Refresh.

4 Click OK to save the settings.

Configuring email notifications
Email notifications provide a way to stay up to date with changes made to files. You may also receive 
system notifications, which the TestTrack Pro administrator configures.

Adding email notifications
1 Choose Tools > My Email Notifications.

The My Email Notifications window opens.
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2 Click Add.

The Add My Email Notifications dialog box opens.

3 Enter a description.

4 Select the file options. These options specify which files fire the trigger.

Select Only in this branch: then choose a branch from the list to limit searches.

Enter a repository name or click Browse to select a repository.

Select Recursive to search all subrepositories in the specified repository.

Enter the File(s) you want the trigger to fire for. You can enter a file name or wildcard characters.

Select Use regular expression to perform a regex-style search instead of a wildcard search.

Select Match case to enable case-sensitive searching.

5 Select the Event options. These options specify when the notification is sent.

Select a file event from the Send me an email after list.

To add a disabled trigger, clear Enabled.

Select Disable trigger after it runs once if you only want the trigger to run one time. For example, you 
may want to receive an email once after a particular user checks in a file.
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6 Select the Email options

Select Consolidate multiple file actions into one email to send one email for all files affected by the event. 
If this option is not selected, an email is sent for each file.

Click Edit email template to modify the standard email. See Editing email templates, page 114 for more 
information.

7 Click OK.

The notification is added.

Editing email notifications
1 Choose Tools > My Email Notifications.

2 Select a notification and click Edit.

The Edit My Email Notifications dialog opens.

3 Make any changes.

You can edit all information, including the email template.

4 Click OK.

Your changes are saved.

Duplicating email notifications
If you need to create a notification that is similar to an existing one, you can duplicate and edit the 
existing one.

1 Choose Tools > My Email Notifications.

2 Select a notification and click Duplicate.

The notification is duplicated. It is added below the selected notification.

3 Select the new notification and click Edit.

4 Make any changes and click OK.

Disabling email notifications
If you do not want a notification to be sent, you can disable it temporarily instead of deleting it.

1 Choose Tools > My Email Notifications.

2 Select a notification and click Disable.

The notification is disabled.
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Enabling email notifications
1 Choose Tools > My Email Notifications.

2 Select a notification and click Enable.

The notification is enabled.

Deleting email notifications
1 Choose Tools > My Email Notifications.

2 Select a notification and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The notification is deleted.

Setting the working directory
A working directory must be set before you can work with source files. The working directory is 
generally mapped to a local drive directory. It can also be mapped to a different location, such as a 
network drive.

1 Select the repository you want to set the working directory for.

2 Choose Repository > Set Working Directory.

The Set Working Directory dialog box opens.

3 Enter a directory path or click Browse to select a directory.

4 Select Allow child repositories to inherit this working directory if you want child repositories to use the same 
directory.

The working directory is set automatically when subrepositories are added.

5 Select Inherit working directory from parent to use the parent repository’s working directory. 

The working directory is set as <parent’s path> \ <repository name>.

6 Click OK.
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Working directory editor
The working directory editor provides a convenient way to add, edit, or delete working directories from 
one central location. You can add or edit your own working directories. You can delete a working 
directory that was setup on any computer you used.

1 Choose Tools > Working Directories.

The working directory editor opens. A list of working directories is displayed. To filter the list, select a 
computer from the Computer list.

Adding working directories
1 Open the working directory editor.

2 Click Add.

The repository browser opens.

3 Select a branch and repository and click OK.

The Add Working Directory dialog box opens.
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4 Enter a directory path or click Browse to select a directory.

5 Select Allow child repositories to inherit this working directory if you want child repositories to use the same 
directory.

The working directory is set automatically when subrepositories are added.

6 Click OK.

The working directory is set.

Editing working directories
You can change the working directory and the child repositories inherit option.

1 Open the working directory editor.

2 Select a working directory and click Edit.

The Edit Working Directory dialog box opens.

3 Make any changes and click OK.

Deleting working directories
1 Open the working directory editor.

2 Select a working directory and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The working directory is deleted.
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Chapter 3
Setting up Surround SCM

It only takes a few minutes for new and upgrade users to set up Surround SCM. After creating or 
upgrading mainline branches, your users will be working with source files in no time at all.

Starting Surround SCM, 22

Setting up server connections, 23

Creating mainline branches, 25

Upgrading mainline branches, 26
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Starting Surround SCM
The first time you start Surround SCM, configure the server connection and set the working directory. 
Also take a few minutes to set user options and change your password. If you are the Surround SCM 
administrator, you must also create a mainline branch.

Note:  The Seapine License Server and the Surround SCM server must be running before 
you start Surround SCM. 

1 On the Start menu, choose Programs > Seapine Software > Surround SCM > Surround SCM Client.

The Login dialog box opens.

2 Select the server you want to connect to.

If you need to add a server, see Setting up server connections, page 23 for more information.

3 Enter your Username and Password.

Select Always login with this username and password to automatically login when Surround SCM starts.

4 Click Connect.

You are logged in and ready to start using TestTrack Pro.
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Setting up server connections
You need to add a server connection for each Surround SCM server you want to access.

Adding server connections
1 Click Setup on the Surround SCM login dialog box.

Note:  Start Surround SCM or choose File > Connect to Server to open the login dialog box.

The Setup Server Configurations dialog box opens.

2 Click Add.

The Add Surround SCM Server dialog box opens.

3 Enter a Server Name and Server Address. 

The server address is the IP address of the computer where the Surround SCM server application is 
installed. Your Surround SCM administrator can tell you the server address.

4 Enter the Port number.

Surround SCM clients connect to the server on this port via TCP/IP. Valid values are 1-65535.
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5 Click OK.

The server connection is added. You return to the Setup Server Configurations dialog box. To change the 
order of the servers, select a server entry and click Up or Down.

6 Click Close to close the Setup Server Configurations dialog box.

Editing server connections
1 Start Surround SCM or choose File > Connect to Server to open the login dialog box.

2 Click Setup on the Surround SCM login dialog box.

The Setup Server Configurations dialog box opens.

3 Select the server and click Edit.

4 Make any changes and click OK.

Deleting server connections
1 Start Surround SCM or choose File > Connect to Server to open the login dialog box.

2 Click Setup on the Surround SCM login dialog box.

The Setup Server Configurations dialog box opens.

3 Select the server and click Delete.

You are prompted to confirm the deletion.

4 Click Yes.

The server is deleted.

Connecting to a different server
You can connect to another server without closing Surround SCM.

1 Choose File > Connect to Server.

The login dialog box opens.

2 Enter the login information and click Connect. 
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Creating mainline branches
Note:  You may not have access to this administrator command.

A mainline branch is the highest-level central branch that contains all source files, labels, other branches, 
and repositories. All files saved to a specific Surround SCM server are stored in a corresponding branch. 
At least one mainline branch must be created before source files can be added to Surround SCM.

You cannot search, branch, promote, or rebase across mainline branches. Take the time to decide on your 
company’s use of mainline branches. Some companies may need only one mainline branch while other 
companies may have multiple mainline branches.

1 Choose Tools > Administration > Create Mainline Branch.

The Create Mainline Branch dialog box opens.

2 Enter the Mainline branch name.

3 Enter the Location on server.

This is the path on the Surround SCM server computer where Surround SCM files are stored. This field 
is automatically populated with the same name as the mainline branch. You can enter a different name.

4 Enter any comments.

5 Click OK.

You are prompted to confirm that you want to create a mainline branch.

6 Click Yes.

The mainline branch is created. for more information about branches see Chapter 6, “Working with 
Branches,” page 51.
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Upgrading mainline branches
The Surround SCM database format may change between major and some minor releases. Database 
changes can be necessary to support new features and functionality. If the database format changes, you 
need to upgrade mainline branches to the new format. If a mainline branch name is appended with old 
database it needs to be upgraded. Before upgrading, make a backup copy of the mainline branch.

1 Select the mainline branch you want to upgrade.

2 Choose Tools > Administration > Upgrade Mainline Branch.

You are prompted to confirm the upgrade.

3 Click Yes.

The mainline branch is upgraded.
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Chapter 4
Learning the Basics

Take a few minutes to learn about the interface features. Surround SCM is easy to use but it is even 
easier when you understand the basics. Once you understand the components and a few basic 
techniques you will be using Surround SCM in no time at all.

Surround SCM interface, 28

Source Tree view, 28

Users view, 30

Security groups view, 30

Surround SCM menus, 31

Surround SCM toolbars, 35
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Surround SCM interface
Surround SCM provides complex functionality with an easy to use, and learn, interface. The interface 
includes the following views: Source Tree view, Users view, and Security groups view. Features, such as 
the title bar, menu bar, toolbars, status bar, and tooltips are common to all three views. Some options, 
such as active menus and commands, are dependent on the view and security permissions.

Source Tree view
The Source Tree view is the most used Surround SCM view. Many users will only have access to this 
view. Most file-related commands such as checking in files are accessed from the Source Tree view. You 
can customize the Source Tree view. For more information see Customizing the Source Tree view, page 4.

Menu bar
Contains the available menus. Menu commands vary depending on the function you are performing and 
your security permissions. If a menu command is greyed out and unavailable you do not have access to 
that command or the command is not available for the view you are in. For details, see Surround SCM 
menus, page 31.

Toolbars
Toolbars provide access to the most used Surround SCM commands. Surround SCM includes Edit, 
View, Activities, Repository, Branch, and Administration toolbars. For details, see Surround SCM toolbars, 
page 35.

SCM files paneRepositories pane

Toolbars

Branches menu

Menu bar

Branches pane

Shortcut menu

Status bar

Title bar

Activity log

File details pane
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Branches menu
Contains a list of all branches you can access.

Branches pane
Displays the available branches. It contains the same list of branches available from the Branches menu. 
Data is displayed in a tree view. Clicking a plus sign expands the selected branch; clicking a minus sign 
collapses the branch.

Shortcut menus
Open when you right-click on views and panes. The specific commands on each shortcut menu vary 
depending on the function you are performing and your security permissions.

Repositories pane
Displays the available repositories. After selecting a branch, this pane is populated with the repositories 
in the selected branch. Data is displayed in a tree view. Clicking a plus sign expands the selected 
repository; clicking a minus sign collapses the repository.

SCM files pane
Displays the selected repository’s source files. After selecting a repository, this pane is populated with 
the files in the selected repository. This pane includes the following columns: Filename, Timestamp, 
Locked By, Status, Type, Version, and Check Out Location. You can also add a graphical status indicator 
to a column. For details, see Customizing the Source Tree view, page 4.

File details pane
Displays the selected file’s properties, history, check out status, and sharing information. Provides a 
convenient way to work with files and access file commands. For more information see Using the file 
details pane, page 5.

Activity log
Displays the file activity log including information about files you get, check out, etc. All file information 
is logged. To clear the activity log choose Edit > Clear Activity Log.

Status bar
A status bar, located at the bottom of the application window, includes connection and working 
directory information. If you select a command from the shortcut menu, the command description is 
displayed on the status bar.

Tooltips
When you place the cursor over a toolbar button, a command description opens.
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Users view
Note:  You may not have access to this view depending on your security permissions.

This view is used to manage Surround SCM users. User commands are accessed via the command 
buttons or the shortcut menu. This view includes the User, Username, and Security Groups columns. 
Click a column heading once to sort ascending; click again to sort descending. For more information see 
Chapter 15, “Managing Users and Security Groups,” page 151.

Security groups view
Note:  You may not have access to this view depending on your security permissions.

This view is used to manage Surround SCM security groups. Security groups commands are accessed 
via the command buttons or the shortcut menu. This view includes the Group Name, Description, and 
Security Permissions columns. Click a column heading once to sort ascending; click again to sort 
descending. For more information see Chapter 15, “Managing Users and Security Groups,” page 151.

Shortcut menu

Command buttons

Shortcut menu

Command buttons
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Surround SCM menus
Surround SCM menus provide access to system commands. The menu commands you can access 
depend on the function you are performing, your security permissions, and if you are connected to the 
Surround SCM server. For example, you are a member of a security group with restricted permissions. 
All Administration menu commands are greyed out and unavailable because your security group does 
not have access to these functions.

File menu

Edit menu

View menu

Command Description

File > Connect to Server Connect to a Surround SCM server and open the login dialog box

File > Logout and Disconnect Logs you out from Surround SCM and disconnects you from the 
server

File > Exit Close the application

Command Description

Edit > Select All Select all items

Edit > Select None Deselect items

Edit > Clear Activity Log Clears the activity log

Edit > Advanced Find Files Advanced search for files

Menu Command Description

View > New Source Tree Open a new source tree window

View > Existing Source Tree Switch to an existing source tree window

View > Users Open the users window

View > Security Groups Open the security groups window

View > Toolbars > Edit Display or hide the edit toolbar

View > Toolbars > View Display or hide the view toolbar

View > Toolbars > Activities Display or hide the activities toolbar

View > Toolbars > Repository Display or hide the repository toolbar
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Activities menu

View > Toolbars > Branch Display or hide the branch toolbar

View > Toolbars > Administration Display or hide the administration toolbar

View > Branch Tree Display or hide the branch tree

View > File Details Pane Display or hide the file details pane

View > Activity Log Display or hide the activity log

View > Status Bar Display or hide the status bar

View > Refresh Refresh all views

Menu Command Description

Activities > Get Get a read-only copy of the selected files

Activities > Check In Put the changes from the local file back into the repository file

Activities > Check Out Retrieve a copy of the file and mark it as checked out (locked)

Activities > Undo Check Out Undo the checked out (locked) status of a file

Activities > Create Label Create a new label for a file, folder, or branch

Activities > Share Files Share, or link, files between repositories

Activities > Break Shares Break the shared link

Activities > History Display the file history

Activities > Differences Display the differences between the local copy of the file and the 
tip revision of the file in the repository

Activities > Merge Merge the changes in the repository into the local file

Activities > Add Files Add a file to the repository

Activities > View File View the currently selected file, as it is in the repository

Activities > Edit File Edit the selected file by checking the file out, if needed, and 
opening an editor

Activities > Rename File Rename the selected file

Activities > Remove File Remove the selected files from the repository

Activities > Properties Display the file or repository properties

Menu Command Description
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Repository menu

Branch menu

Tools menu

Menu Command Description

Repository > Create Repository Create a new repository

Repository > Rename Repository Rename the selected repository

Repository > Remove Repository Remove the selected repository

Repository > Set Working Directory Set the working directory for the selected repository

Menu Command Description

Branch > Promote Branch Update ancestor branch with selected branch changes

Branch > Rebase Branch Update selected branch with ancestor branch changes

Branch > Freeze / Unfreeze Branch Freeze or unfreeze the selected branch

Branch > Promote File Update ancestor branch with selected file changes

Branch > Rebase File Update selected file with ancestor branch changes

Branch > Create Branch Create a workspace, baseline, or snapshot branch

Branch > Rename Branch Rename the selected branch

Branch > Remove Branch Remove the selected branch

Menu Command Description

Tools > Administration > Create 
Mainline Branch

Create a mainline branch

Tools > Administration > Add 
Existing Mainline Branch

Add an existing mainline branch to the server

Tools > Administration > Remove 
Mainline Branch

Remove a mainline branch

Tools > Administration > Upgrade 
Mainline Branch

Upgrade a mainline branch to the current version

Tools > Administration > Branch 
Maintenance

Destroy or restore branches

Tools > Administration > Void 
Check Out

Void the checked out (locked) status of a file
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Window menu

Help menu

Tools > Administration> Shadow 
Folders

Manage shadow folders

Tools > Administration > Triggers Manage triggers

Tools > Administration > View 
Server Log

Manage the server log

Tools > Administration > Mail 
Queue

Manage the mail queue

Tools > Administration > Server 
Options

Manage server options

Tools > TestTrack Pro Integration > 
TestTrack User Settings

Configure TestTrack Pro users settings

Tools > TestTrack Pro Integration > 
TestTrack DB Configurations

Configure TestTrack Pro database connections

Tools > Reports > History Create a history report

Tools > Reports > Trend Create a trend report

Tools > Reports > Labeled Files Create a labeled files report

Tools > Change Password Change your password

Tools > My Email Notifications Set your email notifications

Tools > Working Directories Edit working directories

Tools > User Options Manage user options

Menu Command Description

Window > Cascade Layers the Surround SCM windows

Window > Tile Arranges the Surround SCM windows side by side

Window > Close All Closes all open Surround SCM windows

Menu Command Description

Help > Contents Open the help file contents page

Help > Index Open the help file index page

Menu Command Description
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Surround SCM toolbars
The toolbars provide easy access to Surround SCM functions. Use the View menu to display or hide 
toolbars. If you do not have access to a command, or the command is not available for the view you are 
in, the toolbar icon is greyed out and unavailable. For example, the Activities toolbar icons are greyed 
out when you work in the Users view because Activities commands can only be used with source files.

Edit toolbar

View toolbar

Help > Search Open the help file search page

Help > Email Technical Support Send an email to Seapine technical support

Help > WWW Resources > Seapine 
Software

Go to Seapine Software’s web site

Help > WWW Resources > Surround 
SCM Updates

Go to the Surround SCM update web page

Help > WWW Resources > 
Knowledgebase

Go to Seapine Software’s knowledgebase

Help > WWW Resources > Report a 
Bug

Report a bug to Seapine Software

Help > About Surround SCM View the Surround SCM information dialog

Click: To:

Select all

Select none

Click: To:

View an existing source tree window

Open the users window

Menu Command Description
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Activities toolbar

Open the security groups window

Refresh all views

Click: To:

Get a read-only copy of the selected files

Check in a file

Check out a file

Undo the check out operation

Create a label

Share files

Break shares

Display history

Display differences

Merge file changes

Add files

View a file

Click: To:
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Repository toolbar

Branch toolbar

Edit a file

Remove files

Display properties

Click: To:

Create a new repository

Set the working directory

Remove the repository

Click: To:

Create a new branch

Promote a branch

Rebase a branch

Promote files or repositories

Rebase files or repositories

Remove a branch

Click: To:
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Administration toolbar

Freeze a branch

Unfreeze a branch

Click: To:

Create a mainline branch

Void a check out operation

Click: To:
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Chapter 5
Managing Repositories

A repository is a collection of files and/or subrepositories that helps you organize Surround SCM. 
Each repository is generally mapped to a directory on your hard drive. You can create as many 
repositories as necessary.

About repositories, 40

Creating repositories, 40

Selecting a repository, 41

Configuring repository security, 42

Creating repository labels, 44

Renaming repositories, 45

Viewing repository history, 45

Diffing repositories, 46

Viewing repository shadow folders, 47

Removing repositories, 48

Restoring repositories, 48

Destroying repositories, 50
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About repositories
Repositories are used to organize Surround SCM by grouping together file and subrepositories. Your 
company’s needs and business processes dictate how you set up repositories. You may want to ask the 
following questions before you start creating, and providing access to, repositories:

What guidelines should be used when creating repositories? Should a new repository be created for 
each product, each component, etc?

Who can create Surround SCM repositories?

Who can access advanced Surround SCM repository commands? Advanced commands include 
commands such as renaming, deleting, destroying or restoring repositories, promoting or rebasing 
repositories, configuring repository security, etc.

Who is responsible for maintaining repositories?

i
For example, a software development company creates repositories for each software 
component. After creating a WysiApp mainline branch, the project lead creates 
repositories named WysiApp Client and WysiApp Server. She then populates each 
repository with the corresponding client or server code files. She also creates a WysiApp 
Documentation repository to make sure the latest documentation is included with all 
software release builds.

Creating repositories
1 Select the repository you want to create the repository in. Choose Repository > Create Repository.

The Create Repository dialog box opens.
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2 The Branch field is read-only.

This is the name of the branch you are creating the repository in.

3 The Parent repository field is read-only.

This is the name of the repository you are creating the repository in.

4 Enter the repository name in the New repository field.

5 Enter optional comments such as the reason for creating the repository.

6 Set the working directory. 

This is the directory where Surround SCM files are stored.

7 Click OK.

After creating a repository, you need to add source files. See Adding files, page 72 for details.

Selecting a repository
1 Select the mainline branch that contains the repository you want to access.

You can select the mainline branch from the Branches pane or the Branches menu.

2 The Repositories pane is populated with the repositories in the selected branch.

3 Click the repository you want to access.

The selected repository is highlighted. The SCM files pane is populated with the source files.

4 Select List recursively to display all files and subrepositories in the repository.

For more information, see Listing files recursively, page 7.
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Configuring repository security
Note:  You may not have access to this admin command.

You can apply security at the repository level, overriding the server security. Security can be modified 
for any group for the selected repository. For example, you have multiple products and development 
teams. Configuring repository security lets you restrict each development team to specific repositories.

1 Select the repository and choose Activities > Properties.

The Properties dialog box opens.

2 Click the Security tab to configure repository security. 

The text at the top of the tab provides information about the repository and the affect that setting 
security has on other branches. For example, when you set security for a specific branch in a repository, 
the following text appears at the top of the tab: This repository is using security that applies only to this 
branch and child branches that have selected to inherit it.

The Group column lists the name of all security groups.

The Inherited From column lists where security permissions are being set.

The Security column shows a summary of the group’s security. Scan this column to quickly see which 
groups have access to all commands, some commands, etc.
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3 Click Modify to change the security.

4 To override security permissions, select a group and click Override.

Enable/disable commands for the selected group.

Click Inherit to remove the repository security.

5 To add a security group, click Add.

The Select a Group dialog box opens. Select the group you want to add and click OK.

Enable/disable commands for the group.

Select a group and click Remove to remove the group.

6 Select Force all child repositories to inherit these security permissions to apply security to the selected 
repository and all child repositories.

Select this option to use these permissions and remove security for all child repositories. You are 
prompted to confirm this action.

7 Click OK to save any changes.
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Creating repository labels
Labels provide a way to mark a specific version of files in a repository. When a label is created, a new 
entry is added to the repository history. The file, and the version number, do not change. For example, 
label a repository that contains all the files for a testing release. Each time the build is released to testing, 
create a corresponding label. You can view the history to see what changed after a label was created. You 
can also easily recompile a specific version of the testing build.

1 Select the repository and choose Activities > Create Label.

The Create Label dialog box opens.

2 Enter the Label.

Use a meaningful label. If you are applying the label to files for release 2, use a label such as Version 2.0.

3 Enter optional comments.

4 Select Recursive to apply the label to the selected repository and all child repositories.

5 Select an If label exists option.

Prompt prompts you to replace the label, leave the label, or cancel the labeling command

Replace deletes the label and replaces it with the new label

Leave leaves the label as is

6 Click OK to create the label.
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Renaming repositories
1 Select the repository and choose Repository > Rename Repository.

The Rename Repository dialog box opens.

2 Enter a new name and any comments.

3 Click OK.

The repository is renamed.

Viewing repository history
History provides a convenient way to view repository information.

1 Select a repository. 

2 Choose Activities > History.

The History dialog box opens.

3 Optionally select a user from the Filter by user menu.
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4 Optionally select an action from the Filter by action menu.

5 Select a repository and click Details to view more information.

The read-only History Details dialog box opens. Click Close to return to the History.

6 Click Close to close the repository history.

Diffing repositories
Diff repositories to see if there are differences between server files and files in your working directory. 
You can also work with files while diffing repositories.

1 Select the repository. Choose Activities > Differences.

The Repository Differences dialog box opens.
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2 Select any options to control which files display.

Select Recursive to display all files in the repository and any subrepositories.

Select Show changed files to display changes files.

Select Show identical files to display identical files.

Select Show files that are missing locally to display missing local files.

Select Show files that are missing on the server to display missing server files.

3 Select a file and click Differences.

The Differences dialog box opens. See Diffing files, page 90 for more information.

Viewing repository shadow folders
You can view a list of all shadow folders in a repository. A shadow folder contains a “reference copy” of 
the current files in a repository. 

1 Select the repository and choose Activities > Properties.

2 Click the Shadow Folders tab.

A read-only list of all shadow folders in the repository opens.

3 Click OK to close the Properties dialog box.
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Removing repositories
Depending on your security permissions, you can remove a repository. When a repository is removed, 
its contents are not deleted from the hard drive and can be restored.

1 Select the repository and choose Repository > Remove Repository.

The Remove Repository dialog box opens.

2 Enter optional comments such as the reason for removing the repository.

3 Select Force recursive remove to remove the repository and all files and subrepositories.

Repositories that contain files and/or subrepositories cannot be removed. This option forces the removal 
of all files and subrepositories.

4 Select Permanently destroy repository to delete the repository from the hard drive.

If you select Force recursive remove this option changes to Permanently destroy repository and contents.

5 Click OK.

You are prompted to confirm the removal.

6 Click Yes to remove the repository.

The repository is removed; it is not deleted from the Surround SCM server.

Restoring repositories
1 Select the repository that contains the subrepository you want to restore. 

2 Choose Activities > Properties.

The Properties dialog box opens. Make sure you are viewing repository properties and not file 
properties.
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3 Click the Removed Items tab.

This tab includes a list of all removed repositories and files.

4 Select the repository you want to restore.

5 Click Restore.

The Restore Files/Repositories dialog box opens.

6 Enter optional comments such as the reason for restoring the repository.

7 Click OK.

The repository is restored.
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Destroying repositories
Destroyed repositories are permanently deleted from the hard drive and cannot be restored.

1 Select the repository that contains the subrepository you want to destroy. 

2 Choose Activities > Properties.

The Properties dialog box opens. Make sure you are viewing repository properties and not file 
properties.

3 Click the Removed Items tab.

This tab includes a list of all repositories removed from the selected repository.

4 Select the repository you want to destroy.

5 Click Destroy.

The Destroy Files/Repositories dialog box opens.

6 Enter optional comments such as the reason for destroying the repository.

7 Click OK.

You are prompted to confirm the deletion.

8 Click Yes.

The repository is destroyed. It cannot be restored.
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Chapter 6
Working with Branches

Branching provides easy and effective management of source files throughout a lifecycle. Surround 
SCM does not impose a branching process on users - your use of branching depends on your 
company’s needs and business processes.

About branches, 52

When to create a branch, 53

Creating branches, 54

Selecting a branch, 55

Renaming branches, 56

Viewing branch properties, 56

Configuring branch security, 57

Promoting branches, 58

Rebasing branches, 62

Freezing branches, 65

Unfreezing branches, 65

Configuring shadow folders, 65

Removing branches, 68

Removing mainline branches, 69

Restoring branches, 69

Restoring mainline branches, 70

Destroying branches, 70
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About branches
A branch is a separate line of development that uses an existing repository and the files in that repository 
as a starting point. When a repository is branched, the files in both branches are initially identical. As file 
contents change, the branched files become dissimilar. Use branches when you need to make changes to 
source files without affecting files in the existing repository. When you branch a repository, changes can 
be promoted to, or rebased from, associated branches. Surround SCM includes four types of branches: 
mainline, baseline, workspace, and snapshot.

Mainline branch
A mainline branch is the highest-level branch that contains all source files, labels, other branches, and 
repositories. The Surround SCM administrator is generally responsible for creating mainline branches. 
All files saved to a specific Surround SCM server are stored in a corresponding repository.

Admin:  The Surround SCM administrator is generally responsible for creating mainline 
branches. At least one mainline branch must be created before source files can be added 
to Surround SCM.

Baseline branch
A baseline branch is a public branch. Allowing checkouts on a baseline branch lets all users directly 
check out and make changes to the baseline code. Changes made to the baseline branch affect everyone 
who accesses that branch.

Workspace branch
A workspace branch is a private branch. It is used to track and isolate changes made by users. Users 
create their own workspace branch. The branch a workspace is created from is its parent branch. Other 
users are not affected by any changes that are made because the work is being done in a private, 
workspace branch. When a user finishes making changes, changes are promoted from the workspace 
branch to the baseline, or parent, branch. Changes can also be rebased from the baseline branch to a 
workspace branch.

Snapshot branch
A snapshot branch is a static branch of a baseline branch that generally corresponds to a project 
milestone, such as a QA build or final release build. Most Surround SCM commands are disabled in 
snapshot branches. You cannot check out, check in, or merge files into a snapshot branch. Create a 
snapshot branch when you need to be able to tell exactly which versions of files went into a build. You 
can create a snapshot branch based on the latest file version or a specific label or timestamp.

Baseline branch
Snapshot branch
Workspace branch

Mainline branch
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When to create a branch
Create a baseline branch to customize software for a customer. For example, your company develops 
software and a customer requires a feature to integrate with another vendor’s reporting tool. Creating a 
baseline branch lets you customize the software for that customer without affecting all customers.

Create a workspace branch to work on bug fixes without affecting other users. For example, Suzy creates 
a workspace branch to fix bugs. When she is satisfied with her code, she promotes her changes to the 
baseline branch and moves on to development for the next software release.

Create a snapshot branch to mark the last valid build of the baseline. For example, Greg is doing daily 
development builds. He creates a snapshot branch after each successful build to easily detect differences 
between builds. It also provides an easy way to retrieve all the code used in older builds.

Branching scenarios
The following example illustrates one company’s use of branching. A mainline branch named Version 1 
is created. When Version 1 is close to being released, all changes to the source files need to stop. But bug 
fixes and development of the next version need to continue. The solution is to create two branches from 
Version 1. 

The first branch is named Version 1 Fix. Developers create their own workspaces from this branch and 
begin working on bug fixes. When developers finish bug fixes and test their code, they promote their 
changes to Version 1 Fix. The project lead does a code review to ensure all bugs are fixed and the code is 
stable. She then promotes Version 1 Fix changes to Version 1. 

The second branch is named Version 1.2. Development for the next release is done in this branch. This 
branch becomes the baseline for all Version 1.2 development. After bug fixes are promoted from Version 1 
Fix to Version 1, changes can be rebased from Version 1 to Version 1.2.
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Following is another branch example. The WysiChart development team - Joe, Beth, and Alex - each 
work in private, workspace branches, isolated from changes until they decide to accept them. As code 
changes are completed and tested locally, they are promoted up to the development branch. The latest 
development build is always available to the team. After changes are reviewed by the team lead, they are 
promoted to the QA branch for testing by the SQA team. The latest quality-controlled build is always 
protected from the changes downstream.

Creating branches

Note:  To create a mainline branch, see Creating mainline branches, page 25.

1 Choose Branch > Create Branch.

The Create Branch dialog box opens.

2 Parent branch and Repository are read-only.

WysiChart

Version 3.1 QA

Code
reviewed

Tested by
SQA team

Joe

Development
Beth

Alex

Promote changes toward release
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3 Enter the branch name in the New branch field.

4 Enter optional comments about the branch you are creating.

5 Select a Branch type from the menu.

The menu includes branch types you have security permissions to create. See About branches, page 52 for 
more information.

6 Select a Create Branch Based On option.

Latest version creates a branch from the latest version of each file.

Timestamp creates a branch based on the last check in timestamp.

Label creates a branch based on a specific label. Select a label from the menu.

7 Click OK.

The branch is created.

Selecting a branch
1 Select the mainline branch that contains the branch you want to access.

2 Select the branch from the Branches pane or the Branches menu.

The Repositories pane is populated with the repositories in the selected branch.

Selected mainline 
branch

Selected workspace 
branches
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Renaming branches
1 Select the branch.

2 Choose Branch > Rename Branch.

The Rename Branch dialog box opens.

3 Enter a new name and any comments.

4 Click OK.

The branch is renamed.

Viewing branch properties
1 Select the branch. Choose Activities > Properties.

The Properties dialog box opens with the General tab selected. This tab includes read-only branch 
information.

2 Click the Security tab.

This tab is used to apply repository security to a specific branch, overriding the server security. See 
Configuring branch security, page 57 for more information.
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3 Click the History tab. History provides a convenient way to view branch information.

4 Optionally select a user from the Filter by user menu.

5 Optionally select an action from the Filter by action menu.

6 Select a branch and click Details to view more information.

The read-only History Details dialog box opens. Click Close to return to the History.

7 Click Close when you finish viewing, and working with, branch properties.

Configuring branch security
You can apply repository security to a specific branch, overriding the server security. When you 
configure branch security, you are setting repository security that only affects one branch. For example, 
you can restrict access to a branch of released code. 

1 Select a branch and choose Activities > Properties.

The Properties dialog box opens.
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2 Click the Security tab.

This tab is used to select branch security.

Use security that applies to all branches is the default selection. All new child branches inherit security 
from the parent branch

Select Use own security to override security for the selected branch. The first time you select this 
option, you need to select a value from the menu. Copy the security that applies to all branches uses the 
security applied to all branches but lets you change the permissions for the selected branch. Copy the 
parent branch’s security is only available if the parent branch uses its own security or if it is inheriting 
security. Start with no specific security applied uses the server level defaults.

Select Inherit parent’s security to use the same security as the parent branch.

3 Click OK to save the changes.

After you select branch security, you need to enable/disable file commands. Select the highest level 
repository to set commands. For more information, see Configuring repository security, page 42 or Setting 
branch security, page 148.

Promoting branches

Note:  Promoting merges changes from the child branch up to the parent branch.

Promoting is the process of updating an ancestor branch with changes made in the selected branch. 
When you finish making changes to source files, and are ready to share your changes, promote the 
branch. This ensures the ancestor branch includes the most current files and other users have access to 
your changes.

For example, Michelle is working in her private, workspace branch. She finishes developing the new 
features assigned to her and completes informal testing. She knows the QA Manager, Jack, wants to start 
formal testing. She promotes her branch. Jack then rebases her changes into the QA Build branch so he 
can start the testing process.
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You can promote changes to any ancestor branch. For example, Pat finishes making bug fixes in the 
Version 1.5 branch. This branch was created from Version 1 but he does not want to promote changes to 
Version 1. Instead, Pat promotes to WysiApp, which is the parent branch for Version 1 and the 
grandparent branch for Version 1.5. When the team begins development on Version 2, the branch is 
created from WysiApp. This ensures Pat’s Version 1.5 bug fixes are included in the Version 2 code.

1 Select the branch you want to promote. Choose Branch > Promote Branch.

The Promote Branch dialog box opens.

2 The Branch field is read-only.

3 Select an Ancestor to promote to from the menu.

You can promote changes to any ancestor branch.

4 Enter optional comments about the reason for promoting the branch.

5 Select Skip server auto-merge to promote all files, overwriting any changes in the ancestor branch.

6 Optionally click Preview to view more information about the files being promoted.

For more information, see Promote preview, page 61.
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7 Click OK to promote changes.

The Promote Status dialog box opens. You can view the files that were promoted, files that were not 
promoted, and files with conflicts. You can also access commands to help resolve conflicts and 
successfully promote files.

Select a file and click Differences to compare the file versions. See Diffing files, page 90 for details.

Select a file and click History to view the file history. See Viewing file history, page 83 for details.

Select a file and click Properties to view the file properties. See Viewing file properties, page 82 for 
details.

Select a file and click Merge Locally to manually merge the files. See Merging files, page 92 for details.

Select a file and click Remove Parent to remove the file from the parent branch. See Removing files, 
page 100 for details. If you are promoting a file that was removed from the child branch, files cannot 
be merged because Surround SCM cannot determine if you also want to remove the file from the 
parent branch.

Select a file and click Force Promotion to promote the file, overwriting any changes in the parent 
branch. You are prompted to confirm the promotion. Click Yes.

Tip:  Click Save All to save the list of files or click Print to print the list of files.

8 Click Close to close the Promote Status dialog box.
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Promote preview
You can preview the files that are being promoted and access various commands. You can quickly view 
file status and files that will be promoted, files that will not be promoted, and files with conflicts. The 
commands you can access depend on the file’s status and security permissions.

1 Click Preview on the Promote Branch or Promote File(s) dialog box.

The Promote Preview dialog box opens.

2 Select a file and click Differences to compare the From and To branch file versions. See Diffing files, page 90 
for details.

3 Select a file and click History to view the file history. See Viewing file history, page 83 for details.

4 Select a file and click Properties to view the file properties. See Viewing file properties, page 82 for details.

5 Select a file and click Promote File to promote the file. See Promoting files, page 93 for details.

You can view files that were promoted or were not promoted, and files with conflicts. You can also 
access commands to resolve file conflicts and successfully promote files.

6 Select a file and click Merge Locally to manually merge the files. See Merging files, page 92 for details.

7 Select a file and click Remove Parent to remove the file from the parent branch. See Removing files, page 
100 for details.

If you are promoting a file that was removed from the child branch, files cannot be merged because 
Surround SCM cannot determine if you also want to remove the file from the parent branch.

8 Select a file and click Force Promotion to promote the file, overwriting any changes in the parent branch.

You are prompted to confirm the promotion. Click Yes.
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9 Click Promote All to promote all files.

Changes are merged into the parent branch. The Promote Status dialog box opens. You can easily view 
files that were promoted, files that were not promoted, and files with conflicts. You can also access 
commands to resolve file conflicts and successfully promote files.

Tip:  Click Save All to save the list of files or click Print to print the list of files.

10 Click Close to close the Promote Preview dialog box.

Rebasing branches
Rebasing merges changes from the parent branch down to the child branch. This ensures the child 
branch includes the most current files. For example, Cathy and Jon work on bug fixes in their 
workspaces. Jon completes his work and promotes changes to the parent branch. Cathy needs his 
changes to fix a bug. She rebases from the parent branch to merge Jon’s changes into her workspace.

1 Select the branch you want to rebase changes into. Choose Branch > Rebase Branch.

The Rebase Branch dialog box opens.

2 The Branch and Parent branch fields are read-only.

3 Enter optional comments about the reason for rebasing the branch.

4 Select a Rebase Branch Based On option.

Latest Version rebases from the latest version of each file.

Timestamp rebases from a specific timestamp. This field must contain a valid timestamp.

Label rebases from a specific label. This field must contain a valid label.

Snapshot rebases from a snapshot branch. Choose the snapshot branch from the menu.
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5 Select Skip server auto-merge to rebase all files, overwriting any changes in the current branch.

6 Optionally click Preview to view more information about the files being rebased. 

For more information, see Rebase preview, page 64.

7 Click OK to rebase the branch.

The Rebase Status dialog box opens. You can view files that were rebased or not rebased and files with 
conflicts. You can also access commands that help resolve conflicts and successfully rebase files.

Select a file and click Differences to compare the file versions. See Diffing files, page 90 for details.

Select a file and click History to view the file history. See Viewing file history, page 83 for details.

Select a file and click Properties to view the properties. See Viewing file properties, page 82 for details.

Select a file and click Merge Locally to manually merge the files. See Merging files, page 92 for details.

Select a file and click Force Rebase to rebase the file, overwriting any changes in the child branch. You 
are prompted to confirm the rebase. Click Yes.

Tip:  Click Save All to save the list of files or click Print to print the list of files.

8 Click Close to close the Rebase Status dialog box.
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Rebase preview
You can preview the files that are being rebased and perform various commands. You can quickly view 
file status and files that will be rebased, files that will not be rebased, and files with conflicts. The 
commands you can perform from this dialog box depends on the file’s status and security permissions.

1 Click Preview on the Rebase Branch or Rebase File(s) dialog box.

The Rebase Preview dialog box opens.

2 Select a file and click Differences to compare the branch file versions. See Diffing files, page 90 for details.

3 Select a file and click History to view the file history. See Viewing file history, page 83 for details.

4 Select a file and click Properties to view the file properties. See Viewing file properties, page 82 for details.

5 Select a file and click Rebase File to rebase the file. See Rebasing files, page 95 for details.

You can view files that were rebased or were not rebased and files with conflicts. You can also access 
commands to resolve file conflicts and successfully rebase files.

6 Select a file and click Merge Locally to manually merge the files. See Merging files, page 92 for details.

7 Select a file and click Force Rebase to rebase the file, overwriting any changes in the child branch.

You are prompted to confirm the rebase. Click Yes.

8 Click Rebase All to rebase all files.

The Rebase Status dialog box opens. You can view files that were rebased or were not rebased and files 
with conflicts. You can also access commands to resolve file conflicts and successfully rebase files.

Tip:  Click Save All to save the list of files or click Print to print the list of files.

9 Click Close to close the Rebase Preview dialog box.
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Freezing branches
Depending on your security permission, you may be able to freeze branches. Freezing a branch prevents 
users from making any changes to files in the branch. When a branch is frozen, any command that can 
affect the code, such as adding a file or creating a repository, is disabled. Commands that do not affect 
the code, such as getting a file or merging to local files, are enabled.

You may want to freeze a branch for administrative or maintenance purposes. For example, you need 
build release for multiple platforms. Freeze the corresponding branches to ensure the files cannot be 
changed during the build process. When you finish, unfreeze the branches.

1 Select the branch you want to freeze.

2 Choose Branch > Freeze Branch.

You must confirm that you want to freeze the branch.

3 Click Yes.

The branch is now frozen. 

Unfreezing branches
Unfreeze a branch if you want to be able to make changes to repositories and files in the branch.

1 Select the branch you want to unfreeze.

2 Choose Branch > Unfreeze Branch.

The branch is unfrozen.

Configuring shadow folders
A shadow folder contains a “reference copy” of the current files in a repository. Files are automatically 
updated when changes are checked in to Surround. Use shadow folders to provide read-only access to 
non-Surround users or to provide a central location to build releases from. Shadow folders cannot be 
created on snapshot branches.

For example, your employee manual files are stored in Surround SCM. Most employees do not have 
access to the Surround database that contains the files. Creating a shadow folder on a public network 
drive lets all employees view the manual. When the human resources department updates the files and 
checks in changes to Surround SCM, the files in the shadow folder are also updated with changes. This 
ensures employees have access to the latest version of the employee manual.
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Before you add a shadow folder, you must first create an empty directory. Surround SCM does not 
automatically create shadow folders to provide greater security and protection against hackers. If 
Surround did automatically create shadow folders, a hacker could fill up the hard drive with 
unnecessary files. A hacker could also specify the Windows system folder as the shadow folder and then 
check in .DLLs that contain a virus. In addition, the administrator can control where the shadow folders 
are being created.

Adding shadow folders
When shadow folders are created Surround SCM assumes it can add, override, and delete files. Creating 
an empty directory protects against hackers and also protects against files being overwritten.

Note:  You must create an empty directory, which the shadow folder will be created in, 
before you create the shadow folder.

1 Choose Tools > Administration > Shadow Folders.

The Shadow Folders dialog box opens.

2 Click Add.

The Add Shadow Folders dialog box opens.

3 Click Set to select the branch and repository.

The Repository Browser dialog box opens. Select the branch and repository you want to shadow and 
click OK.
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4 Enter the Shadow Path.

This is the location of the shadow folder.

5 Select the End-Of-Line Format to use for text files.

6 Select a Timestamp option. This timestamp is used when files are retrieved to the shadow folder.

Current uses the current (time of retrieval) date and time.

Modified uses the last modified date and time.

Check in uses the last checked in date and time.

7 Select Recursive to recursively shadow all subrepositories in the selected repository.

8 Click OK.

The shadow folder is created.

Shadow folder example
WysiCorp wants to create a shadow folder for their existing web server directory. The existing directory, 
which is not empty, is at C:\Inetpub\wwwroot. The following steps are taken to set up this shadow folder:

First, the administrator renames wwwroot to wwwroot2 in the C:\Inetpub directory. The administrator 
also archives wwwroot2 in case a file wasn’t checked in to Surround.

Next, a new empty directory named wwwroot is created in the C:\Inetpub directory. A shadow folder 
is created for wwwroot.

After waiting for Surround to copy the files into the new directory, the administrator manually copies 
any files that were not checked in to Surround from wwwroot2 to the new wwwroot directory. The files 
should also be added to Surround.

Editing shadow folders
1 Choose Tools > Administration > Shadow Folders.

The Shadow Folders dialog box opens.

2 Select the folder and click Edit.

You can change the End-Of-Line Format and the Timestamp.

3 Click OK to save your changes.

Note:  To update the files in the selected shadow folder, click Force Update.
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Deleting shadow folders
1 Choose Tools > Administration > Shadow Folders.

The Shadow Folders dialog box opens.

2 Select the folder and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The shadow folder is deleted.

Removing branches
When a branch is removed, its contents are not deleted from the hard drive and its contents can be 
restored.

1 Select the branch. Choose Branch > Remove Branch.

The Remove Branch dialog box opens.

2 Enter optional comments such as the reason for removing the branch.

3 Select Permanently destroy branch to delete it from the hard drive.

4 Click OK.

You are prompted to confirm the branch removal.

5 Click Yes to remove the branch.

The branch is removed.
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Removing mainline branches
You can remove a mainline branch from the Surround SCM server. All child branches, repositories, 
subrepositories, and files are also removed.

1 Select the mainline branch.

2 Choose Tools > Administration > Remove Mainline Branch.

The Remove Mainline Branch dialog box opens.

3 Enter any comments.

4 Click OK.

You are prompted to confirm the removal.

5 Click Yes.

The mainline branch is removed.

Restoring branches 
Branch maintenance is used to restore branches.

1 Choose Tools > Administration > Branch Maintenance.

The Branch Maintenance dialog box opens.

2 Select a branch and click Restore.

The Restore Branch dialog box opens.
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3 Enter any comments and click OK.

The branch is restored.

4 Click Close to close the Branch Maintenance dialog box.

Restoring mainline branches
When a mainline branch is removed, it is not deleted. You can restore an existing mainline branch to 
make it active again.

1 Choose Tools > Administration > Add Existing Mainline Branch.

The Add Existing Mainline Branch dialog box opens.

2 Enter the server location of the mainline branch and click OK.

The mainline branch, child branches, repositories and subrepositories, and files are restored.

Destroying branches
Destroyed branches are permanently deleted from the hard drive and cannot be restored.

1 Choose Tools > Administration > Branch Maintenance.

The Branch Maintenance dialog box opens.

2 Select a branch and click Destroy.

You are prompted to confirm that you want to destroy the selected repository.

3 Click Yes.

The branch is destroyed and cannot be restored.
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Chapter 7
Working with Files

Surround SCM manages all of your source files, including code files, requirements documents, Web 
pages, image files, specifications, and more. With Surround SCM, you can archive and version 
virtually any file and quickly locate and retrieve it at any time.

Adding files, 72

Finding files, 73

Finding events, 74

Searching by check out status, 75

Searching by status, 75

Getting files, 76

Viewing files, 78

Editing files, 79

Checking out files, 80

Checking in files, 84

Creating file labels, 81

Viewing file properties, 82

Viewing file history, 83

Undoing check out, 86

Voiding check out, 87
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Adding files
When you add files, Surround SCM checks in the files. When you add a directory, a repository with the 
same name as the directory is created. Files are added to the corresponding repository. Surround SCM 
optionally repeats the process recursively for all subdirectories.

1 Select the repository you want to add files to. Choose Activities > Add Files.

The Add File(s) dialog box opens.

2 Click Browse to select the directory you want to add files from.

The Browse for Folder dialog box opens.

3 Select the directory and click OK. 

You return to the Add File(s) dialog box. It is populated with the files and folders from the directory.

4 Select the files or folders you want to add.

To add multiple files or a combination of files and folders, Ctrl + click each item. To add specific files from 
a folder, double-click the folder to open it then select the files.

Tip:  To quickly add one file, select options then double-click the file.

5 Select Show all files to view all files in the directory, including files already added to Surround SCM.

For example, select this option to add files from a directory that is another branch’s working directory.

6 Enter optional comments about the files you are adding. The comment is applied to all files.
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7 Get files after add creates a read-only copy of the files in your working directory. This option is selected by 
default if a working directory is set for the repository you are adding files to. 

This option is not enabled or selected if a working directory is not set for the repository.

8 Select Make files writable to leave the files in read-write mode.

9 Select Check out files after add to immediately check out the files.

10 Select Exclusive check out to prevent other users from checking out the files.

Multiple checkouts are disabled if the checkbox is selected and inactive.

11 Overwrite file if found removed is selected by default. If a file matches a removed file, the removed file is 
overwritten. The added file is checked in and the version number is updated.

If you clear the checkbox, and a file matches a removed file, you are prompted to replace the removed 
file or skip the add.

12 Select Recursive if you are adding a directory and want to automatically add all subdirectories and files.

13 Select a type from the File type menu. 

Auto Detect lets Surround SCM determines the file type

14 Click OK.

The files are added to Surround SCM.

Finding files
1 Choose Edit >Advanced Find Files or click the Advanced Search toolbar button.

The Advanced Find Files dialog box opens with the File Search tab selected.
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2 Select Search filenames and enter the text you want to search for. 

3 Select Match case to perform a case sensitive search.

4 Select Interpret as regular expression to search using regular expressions.

Surround SCM supports all regex characters. If you do not select this option, you can use wildcard 
characters.

5 Select Search recursively to search the selected repository and any subrepositories.

6 Click Find to search the files.

Files that meet the criteria are listed on the SCM files pane. Notice the Search Results filter is applied.

Finding events
1 Choose Edit >Advanced Find Files or click the Advanced Search toolbar button.

The Advanced Find Files dialog box opens.

2 Click the Event Search tab to search for specific text in one or all events.

3 Select Search events.

To search event comments enter the comment text you want to search for.

To search a specific event select an event type. All events are searched are searched by default.

4 Select Match case to perform a case sensitive search.

5 Select Interpret as regular expression to search using regular expressions.

Surround SCM supports all regex characters. If you do not select this option, you can use wildcard 
characters.



75Chapter 7
Working with Files

6 Select Search recursively to search the selected repository and any subrepositories.

7 Click Find to search the files.

Files that meet the criteria are listed on the SCM files pane. Notice the Search Results filter is applied.

Searching by check out status
1 Choose Edit >Advanced Find Files or click the Advanced Search toolbar button.

The Advanced Find Files dialog box opens.

2 Click the Check Out Search tab to search for files based on check out status.

3 Select Search for files checked out to me to search for files you have checked out. 

4 Select Search for files checked out to user and select a Username to search for files checked out by the 
specified user.

5 Select Search recursively to search the selected repository and any subrepositories.

6 Click Find to search the files.

Files that meet the criteria are listed on the SCM files pane. Notice the Search Results filter is applied.

Searching by status
1 Choose Edit >Advanced Find Files or click the Advanced Search toolbar button.

The Advanced Find Files dialog box opens.
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2 Click the Status Search tab to search for files based status.

3 Select the file status.

You can search by Current, Missing, Modified, Old, Unknown, or a combination of file status.

4 Select Search recursively to search the selected repository and any subrepositories.

5 Click Find to search the files.

Files that meet the criteria are listed on the SCM files pane. Notice the Search Results filter is applied.

Getting files
Get files when you want to view a file but do not need to make any changes. You can also view files 
without getting a copy. See Viewing files, page 78.

Note:  Default values can be set for the Get File(s) dialog box. For more information, see 
Setting file dialog default options, page 12.

1 Select the files or repository and choose Activities > Get.

The Get File(s) dialog box opens.
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2 Location defaults to the working directory for the repository. Click Browse to select a different directory.

3 Select Recursive to include all child repositories.

Files in the selected repository and any child repositories are copied into their working directory.

4 Select Force file retrieval from server to get the server copy of the file.

5 Click OK to get the file(s).

Surround SCM copies the files or repositories into the specified directory.

Advanced get
Advanced get includes additional options.

1 Select the files or repository and choose Activities > Get.

The Get File(s) dialog box opens.

2 Click Advanced to expand the Get File(s) options.

3 Select Make files writable to leave the files in read-write mode.

4 Select a Replace writable option. 

This option specifies what to do if a writable file is found.

Prompt prompts you to replace the file, skip the get, or merge the server and local files.

Replace automatically replaces the local file with the repository file.

Skip skips the file.
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5 Select a File timestamp option. 

This is the timestamp used when files are retrieved from the server.

Current uses the current (time of retrieval) date and time.

Modified uses the last modified date and time.

Check in uses the last checked in date and time.

6 Select a Get Based On option. 

Latest version gets the latest server version.

By label gets files based on the selected label.

7 Click OK to get the file(s).

Surround SCM copies the files or repositories into the specified directory. 

Note:  If a writable file is found and you merge the files, the merge utility opens. The Get 
operation complete after the files are reviewed and merged.

Viewing files
When you view a file the associated viewer or application is launched. See Setting view and edit file 
options, page 11 for information.

1 Select the file. Choose Activities > View File. 

A read-only copy of the file is opened in the selected viewer or application.
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Editing files
When you edit a file, Surround SCM checks out the file, launches the viewer or application, and opens a 
writable copy of the file. See Setting view and edit file options, page 11 for information.

1 Select the file. Choose Activities > Edit File.

The file is opened in the selected editor or application.

2 Make any changes and save the file.

Remember to check in the file. When you edit a file, it is checked out to the working directory. 

Note:  If you use the internal text editor and integrate Surround SCM with TestTrack Pro 
you can Save, Check In, and Close the file. The text editor closes after the file is checked in.
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Checking out files
Note:  Default values can be set for the Check Out File(s) dialog box. For more information 
see Setting file dialog default options, page 12.

Check out files when you need to make changes.

1 Select the files or repository and choose Activities > Check Out.

The Check Out File(s) dialog box opens.

2 Select Recursive to automatically check out files from the selected repository and all child repositories. 

3 Select Exclusive check out to prevent other users from checking out the files or repository.

This option may be selected by default depending on the User Options you set.

4 Select Force file retrieval from server to check out the server copy of the files.

5 Select a Replace writable option. This option specifies what to do if a writable file is found.

Prompt prompts you to replace the file, skip the file, or merge the server and local files.

Replace automatically overwrites the local file.

Skip skips the file.

6 Select a File timestamp option. This is the timestamp used when files are retrieved from the server.

Current uses the current (time of check out) date and time.

Modified uses the last modified date and time.

Check in uses the last checked in date and time.
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7 Enter optional comments such as the reason for checking out the file.

8 Click OK.

If a writable file is found and you chose to merge the files, the merge utility opens. The Check Out 
operation finishes after you review and merge the files.

Creating file labels
Labels provide a way to mark a specific version of a file or repository. You can create labels for single 
files, multiple files, or all files in a repository. When you create a label, a new entry is created in the 
history. The file, and the version number, do not change.

1 Select the file. Choose Activities > Create Label.

The Create Label dialog box opens.

2 Enter the Label.

3 Enter optional comments about the reason for creating the label.

4 Select Recursive to apply the label to the selected repository and all child repositories.

5 Select an If label exists option.

Prompt prompts you to replace the label, leave the label, or cancel the labeling command.

Replace deletes the label and replaces it with the new label.

Leave leaves the label as is.

6 Click OK to create the label.
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Viewing file properties
File properties include general and check out information about the selected file.

1 Select a file and choose Activities > Properties.

The Properties dialog box opens with the General tab selected. This tab includes read-only information 
about the file. You may also have access to the following options depending on your security 
permissions.

Select an Expand keywords option.

Select a File type. File types include Text, Binary, Mac Binary, UTF-8 Text, and UTF-16.

2 Click the Check Out tab.

This tab includes read-only check out information about the file.



83Chapter 7
Working with Files

3 Click the Sharing tab.

If the file is shared, a Sharing tab is added to the Properties dialog box. This tab includes read-only 
information about the shared file.

4 Click OK to close the Properties dialog box.

Viewing file history
The history provides a convenient way to view a source file’s history and work with a historic version of 
the file. You can view file details, get or check out a file, create a label, select two version of a file to see 
differences, and view or edit the file. You can also filter the history to display specific files.

1 Select a file and choose Activities > History.

The History dialog box opens. This dialog box includes a summary of historic version information.

2 Optionally select a Filter by user.

3 Optionally select a Filter by action.
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4 Select a file and click Details to view the file version details.

The read-only History Details dialog box opens. Click Close to return to the History.

5 Click Get to get the selected version of the file. For more information see Getting files, page 76.

6 Click Check Out to check out the selected file version. For more information see Checking out files, page 80.

7 Click Create Label to label the selected file version. For more information see Creating file labels, page 81.

8 Click Differences to compare two versions of the file. For more information see Diffing files, page 90.

9 Click View File to view the selected file version. For more information see Viewing files, page 78.

10 Click Edit File to edit the selected file version. For more information see Editing files, page 79.

11 Click Rollback File to revert to a previous file version. For more information see Rolling back files, page 97.

12 Click Close to close the file history.

Checking in files
Check in updates files with changes, removes the lock on the files, makes changes available to other 
users, and increments the version number by one.

Note:  Default values can be set for the Check In File(s) dialog box. For more information 
see Setting file dialog default options, page 12.

1 Select the files or repository and choose Activities > Check In.

The Check in File(s) dialog box opens.
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2 Enter optional comments such as changes made to the files.

Apply comments to all uses the comment field data for each file being checked in. 

3 Select Recursive to check in files from the selected repository and all child repositories.

4 Select a Handle local files after check in option.

Get file after check in creates a read-only copy of the file in the working directory.

Keep checked out checks in changes but keeps the file checked out.

Leave local copy as is checks in the file but does not get the latest version of the file.

Remove local copy checks in the file and deletes it from the working directory.

i
Following are a few reasons you might want to get files after check in. 1. If keyword 
expansion is turned on, files are retrieved with the keywords expanded. Get files to make 
sure keywords are expanded in the working directory files. 2. Changes may be auto-
merged. Get files to make sure files include all changes. 3. Files may be checked in from a 
non-working directory. Get files to make sure the latest copy is in your working directory.

5 Select any Advanced Options.

Enter an optional label. For more information see Creating file labels, page 81.

Select Skip server auto-merge to check in a file without merging changes. The checked in file becomes 
the new version even if someone else made changes and checked in the file after you checked it out.

Select Update version even if no change is made to check in a file even if changes were not made. The 
version number increments by one.

Select Make files writable to leave a read-write copy of the file in the working directory.

6 Click Differences to view differences between the check in file and the file in the working directory.

For more information see Diffing files, page 90.

7 Click Link with Defects to attach SCM files to one or more TestTrack Pro defects.

For more information see Linking with defects, page 124.

8 Click OK.

Note:  Surround SCM automatically merges changes when files are checked in. If there are 
conflicts, the merge utility opens so you can view, accept, or reject changes, and merge the 
changes into a new file. For more information see Merging files, page 92.
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Undoing check out
If a file is checked out and you need to revert changes, you can undo the check out.

1 Select the files or repository and choose Activities > Undo Check Out.

The Undo Check Out File(s) dialog box opens.

2 Select a File overwrite option to specify what happens if a writable file is found. 

Depending on the option you choose any changes you made to the files are lost when you undo the 
checkout. This action cannot be undone.

Get original version replaces the local file with the original server version

Get latest version replaces the local file with the latest server version

Leave local file leaves the local file as is

3 Select Recursive to automatically undo the checkout for the selected repository and all child repositories.

4 Click OK.

The file is no longer checked out.
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Voiding check out
Note:  You may not have access to this administrator command.

You can void a user’s check out operation. This breaks the locks on the selected files, giving other users 
access to the files. Any changes the user made to the files are not saved.

1 Choose Tools > Administration > Void Check Out.

The Void Check Out File(s) dialog box opens.

2 Select a user from the Users list.

The Checked out files list is populated with files the user has checked out.

3 Select the files and click Void Check Out.

You are prompted to confirm that you want to void the checked out files. Remember, this action cannot 
be undone.

4 Click Yes.
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Chapter 8
Managing Files

Surround SCM manages all of your source files and tracks who, when, and what changed for each 
revision. This section includes more advanced file commands that administrators, or other users with 
a high-level of security rights, can access and use to manage source files.

Renaming files, 90

Diffing files, 90

Merging files, 92

Promoting files, 93

Rebasing files, 95

Rolling back files, 97

Sharing files, 98

Unsharing files, 99

Removing files, 100

Restoring files, 100

Destroying files, 101
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Renaming files
1 Select a file.

2 Choose Activities > Rename File.

The Rename File dialog box opens.

3 Enter a new name and any comments.

4 Click OK.

The file is renamed.

Diffing files
You can diff files to compare, accept, or reject differences between two files.

1 Select the file.

2 Choose Activities > Differences.

The Differences dialog box opens. Read-only information is displayed in the File to Compare area.
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3 Select a Second File option.

Copy in working directory compares the server file with the file in your working directory.

Selected file compares the server file with a file you select. Click Browse to choose a file.

4 Click Advanced to select a branched file or historic file version.

The second file area expands with the following options:

Branched file compares the file with a branched version. Choose a file from the list.

Historic version compares the current version with a specific historic version of the file. Choose the 
version from the menu.

5 Click Differences.

The differences utility launches. For additional information about the utility refer to the application’s 
documentation.
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Merging files
You can merge files to compare, accept, or reject differences between files and combine the changes into 
a new file. Surround SCM automatically merges changes when files are checked in. If there are conflicts, 
you are prompted to merge the files. You can merge the file in your working directory with the server 
file, a branched file, or a historic version of the file.

1 Select the file.

2 Choose Activities > Merge.

The Merge dialog box opens. Read-only information about the selected file is displayed in the File to 
Merge Into area of the dialog box.

3 Select a Second File option.

Copy on server merges changes with the latest version on the Surround SCM server.

4 Click Advanced to select a branched file or historic version of the file. The second file area expands with 
the following options:

Branched file compares the file with a branched version. Choose a file from the list.

Historic version compares the current version with a specific historic version of the file. Choose the 
version from the menu.
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5 Click Merge.

The merge utility opens. For additional information about the utility refer to the application’s 
documentation.

i
You can also manually merge files. For example, Sue is close to the end of a development 
cycle and is testing software changes in her workspace branch. She keeps coming across 
the same bug during testing. Pat mentions he fixed the bug and it is in the latest version of 
the file. Sue decides to merge Pat’s changes into the file in her working directory. This lets 
her fix the bug without losing any of her work.

Promoting files
Files can be promoted without affecting other items in the branch. When you finish making changes, 
promote changes back to the parent branch. For detailed information see Promoting branches, page 58.

1 Select the files you want to promote.

2 Choose Branch > Promote File.

The Promote File(s) dialog box opens.

3 The Branch and File(s) fields are read-only.

4 Select an Ancestor to promote to from the menu.

You can promote changes to any ancestor branch.

5 Enter optional comments about the reason for promoting the branch.

6 Select Skip server auto-merge to forcibly promote changes and overwrite any changes in the parent branch.
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7 Click Preview to view more information about the files being promoted. 

For more information see Promote preview, page 61.

8 Click OK to promote changes.

The Promote Status dialog box opens.

9 You can view the files that were promoted, files that were not promoted, and files with conflicts. You can 
also access commands to help resolve conflicts and successfully promote files.

Select a file and click Differences to compare file versions. For more information see Diffing files, page 
90.

Select a file and click History to view file history. For more information see Viewing file history, page 
83.

Select a file and click Properties to view file properties. For more information see Viewing file 
properties, page 82.

Select a file and click Merge Locally to manually merge files. For more information see Merging files, 
page 92.

Select a file and click Remove Parent to remove the file from the parent branch.

Select a file and click Force Promotion to promote the file and overwrite any changes in the parent 
branch. You are prompted to confirm the promotion. Click Yes.

10 Click Close to close the Promote Status dialog box.
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Rebasing files
You can rebase files to make sure you have the most recent copy of the files, including changes made by 
other users. For detailed information about rebasing, see Rebasing branches, page 62.

1 Select the files you want to rebase.

2 Choose Branch > Rebase Files.

The Rebase File(s) dialog box opens.

3 The Branch, File(s), and Parent Branch fields are read-only.

4 Enter optional comments about the reason for rebasing the branch.

5 Select a Rebase File(s) Based On option.

Latest Revision rebases the latest revision of each file.

Timestamp rebases changes from a specific timestamp. This field must contain a valid timestamp 
before the rebase operation can start.

Label rebases changes from a specific label. This field must contain a valid label before the rebase 
operation can start.

Snapshot rebases changes from a snapshot branch. Choose the snapshot branch from the menu.

6 Select Skip server auto-merge to forcibly rebase all changes and overwrite any changes in the child branch.

7 Click Preview to view more information about the files being rebased. 

For more information see Rebase preview, page 64.
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8 Click OK to rebase changes.

The Rebase Status dialog box opens. 

9 You can view files that were rebased, files that were not rebased, and files with conflicts. You can access 
commands to resolve file conflicts and successfully rebase files.

Select a file and click Differences to compare file versions. For more information see Diffing files, page 
90.

Select a file and click History to view file history. For more information see Viewing file history, page 
83.

Select a file and click Properties to view file properties. For more information see Viewing file 
properties, page 82.

Select a file and click Merge Locally to manually merge files. For more information see Merging files, 
page 92.

Select a file and click Force Rebase to rebase the file and overwrite any changes in the child branch. 
You are prompted to confirm the rebase. Click Yes.

10 Click Close to close the Rebase Status dialog box.
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Rolling back files
Rollback files to revert to a previous file version without affecting file history and version numbers. 
Changes made to the file are discarded. The version number increments even though the contents are the 
same as a previous file version. 

For example, the current version is 5 and you rollback to version 3. After the rollback, the new tip version 
is 6. Version 3 and version 6 have the same contents. When you rollback a shared file all the shared files 
are affected. If you only want to change the file in the specified repository break the share then rollback 
the file.

1 Select the file.

2 Choose Activities > History.

The History dialog box opens.

3 Select the file version you want to rollback to and click Rollback File.

The Rollback File dialog box opens.
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4 Enter any comments and click OK.

The file is rolled back to the selected version. 

Note:  Notice the version number increments by one and a check in action is added to the 
file history.

Sharing files
Sharing files creates a link in one repository to a file in another repository within the same branch. This 
lets you maintain common code while eliminating the need to work with multiple copies of the same 
source file. Operations on the shared file are applied to the base (linked to) file. When a file is shared, a 
shared history and filename are maintained. Only the file location is different. If a file or repository is 
shared in a branch, any subsequent branches maintain the defined shared files.

1 Select the file or repository you want to share. 

2 Choose Activities > Share Files.

The Share Files dialog box opens.

3 Select the repository you want to share the files with. 

Click the plus sign to expand the repositories tree.

4 Select Recursive to recursively share all files in a repository.

5 Enter any comments.
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6 Click OK.

The files are now shared. Notice the file is listed in each repository.

i
For example, WysiCorp has 2 products. Repositories are created for each product in the 
same mainline branch. When software is released, all files in the product repositories, 
including all subrepositories, are zipped and shipped. WysiCorp uses the same order form 
(orderform.txt) for all products. 

A repository named Shared is created in the same mainline branch as the product 
repositories. The orderform.txt file is added to the Shared repository. The order form file 
is then shared with both product repositories. The orderform.txt file is the same in all three 
repositories. Checking out orderform.txt from any of the repositories marks it as checked 
out in all repositories. When the changed file is checked in, all files are updated.

Unsharing files
You can break a shared link if you want to maintain files independently. When files are unshared, all 
archive information is copied to the shared directory. The link is broken after the files are copied. If a 
base file is shared more than once, the shared status only changes for the selected files or repository.

1 Select the file or repository you want to unshare. 

2 Choose Activities > Break Shares.

The Break Shares dialog box opens.

3 Select Recursive to recursively break all shared files in a repository.

4 Enter any comments.

5 Click OK.

The files are no longer shared.
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Removing files
Depending on your security permissions, you can remove a file. When a file is removed, its contents are 
not deleted from the hard drive and can be restored.

1 Select the files. Choose Activities > Remove File.

The Remove File(s) dialog box opens.

2 Enter optional comments such as the reason for removing the files.

3 Select Permanently destroy file(s) to delete the selected files from the hard drive.

4 Click OK.

You are prompted to confirm the file removal.

5 Click Yes.

The file is removed from the repository; it is not deleted from the Surround SCM server.

Restoring files
Note:  You may not have access to this administrator command.

1 Select the repository that contains the file you want to restore.

2 Choose Activities > Properties.

The Properties dialog box opens.

3 Click the Removed Items tab.

This tab includes a list of all removed files and repositories.
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4 Select the files you want to restore. To select multiple files, Ctrl+click each file.

5 Click Restore.

The Restore Files/Repositories dialog box opens.

6 Enter optional comments such as the reason for restoring the files.

7 Click OK.

The files are restored.

Destroying files
Destroyed files are permanently deleted from the hard drive and cannot be restored.

1 Select the repository that contains the files you want to destroy. 

2 Choose Activities > Properties.

The Properties dialog box opens.
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3 Click the Removed Items tab.

This tab includes a list of all removed files and repositories.

4 Select the files you want to destroy.

5 Click Destroy.

The Destroy Files/Repositories dialog box opens.

6 Enter any comments such as the reason for destroying the file.

7 Click OK.

You are prompted to confirm the deletion.

8 Click Yes.

The file is permanently destroyed.
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Chapter 9
Running Reports

You will be running reports in no time! Surround SCM makes reporting simple—point, click, print, 
and read.

About reports, 104

Generating history reports, 104

Generating trend reports, 106

Generating labeled files reports, 107
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About reports
Reports are used to analyze file information and actions. Surround SCM includes the following reports:

History reports include information about files, actions, and users who performed the actions.

Trend reports include actions over time.

Labeled File reports include a list of files and their labels.

Generating history reports
History reports include historical information about repositories and files. You can generate a report 
based on specific actions, users, and dates.

1 Select the branch or repository you want to generate the report for.

2 Choose Tools > Reports > History.

The Generate History Report dialog box opens.

3 Select the Actions you want to include.

Click Select Change Actions to automatically the following actions: Add, Check In, Rebase with merge, 
Remove, Promote to, and Promote from with merge.
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4 Select the Users you want to include.

5 Select a Filter by Dates option.

To generate a report based on a date range select the date range option then enter the start date in the 
From field and the end date in the Through field.

6 Select Summary Style Report to generate a summary report. 

Select Hide repositories without selected actions to ignore repositories if files do not meet the report criteria.

7 Select Table Style Report to generate results in a table format. 

Select a Show by and Sort option. 

8 Select Use tab delimited columns to generate a report with tab delimited columns.

Select this option if you are going to save the report as a text file and use it with other programs. Many 
programs can easily import tab delimited text files.

9 Select Recursive to include all subrepositories.

10 Click OK.

The report is generated.

Click Print to print the report.

Click Save As to save the report as a text file.

11 Click OK to close the report.
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Generating trend reports
Trend reports include a count of selected actions, which can be grouped by user, day, week, or month.

1 Select the branch or repository you want to generate the report for.

2 Choose Tools > Reports > Trend.

The Generate Trend Report dialog box opens.

3 Select the Actions you want to include.

Click Select Change Actions to automatically select all change actions. Change actions include Add, Check 
In, Rebase with merge, Remove, Promote to, and Promote to with merge.

4 Select the Users you want to include.

5 Select a Filter by Dates option.

To generate a report based on a date range select the date range option then enter the start date in the 
From field and the end date in the Through field.

6 Select Group actions by User, Day, Month, or Week.

Select one event type per file to include one event type per file. This option changes based on the group by 
selection.
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7 Select Use tab delimited columns to generate a report with tab delimited columns.

Select this option if you are going to save the report as a text file and use it with other programs. Many 
programs can easily import tab delimited text files.

8 Select Recursive to include all subrepositories.

9 Click OK.

The report is generated.

Click Print to print the report.

Click Save As to save the report as a text file.

10 Click OK to close the report.

Generating labeled files reports
Trend reports include a count of selected actions, which can be grouped by user, day, week, or month.

1 Select the branch or repository you want to generate the report for.

2 Choose Tools > Reports > Labeled Files.

The Generate Labeled Files dialog box opens.

3 Select the Label you want to include.

4 Select Recursive to include all subrepositories.

5 Select Hide repositories that do not contain files to ignore empty repositories.
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6 Click OK.

The report is generated.

Click Print to print the report.

Click Save As to save the report as a text file.

7 Click OK to close the report.
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Managing Triggers

Triggers enhance and expand Surround by letting you run a script or send an email before, or after, 
a specific event. Triggers can be used for notifications, validation, custom text entry, logging, and 
synchronization.

About triggers, 110

Environment variables, 110

Adding triggers, 112

Editing email templates, 114

Editing triggers, 116

Duplicating triggers, 116

Disabling triggers, 116

Enabling triggers, 117

Deleting triggers, 117
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About triggers
Surround SCM includes pre- and post-event triggers that are stored on the Surround SCM server. 
Triggers can only be fired from events on files. Each trigger is run once per file that it is associated with. 
Pre-event triggers run after a client requests that a command be performed, but before the event is 
complete. These trigger types let a server script perform additional checks on a file before the event 
completes. Pre-event triggers are for validation and custom text entry, such as keyword expansion. For 
example, you can create scripts for custom keyword expansion or to verify that text, such as a copyright 
notice, is included in certain files before check in.

Post-event triggers run after a command is successfully completed on the server. These triggers can 
either run a script or send email. Post-event triggers are for logging and synchronization. For example 
you can create scripts for custom logging of SCM file activity or to synchronize two separate Surround 
SCM servers.

Email triggers use a standard email template, which can be customized, to inform selected users when 
an event occurs to a file or a set of files. Each email template is stored with the trigger on the server.

Triggers can attach to the following file events: (all), (file version updated), (new file), Add, Add from 
branch, Attach to defect, Check in, Promote from, Rebase, Remove, Rename file, Restore, Share broken, 
Share created.

i
Post-event triggers should always be used unless the trigger is used for validation purposes. 
Pre-event triggers, which are run once per file, can adversely affect performance because 
the Surround SCM server waits for the script to complete before moving to the next file. 
Even a one second pre-event script will significantly slow down the server because it will 
take one additional second per file that the trigger fires on. Post-event triggers may impact 
performance because each file affected by the action must be checked for existing 
triggers. 

Environment variables
Environment variables give scripts access to most of the event information. Any variable that does not 
apply to the event that fired the trigger will be empty. These variables can also be used with email 
templates by placing the variable name between percent (%) symbols, e.g., %SSCM_USER%.Variables 
marked with an asterisk (*) can only be used with the email template file list field code and scripts.

Variable Definition

SSCM_TRIGGERDESC Trigger description

SSCM_EVENT Event that fired the trigger

SSCM_BEFOREAFTER Indicates the trigger fired before or after the event

SSCM_DATE Date the trigger fired



111Chapter 10
Managing Triggers

SSCM_TIME Time the trigger fired

SSCM_USER User that caused the event to occur

SSCM_CLIENTIP User’s IP address

SSCM_CLIENTMACHINE User’s machine name

SSCM_MAINLINE Mainline branch the specified file is in

SSCM_BRANCH Branch the specified file is in

SSCM_BRANCHTYPE Type of branch the specified file is in

SSCM_REPOSITORY * Full repository path for the specified file

SSCM_FILE * File name

SSCM_FILEVERSION * Post-event file version

SSCM_LOCALFILE * Full path of the local file, used with Check In or Add events only

SSCM_COMMENT * File event comments

SSCM_SOURCEBRANCH Source branch used for an add/promote/rebase event

SSCM_DEFECTNUMBER * Defect number the file is attached to

SSCM_SHAREREPOSITORY Source repository the share was created from

SSCM_OLDFILENAME File’s original name, used with rename event

SSCM_PERMREMOVE File was permanently removed (yes/no)

SSCM_NUMFILES Number of files user is being notified about, used with email triggers

SSCM_FILELIST List of files for the event, used with email triggers

Variable Definition
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Adding triggers
1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Click Add.

The Add Trigger dialog opens.

3 Enter a description.
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4 Select the file options. These options specify which files fire the trigger.

Select Only in this branch: then choose a branch from the list to limit searches.

Enter a repository name or click Browse to select a repository.

Select Recursive to search all subrepositories in the specified repository.

Enter the File(s) you want the trigger to fire for. You can enter a file name or wildcard characters.

Select Use regular expression to perform a regex-style search instead of a wildcard search.

Select Match case to enable case-sensitive searching.

5 Select the Event options. These options specify when the trigger fires.

Select before to add a pre-event trigger or after to add a post-event trigger.

Select a file event from the list.

To add a disabled trigger, clear Enabled.

Select Disable trigger after it runs once if you only want the trigger to run one time. For example, you 
may want to send an email once after a particular user checks in a file.

6 Select the Action options. These options specify what happens when the trigger fires.

Select Run this script: and enter the full server script path. For security reasons, you cannot browse for 
a script.

Select Send an email if you are adding an email trigger. Select users from the list of Surround SCM 
users. To add non-Surround users, click Add Email and enter an email address.

Select Consolidate multiple file actions into one email to send one email for all files affected by the event. 
If this option is not selected, an email is sent for each file.

Click Edit email template to modify the standard email. For more information see Editing email 
templates, page 114.

Note:  Security is not checked when email is sent. If users request to receive email when any 
file is checked in to a mainline branch, they will receive an email if a file is checked in to a 
repository that they are normally restricted from viewing. If your security restrictions are 
set this way, it is recommended that the Surround SCM administrator manage all email 
triggers and that general users do not have access to the My Email Notifications command.

7 Click OK.

The trigger is added.
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Editing email templates
Each trigger you create begins with a basic email template that can be customized. Email templates are 
stored with triggers on the server.

1 Click Edit Email Template on the Add Trigger or Edit Trigger dialog box.

The Edit Email Template dialog box opens with the Edit Email tab selected.

2 You can use the default subject or customize it.

The default subject line returns the following: UserName performed the following event on the specified 
number of files. To customize the subject enter text and event variables. For example, if you are adding a 
trigger to notify project leads when files are shared, you can change the subject line to: %SSCM_USER% 
performed a %SSCM_EVENT% into %SSCM_REPOSITORY%.

3 You can use the default body or customize it.

To customize the body text enter text and event variables. You can type the variables or select a variable 
from the menu and click Insert.

4 Select an email recipient option.

If security is an issue, select Each email has a single recipient to ensure privacy.

5 Select Send email in HTML format to send HTML-formatted email.
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6 Click the File List tab.

You can provide detailed file information in email notifications. The information on this tab replaces the 
%SSCM_FILELIST% field code, on the Email Template tab, when the notifications is sent.

7 You can use the default file list information or customize it.

You can type the variables or select a variable from the menu and click Insert.

8 Click OK.

The template is saved with the selected trigger.

i
When you customize a template any spaces and lines that you add are saved with the 
template. Text is automatically wrapped to the next line as you type. When an email 
message notification is sent all field codes are automatically replaced with the 
corresponding Surround SCM data.
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Editing triggers
1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Select a trigger and click Edit.

The Edit Trigger dialog opens.

3 Make any changes.

You can edit all trigger information, including the email template.

4 Click OK.

Your changes are saved.

Duplicating triggers
If you need to create a trigger that is similar to an existing one you can duplicate the existing one then 
edit the new trigger.

1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Select a trigger and click Duplicate.

The trigger is duplicated. It is added below the selected trigger.

3 Select the new trigger and click Edit.

4 Make any changes and click OK.

Your changes are saved.

Disabling triggers
When a trigger is created it is enabled. If you do not want a trigger to fire you can disable it temporarily 
instead of deleting it. Disabled triggers do not fire event if the event occurs.

1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Select a trigger and click Disable.

The trigger is disabled.
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Enabling triggers
1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Select a trigger and click Enable.

The trigger is enabled.

Deleting triggers
Delete triggers if they will not be used again. This action cannot be undone.

1 Choose Tools > Administration > Triggers.

The Triggers window opens.

2 Select a trigger and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The trigger is deleted.
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Chapter 11
Integrating with TestTrack Pro

Integrate Surround SCM with TestTrack Pro to provide a complete change management solution! 
Surround SCM’s two-way, seamless integration with TestTrack Pro provides complete change 
management by tracking what changed and why. This integration lets you link changes with defects, 
feature requests, and change requests. Files can be accessed from Surround SCM or TestTrack Pro.

Enabling TestTrack integration, 120

Setting TestTrack integration options, 123

Configuring TestTrack database connections, 121

Entering TestTrack user information, 122

Linking with defects, 124
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Enabling TestTrack integration
Integrating Surround SCM with TestTrack Pro lets users access source files and the following commands 
from TestTrack Pro: Attach file, Detach file, Get, Check in, Check out, Undo Check out, View, and 
History. For more information, refer to the TestTrack Pro user guide.

The following example illustrates the integration with TestTrack Pro. A defect is created in TestTrack Pro 
and assigned to Jane to fix. In Surround SCM, Jane checks out the source file and fixes the bug. When she 
checks in the file, she clicks Link with Defects. In the Link with Defects dialog box, she selects the 
TestTrack Pro database to view her assigned defects. She then selects the appropriate defect and attaches 
the file to it. TestTrack Pro users with security access to the Source Code tab can work with the file Jane 
attached.

1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens.

2 Select Enable TestTrack Pro integration on the General tab.

3 Click OK.

The integration is enabled. 

i
Next, the Surround SCM administrator should configure TestTrack Pro connections. For more 
information see Configuring TestTrack database connections, page 121. Users can then enter 
their TestTrack Pro login information. For more information see Entering TestTrack user 
information, page 122.
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Configuring TestTrack database connections

Note:  The administrator or another high-level user is generally responsible for configuring 
database connections.

Configure the connection to provide users with access to TestTrack Pro servers and databases. You can 
limit users to a specific database or let users choose a database when checking in, and linking, source 
files with TestTrack Pro defects. For more information see Setting TestTrack integration options, page 123.

Adding database connections
1 Choose Tools > TestTrack Pro Integration > TestTrack DB Connections.

The TestTrack Connections dialog box opens.

2 Click Add.

The Add TestTrack DB Connection dialog box opens.

3 Enter a Connection name.

This required field uniquely identifies the database. Enter a name that is meaningful to users to help 
users select the correct database. For example, name a connection Beta Bugs instead of BB1.

4 Enter the TestTrack Pro Server address and Port number.

These fields are required.

5 Click Get Databases to retrieve a list of all databases from the TestTrack Pro server.
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6 Select a Database.

7 Click OK.

The database connection is added.

8 Click OK to close the TestTrack Connections dialog box.

Editing database connections
1 Choose Tools > TestTrack Pro Integration > TestTrack DB Connections.

2 Select the configuration and click Edit.

3 Make any changes and click OK.

4 Click OK to close the TestTrack Connections dialog box.

Deleting database connections
1 Choose Tools > TestTrack Pro Integration > TestTrack DB Connections.

2 Select the configuration and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The database connection is deleted.

4 Click OK to close the TestTrack Connections dialog box.

Entering TestTrack user information
You need to enter your TestTrack Pro login information before you can link with defects.

1 Choose Tools > TestTrack Pro Integration > TestTrack User Settings.

The TestTrack Pro User Settings dialog box opens.

2 Select Use Surround SCM username and password if you use the same login information for TestTrack Pro.
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3 Select Use the following: and enter your TestTrack Pro username and password if you use different login 
information for TestTrack Pro.

4 Click OK.

You can now link Surround SCM source files with TestTrack Pro defects.

Setting TestTrack integration options
You can configure TestTrack Pro integration settings for repositories.

1 Select a repository and choose Activities > Properties.

The Properties dialog box opens.

2 Click the TestTrack Pro Integration tab.

This tab is used to configure TestTrack Pro integration settings for the selected repository.

3 Select Configure repository settings to set TestTrack Pro integration options for the selected repository.

This option overrides the parent repository settings.

4 Select Can override default TestTrack DB Connection to let users choose a TestTrack Pro database. 

5 Select a database from the Default TestTrack DB Connection menu to restrict users to a specific databases.

Make sure Can override default TestTrack DB Connection is not selected.

6 Select an option from the Check in options menu. 

You can enable, disable, or require the user to attach a file to a defect when checking in the file.

7 Click OK to save changes.
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Linking with defects
When you check in files you can link the source files with TestTrack Pro defects. Files can be accessed 
from Surround SCM or TestTrack Pro. You can link multiple Surround SCM files with one defect or one 
Surround SCM file with multiple defects.

1 Select the files or repository. 

2 Choose Activities > Check In.

The Check in File(s) dialog box opens.

Note:  See Checking in files, page 84 for detailed information about check in options.

3 After selecting check in options click Link with Defects.

The Link with TestTrack Pro Defects dialog box opens.

Note:  Click Configure DB if you need to configure database connections. For more 
information see Configuring TestTrack database connections, page 121.
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4 Select a database from the TestTrack DB menu.

5 The TestTrack Pro defects list is populated with your assigned defects. Select a select filter to change 
which defects are displayed.

6 Select the defects you want to attach the files to.

When you select a defect, read-only defect summary and description information is displayed. To select 
multiple defects Ctrl+click each defect.

7 Select the files you want to link with defects.

To select multiple files Ctrl+click each file.

8 Click Link File to link the selected source files with the selected defects.

The files are added to the Linked File(s) list. If you attach a file by mistake select it and click Undo Link.

9 Click OK when you finish attaching files.

The Surround SCM files are linked with the TestTrack Pro defects. TestTrack Pro users can access the 
Surround SCM files via the TestTrack Pro Source Code tab.

TestTrack Pro 
Source Code tab
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Integrating with IDEs

The SCCI interface lets you access Surround SCM commands from most Windows-based 
development environments. This integration accelerates development efforts because the most-used 
Surround SCM functions are available from within the tool you use.

About IDE integration, 128

Adding files, 128

Working with files, 130
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About IDE integration
Surround SCM conforms to the Microsoft Source Code Control Interface (SCCI) standard, allowing you 
integrate Surround SCM with SCCI-compliant applications including TestTrack Pro, Microsoft Visual 
Studio and Visual Studio .NET, Macromedia Dreamweaver, and Borland JBuilder. Functionality is based 
on the tool you are integrating with Surround SCM. Most integrations include access to basic source 
control commands, such as Check In, Check Out, and Undo Check Out.

Note:  During installation, you are prompted to select Surround SCM integration options. If 
you did not select an option and want to integrate Surround SCM with a SCCI-compliant 
application reinstall Surround SCM and select the appropriate integration option.

Adding files

i
Visual Studio .NET is used to illustrate the integration. These commands can also be accessed 
through other IDEs. Refer to the application’s documentation for information specific to the 
IDE you are working with. 

You can add all files in a workspace or a project to Surround SCM. You can also add single files to 
Surround SCM. This example illustrates adding all files in a repository.

1 Open the solution that contains the files you want to add to source control.

2 Select the FileView pane.

The FileView pane shows relationships among the projects and files included in the project workspace. 
This pane also includes icons that provide information about the files.

3 Choose Project > Source Control > Add to Source Control.

You may be prompted to configure your Surround SCM connection. Enter the server name, port 
number, your username and password, and click OK. See Changing your password, page 8 for 
information.
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4 The SCM Repository Browser opens.

5 Select the branch that contains the repository you want to use. Next, select the repository that contains the 
files you want to add and click OK.

You can also create a new repository. Source control files are added to the new repository. For more 
information, see Creating repositories, page 40.

6 The Add to Source Control dialog box opens.

All files found in the repository are selected. Clear the check box if you do not want to add a file to 
source control.

7 Click Advanced to select advanced add options.

The Advanced Add Options dialog box opens.
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8 Select any options and click OK.

You return to the Add to Source Control dialog box.

9 Click OK to add the files.

The selected files are added to Surround SCM.

The icons in the FileView pane change. Grayed icons indicate a project or file is under source code 
control. A check mark next to the icon indicates you have the file checked out.

Errors and status messages are displayed on the Output window Source Control tab.

Working with files
You can access the following Surround SCM commands from Visual C++: check out, check in, and undo 
check out. You can also view history or differences and view file properties.

Check out
Check out files when you need to make changes. You can check out single files, multiple files, or all files 
in a project. Surround SCM creates a read-write copy of the file in the working directory. See Checking out 
files, page 80 for more information.

1 Select the files or project. Choose Project > Source Control > Check Out.

The Check out file(s) dialog box opens.
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2 Click Advanced to select advanced check out options.

The Advanced Check Out Options dialog box opens.

3 Select any options and click OK.

You return to the Check out file(s) dialog box.

4 Click OK.

The files are checked out and ready for editing. 

Undo check out
If you have a file checked out and need to revert changes, you can undo the check out command. See 
Undoing check out, page 86 for more information.

1 Select the files or project. Choose Project > Source Control > Undo Check Out.

The Undo Check Out dialog box opens.

2 Click Advanced to select advanced undo check out options.

The Advanced Undo Check Out Options dialog box opens.

3 Select a file overwrite option and click OK.

You return to the Undo Check Out dialog box.
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4 Click OK.

Make sure you selected the appropriate file overwrite option. Depending on the option you choose, any 
changes you made to the file are lost when you undo the checkout. This action cannot be undone.

Check in
Check in files after you finish making changes. Check in updates Surround SCM with changes, removes 
the lock on the files, and makes the changes available to other users. The version number is also 
incremented by one. See Checking in files, page 84 for more information.

1 Select the files or project. Choose Project > Source Control > Check In.

The Check in file(s) dialog box opens.

2 Click Advanced to select advanced check in options.

The Advanced Check In Options dialog box opens.

3 Select any options and click OK.

You return to the Check in file(s) dialog box.

4 Click OK.

Surround SCM automatically merges changes when files are checked in. This ensures that changes are 
not accidentally lost or overwritten.
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Show history
The history dialog box provides a convenient way to view a source file’s history and work with a historic 
version of the file. You can view file details, get or check out a file, create a label, select two version of a 
file to see differences, and view or edit the file. You can also filter the history to display specific files. See 
Viewing file history, page 83 for more information.

1 Select the file. Choose Project > Source Control > Show History.

The History dialog box opens. This dialog box includes a summary of historic version information.

2 Optionally select a user from the Filter by user menu.

3 Optionally select an action from the Filter by action menu.

4 Select an entry and click Details to view the file version details.

5 Click Get to get the selected version of the file.

6 Click Check Out to check out the selected version of the file.

7 Click Create Label to label the selected version of the file.

8 Click Differences to compare two selected versions of the file.

9 Click View File to view the selected version of the file.

10 Click Edit File to edit the selected version of the file.

11 Click Rollback File to revert to a previous file version.

12 Click Close to close the file history.
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Show differences
Provides a visual display of the differences in a file. See Diffing files, page 90 for more information.

1 Select the file. Choose Project > Source Control > Show Differences.

If there are differences, the diff utility opens.

File properties
You can view general and check out information about the selected file.

1 Select the file. Choose Project > Source Control > Surround SCM Properties.

The Properties dialog box opens with the General tab selected. This tab includes read-only information 
about the file. The Check Out tab includes read-only file check out information.

Refresh status
Refreshes the status of all files included in the project. Use this command if you change the status of one 
or more opened files using external tools.

Surround SCM
Launches the Surround SCM application.
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Chapter 13
Managing the Server

Configure it once and forget about it! Surround SCM’s cross-platform design centralizes mail, 
logging, and other server settings.

Setting general options, 136

Setting log options, 138

Setting email server options, 139

Setting email options, 140

Setting license server options, 141

Managing the mail queue, 142

Managing the server log, 143
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Setting general options
1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens with the General tab selected.

2 Select Expand keywords to enable keyword expansion.

Keywords are case sensitive placeholders that can be inserted into text files and expanded upon check in. 
Keywords cannot be expanded for binary files. The following keywords are supported:

$Author$ - Name of the user who checked in the last revision

$Date$ - Date and time of the last revision

$Header$ - File, Revision, Date, Author

$File$ - Unqualified name of the file

$Revision$ - Revision number

$Log$ - File history in RCS-style format
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3 Select Allow multiple users to check out a file to enable multiple check outs of the same file.

4 Select Enable TestTrack Pro integration to integrate Surround SCM and TestTrack Pro.

5 To require a minimum comment length enter the minimum number of characters.

This option applies to all commands with comment fields, such as check in or rebase.

6 Select Enable compression of files stored on the Surround server to compress server files.

Enable compression to make sure files use as little disk space as possible. Compression may slow 
performance due to the time needed to compress and decompress files.

7 Select Encrypt server communications to encrypt messages sent between the client and the server.

Encryption provides a higher level of security but may slow performance due to the time spent to 
encrypt and decrypt messages.

8 Select Enable Guiffy for automatic merges to use the Guiffy diff/merge utility for automatic merges.

The diff3 merge application, which is used by default, is faster than Guiffy on the server and uses less 
memory. However diff3 and Guiffy use different algorithms for determining conflicts. You may want to 
use the same merge application on both the client and the server.

9 Enter the number of MB of memory you want Guiffy to use.

The recommended setting is 128 MB. This setting should not exceed 50% of the server computer’s 
physical memory. Depending on the amount of available RAM you may want to set this lower. If you set 
the amount of memory too high other applications can be negatively affected.

10 Enter and confirm a new password to change the local SCM admin password.

When Surround SCM is installed, a local SCM admin user is created. If your existing username and 
password are not recognized, you can login using the local SCM admin password, leaving the username 
blank and entering admin as the password.

Note:  It is strongly recommended that you change the local SCM admin password.

11 Select any Unicode file options.

These options are used by Guiffy when auto-merging text files. Surround SCM includes limited Unicode 
support of file contents only. Unicode support does not include metadata (file names, comments, etc.). 
Surround SCM supports UTF-8 and UTF-16 encoding. 

Select Auto-detect text files as type UTF-8 text to add files as UTF-8 text files. If all files are Unicode, or 
Unicode standards are not followed, select this option. For example, if you are adding 500 files and 
only a few are text files, select this option. You can then go to file properties to mark the text files.

Select Use UTF-8 encoding for all text file auto-merges to automatically use UTF-8 encoding for auto-
merges. If this option is selected it does not matter if a file is marked as text or UTF-8. Guiffy will use 
UTF-8 encoding when auto-merging files.
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Select a UTF-8 character encoding set.

Select a UTF-16 character encoding set.

Note:  The larger international version of the Java Runtime Environment (JRE) contains 
character conversion classes and support for locales other than the US English locale. If you 
use this JRE you can type in the character encoding set you want to use. Refer to Guiffy 
Help for a list of all supported character sets.

12 Click OK to save the settings.

Setting log options
You can set Surround SCM server log options, such as the level of messages. The log file includes 
information about problems that occur during start up and while Surround SCM server is running.

1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens.

2 Click the Logging tab.

3 Select a Write to server database option.

This specifies the types of messages that are written to the Surround SCM server log file.

4 Select a Write to NT event log option. 

This specifies the types of messages that are written to the server’s NT log.
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5 Select an Email notification logging option.

This specifies the types of server messages that generate email notifications. To generate email 
notifications, you must also enter an email send to address, select an email address type, and enter an 
email return address.

Note:  Select No Logging if you do not want to generate email notifications.

6 Select Write all message to SCMStartup.log to write messages to this log file. 

The log file is usually stored in the same directory as the Surround SCM server executable. 

7 Click OK to save the settings.

Setting email server options
You can select the mail protocol used with email notifications.

1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens.

2 Click the Email Servers tab.

3 Select Enable sending mail via MS Mail / Exchange to send email in MAPI format.

Select a Profile Name.

Enter a password.
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4 Select Enable sending mail via Simple Mail Transport Protocol to send email via SMTP.

Select Only send one message per SMTP connection to send one message per connection.

Enter the SMTP Host used to send outgoing mail. Enter an IP address (e.g., 123.34.5.26) or your mail 
server’s fully qualified domain name (e.g., mail.your company.com).

Enter a Username and Password.

Note:  Only pause email if you are experiencing problems and need to troubleshoot. Select 
either of these options will back up outgoing mail.

5 Click OK to save the settings.

Setting email options
1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens.

2 Click the Email Options tab.

This tab is used to specify the return address used for email notifications

3 Select Always use the notification email account for the return address to use the notification email account. 

4 Select Only use notification account if the logged in user’s email address is blank to use the notification email 
account if the logged in user did not provide an email address. 

5 Enter a notification account name. The notification account name defaults to “Surround SCM.” You will 
probably want to customize the account name for your company

6 Enter an email address. If you do not enter an email address, your email may be rejected. Some Internet 
providers will not accept email without a return address. 

7 Click OK to save the settings.
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Setting license server options
1 Choose Tools > Administration > Server Options.

The Server Options dialog box opens.

2 Click the License Server tab.

3 Enter the address and port number of the license server you want Surround SCM to connect to.

4 Optionally enter a license server password.

The license server password provides additional security. If a password is entered on the license server, 
Surround SCM must use the same password to communicate with the license server.

5 Select a cache refresh rate.

6 Click Test Connection to test the license server connection.

If the connection is not successful, check the address, port number, and password.

7 Click OK to save the settings.
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Managing the mail queue
When Surround SCM sends email the message is placed in the mail queue for processing by the server. If 
all mail is not sent before the Surround SCM server is shut down, the mail queue is saved to the hard 
drive. The next time the server is started, the mail queue is reloaded and mail is sent.

The mail queue only contains unsent email messages. Under normal circumstances, email is sent and 
removed from the mail queue in less than 60 seconds. An email can get stuck in the mail queue if send 
mail is paused, the MAPI or SMTP options are not properly configured, or the MAPI or SMTP host is 
experiencing problems.

Viewing the mail queue
1 Choose Tools > Administration > Mail Queue.

The Mail Queue window opens with a list of all unsent email messages. The list includes the email date, 
number of attempts made to send the email, and the email subject.

2 Select a message to view details.

The name, email address, mail type, and send error are listed in the Recipients area. 

3 Click Close when you are finished.

Resending mail
1 Choose Tools > Administration > Mail Queue.

The Mail Queue window opens. 

2 Select the email message you want to resend and click Reattempt.

Surround SCM attempts to resend the message.
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Deleting mail
1 Choose Tools > Administration > Mail Queue.

The Mail Queue window opens. 

2 Select the email message(s) you want to delete.

3 Click Delete.

The email message is deleted from the mail queue. 

Managing the server log
1 Choose Tools > Administration > View Server Log.

The View Server Log dialog box opens.

2 To filter the log entries select a Filter from the menu. You can filter the log list even more by choosing one 
of the following options:

and More Severe includes the filtered log entries plus more severe entries

and Less Severe includes the filtered log entries plus less severe entries

Only limits the filter to the filtered log entries

3 Select the entry you want to view.

The details appear in the Selected Log Entry area.

4 Click Close when you finish viewing log entries.
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Deleting all log entries
If you are not experiencing any problems, you can periodically delete all of the log entries.

1 Choose Tools > Administration > View Server Log.

The View Server Log dialog box opens. 

2 Click Delete All.

You are prompted to confirm the deletion.

3 Click Yes.

The entries are deleted from the log. 

Deleting log entries by date 
If the log becomes too large, and you are not experiencing problems, you can delete older entries.

1 Choose Tools > Administration > View Server Log.

The View Server Log dialog box opens. 

2 Click Delete by Date.

The Delete Entries by Date dialog box opens.

3 Enter a date in the Date field.

4 Click OK.

You are prompted to confirm the deletion.

5 Click Yes.

All log entries, including any entries that occurred on the date you entered, are deleted.
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Chapter 14
Configuring Security

Protect your data integrity and security by configuring security for all user levels. Surround SCM can 
be configured to provide as much, or as little, security as needed. Access to Surround SCM 
commands, such as promoting a branch, is controlled by the security set for each group. You can also 
configure repository and branch security.

About security, 146 

Planning security, 146

Setting server security, 147

Setting repository security, 148

Setting branch security, 148

Security notes, 150
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About security
Surround SCM security is extensive and configurable and can be applied at the server level, to 
repositories, or to a specific branch in a repository. Security is always applied recursively unless it is 
overridden. You can access security in two ways:

Repository and branch properties let you easily view, and configure, security for a specific repository 
or branch. For more information, see Configuring repository security, page 42 or Configuring branch 
security, page 57.

The Security groups view lets you easily view, and configure, security for a selected group of users. 
For more information, see Editing security groups, page 159. 

Planning security
One of the first things to do, before you start adding security groups, is to group users together based on 
function. It may be helpful to create a list of the types of users who will be accessing Surround SCM and 
what their needs are. You should also consider your company’s process and define roles and 
permissions accordingly. A strong security model allows you to be flexible in assigning access without 
risking data integrity. The following questions can help you get started:

What types of users will be accessing Surround? For example, project leads, programmers, and 
testers. 

What level of security do groups need? For example, access to promote and rebase files.

Will users have access to all repositories? For example, restrict teams to specific repositories.

How does the build process work? For example, apply read-only branch security after a software 
release.

i
For example, a project team might includes one or more of the following:

An administrator who has access to all commands.

A project lead who has access to most commands but is restricted from such things as creating 
mainline branches, adding users, or editing server options.

One or more developers who have access to most file and branch commands but are 
restricted from most admin, user, and group commands.

One or more testers who only have access to basic commands such as getting and viewing 
files.

A customer who is restricted to viewing one repository.
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Setting server security
Note:  Many companies will only need to set server security. Server security is always used 
unless it is overridden at the repository level.

Server security is grouped into the following categories: admin, users, groups, files, and branch. The 
commands you enable or disable for a group apply to all repositories in the mainline branch. Server 
security is set when security groups are created or changed by editing security groups. For more 
information see Chapter 15, “Managing Users and Security Groups,” page 151.

Admin
Contains the following commands used to administer Surround SCM: Edit Server Options, Edit 
TestTrack Pro Integration, Create Mainline Branch, Remove Mainline Branch, Create Label, Run Reports, 
Void Check Out, Work with Shadow Folders, Edit Triggers, Edit Own Email Notifications, Edit Mail 
Queue.

Users
Contains the following commands used to manage Surround SCM user accounts. Include the following 
commands: Add User, View User, Edit User, Delete User, Edit Other Users Password, 
Activate/Inactivate User, Edit Own Password, Edit Own TestTrack Pro Settings.

Groups
Contains commands used to manage security groups. Include the following commands: Add Group, 
View Group / Security, Edit Group / Security, Delete Group.

Files
Contains commands used to work with files. Include the following commands: View Repository List, 
Add File, Remove File, Destroy File, Get File, Check In File, Change File Type, Change File Properties, 
View File History, Share Files, Break Shares.

Branch
Contains commands used to manage branches. Include the following commands: Create Baseline 
Branch, Use Workspace Branch, Create Snapshot Branch, View Branch History, Delete Branch, Destroy 
Branch, Destroy Other User’s Workspace Branches, Promote Branch, Rebase Branch, Rename Branch, 
Freeze/Unfreeze Branch.
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Setting repository security
You can override the server security and enable/disable file commands for a selected repository. The 
security you set affects all branches in the selected repository. For example, you have multiple products 
and customers. You provide access to Surround SCM for a customer. You do not want this customer to 
be able to view all repositories. Restrict the customer to a specific repository by setting repository 
security. For more information, see Configuring repository security, page 42.

Setting branch security
You can override the server security and enable/disable file commands for a specific branch in a 
repository. The security you set only affects one branch in the selected repository. For example, you 
branch your code into multiple versions. When development starts in a new version, you only want the 
development group and projects leads to have access to the branch. You can set branch security that 
restricts all other groups from accessing the specific branch. For more information, see Configuring branch 
security, page 57.

Security scenarios
The following sample scenarios are provided to help you understand how the different security levels 
work. Depending on your company’s needs and business processes, you may only want to set server 
security. If your needs are more complex, or your business process dictates restricting users to specific 
data, you may decide to set repository and/or branch security.

Overview
WysiCorp, a fictional company, develops customized software applications for multiple customers. 
Many of these customers are competitors and require a high level of security and confidentiality. To 
ensure that all development goals are met, WysiCorp’s development teams, TeamA and TeamB, are 
assigned to one company for the duration of a project. Other teams, such as Project Leads and QA, may 
be assigned to more than one company at a time.

WysiCorp, the mainline branch, includes the following repositories: Client and Server. The Client 
repository includes two subrepositories, CompanyA and CompanyB. The CompanyA subrepository 
includes two baselines branches, Development and Released.

Server security
Members of the Project Leads security group are administrators and have access to all commands. 
Members of the TeamA and TeamB security groups have access to some commands, such as adding files 
or viewing file history. The QA security group is restricted to read-only security.
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Repository security
WysiCorp does not want TeamA members to have access to the CompanyB subrepository or TeamB 
members to have access to the CompanyA subrepository. Repository security is applied to the 
CompanyA and CompanyB subrepositories. The TeamA security group is restricted from viewing the 
CompanyB subrepository. The TeamB security group is restricted from viewing the CompanyA 
subrepository. 

When viewing CompanyA repository properties, the Inherited From column changes from <server level 
default> to <not inherited> for the TeamB security group. This indicates the server security is overridden.

Branch security
After code is released to customers, it is important to stop development on that code. Branch security, 
limited access to the release code, is applied to the Released branch in the CompanyA subrepository. The 
TeamB security group is restricted from viewing the CompanyB subrepository. In addition, all other 
groups only have list-only access to the Released branch. 

When viewing CompanyA repository properties, notice the only groups listed are Team B and <All other 
groups>. In addition, the Inherited From column changes from <server level default> to <not inherited>. This 
indicates the server security is overridden.
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Security notes
The ability to create a repository requires “Add File” permission. The ability to remove a repository 
requires “Remove File” permission.

To perform a promote or rebase action, you must have promote or rebase permission. In addition, 
you must also have some file permissions on the repository being promoted/rebased to. To promote 
to a branch, you must have the “Add File” permission to promote an add, the “Check In File” 
permission to promote a change, and the “Remove File” permission to promote a remove. To rebase 
to a branch, you must have the “Add File” permission to rebase an add, the “Check In File” 
permission to rebase a change (and “Get File” in the parent branch), and the “Remove File” 
permission to rebase a remove.

To create a share in a destination repository, you must have “Add File” permission in that repository.

If you have “Check In File” permission on a repository, you can check out (and in) a shared file even 
if the file is shared with a repository you do not have “Check In File” permission for.

To set branch security, you must first configure a branch to “Use its own security.” 
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Chapter 15
Managing Users and Security Groups

A user is anyone who can access Surround SCM and belongs to one or more security groups. 
Surround SCM users can only access commands granted to the security group they belong to. A 
security group is a collection of users who share responsibilities and perform similar tasks.

About users and security groups, 152

Adding security groups, 152

Adding users, 155

Retrieving global users, 157

Viewing users, 158

Viewing security groups, 158

Editing users, 159

Editing security groups, 159

Deleting users, 161

Deleting security groups, 161



152 Chapter 15
Managing Users and Security Groups

About users and security groups
Surround SCM includes global and local users. Users can be created using the license server admin 
utility or Surround SCM. Global users have access to all databases and can be created using the license 
server admin utility or in Surround SCM. Local users cannot log into Surround SCM and can only be 
created in Surround SCM.

A security group is a collection of users who share responsibilities and perform similar tasks. A security 
group is a collection of users who share responsibilities and perform similar tasks. Security groups let 
you create a security structure for users. You can add as many or as few security groups as you need and 
make the security as general or as specific as you need.

Before you start creating security groups, it may be helpful to list the types of users you will be adding to 
Surround SCM and what their needs are. You can add as many or as few security groups as you need.

Adding security groups

Note:  When Surround SCM is installed, a default Admin group is created. This group has 
access to every command. Carefully consider which users are added to this group.

1 Choose View > Security Groups.

The Security Groups window opens.
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2 Click Add.

The Add Security Group dialog box opens with the Users tab selected.

3 Enter a Name and Description.

4 Select a user and click Add to add users to the group.

To add multiple users, Ctrl+click each user.

5 Click the Server Security tab to set server security. 

Make sure you set server security for all categories. See Setting server security, page 147 for a list of all 
commands.
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6 Skip the Repository Security tab.

This tab is used when editing groups to set security for specific repositories. See Configuring repository 
security, page 42 for details.

7 Skip the Branch Security tab.

This tab is used when editing groups to set security for a specific branch in a repository. See Configuring 
branch security, page 57 for details.

Note:  The Branch Security tab is hidden unless a branch uses its own security.

8 Click the Notes tab and enter any information about the security group.

9 Click OK to save the security group.
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Adding users
Users can be created using the license server admin utility or Surround SCM. If you create users with the 
license server admin utility you may need to retrieve global users. See Retrieving global users, page 157 
for more information.

1 Choose View > Users.

The Users window opens.

2 Click Add.

The Add User dialog box opens with the Info tab selected.

3 Enter the user information.

Enter a First name.

Enter a Last name.

Enter a Username.
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4 Enter the information on the Info tab.

Enter the user Phone Numbers.

Select an email type and enter the user Email Address.

Enter and confirm a user Password. Users can change their passwords when they login.

5 Click the Groups tab to select the security groups you want the user to belong to.

To access Surround SCM users must be assigned to at least one security group. If you need to create 
security groups see Adding security groups, page 152.

6 Click the License tab.

Select a license type for the user.
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7 Click the Address tab.

Enter the user’s address information.

8 Click the Notes tab.

Enter any notes about the user.

9 Click OK.

The user is added.

Retrieving global users
Global users, which reside on the license server, can be retrieved and provided access to Surround SCM.

1 Choose View > Users.

The Users window opens.
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2 Click Retrieve Global User.

The Retrieve Global User dialog box opens.

3 Select the global users you want to add to Surround SCM and click Add.

The global users can now access Surround SCM.

Viewing users
1 Choose View > Users.

The Users window opens.

2 Select the user and click View.

The read-only View User dialog box opens.

3 Click Close when you finish viewing the user information.

Viewing security groups
1 Choose View > Security Groups.

The Security Groups window opens.

2 Select the group and click View.

The read-only View Security Group dialog box opens.

3 Click Close to close the dialog box.
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Editing users
You can edit most user information. The username cannot be changed.

1 Choose View > Users.

The Users window opens.

2 Select the user and click Edit.

The Edit User dialog box opens.

3 Make any changes.

and click OK.

Editing security groups
You can edit most security group information including security permissions. The security group name 
cannot be changed.

1 Choose View > Security Groups.

The Security Groups window opens.

2 Select the group and click Edit.

The Edit Security Group dialog box opens.

3 Click the Users tab to add users to/remove users from the security group.

4 Click the Server Security tab to modify server security.

Server security is the default security and affects all repositories in the mainline branch. For more 
information see Setting server security, page 147.
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5 Click the Repository Security tab to modify repository security.

Repository security lets you override server security for all branches in the selected repository. For more 
information see Configuring repository security, page 42.

6 Click the Branch Security tab modify branch security.

Branch security lets you override server security for the branch. This tab is hidden unless a branch uses 
its own security. For more information see Configuring branch security, page 57.

7 Click OK to save any changes.
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Deleting users
When a user is deleted, all of the corresponding historic information is also deleted. Inactivate a user if 
you need to save historic information. 

1 Choose View > Users.

The Users window opens.

2 Select the user(s) and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

Deleting security groups
When a security group is deleted, all of the corresponding historic information is also deleted.

1 Choose View > Security Groups.

The Security Groups window opens.

2 Select the security group and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.
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Using the Analyze Utility

Maintaining healthy databases is important - you need to make sure your source code files are always 
accessible. Surround SCM includes a utility that analyzes, and repairs, database corruption issues.

About the analyze utility, 164

Analyzing databases, 164

Repairing databases, 166

Compacting databases, 167

Converting databases, 168
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About the analyze utility

Note:  The Surround SCM administrator, or another user with security permission, is usually 
responsible for running the analyze utility.

The analyze utility checks for corrupt or truncated database files. These errors can result from server file 
system corruption due to such things as power failures. It also validates shared file links. The utility can 
be run in analyze or repair mode. Analyze mode lets you preview errors. Repair mode automatically 
fixes the errors and reports the changes.

You should run the analyze utility before upgrading a database or after the server computer is 
stopped/restarted “uncleanly” (e.g., power failure). The utility should also be run if you suspect there is 
a database problem. For maintenance, you may want to run the utility once a month even if you are not 
experiencing any problems.

Before you run the utility, make sure the Surround SCM server is stopped. When the utility is run on a 
mainline database in use by a server, the cached data files may be changed. If you run the utility, and the 
mainline database is in use, an error message is returned.

The analyze utility must be run from the server or a computer with direct access to the database 
directories. The user running the utility must have read/write access to the database directories.

Analyzing databases
The utility should be run in analyze mode first. This lets you view any errors and back up the database 
before running the utility in repair mode.

1 On the Start menu, choose Programs > Seapine Software> Surround SCM > Surround SCM Analyze Utility.

The analyze utility opens.
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2 Choose File > Open Database to select the database you want to analyze.

The Open Database dialog box opens. All databases found in the Surround SCM directory is displayed.

3 Select a database and click OK.

To analyze a removed mainline branch click Browse to select the database.

4 You return to the analyze utility, which is populated with the selected database information

5 Click Analyze to analyze the selected database.

The Advance Analyze dialog box opens.
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6 Select any options and click OK.

The database is analyzed. The Results area includes information about the database and any errors that 
were found.

7 Click Print Results to print the results.

You can also copy the text and paste it into another program.

8 Click Close to close the utility.

Repairing databases
After analyzing a database run the utility in repair mode to fix any errors. Make a backup copy of the 
data before you repair the database. If an error occurs during the repair process you will be able to 
restore the data.

Note:  Analyze the database before repairing it to preview any errors or corruptions.

1 On the Start menu, choose Programs > Seapine Software > Surround SCM > Surround SCM Analyze Utility.

The analyze utility opens.

2 Choose File > Open Database to select the database you want to repair.

The Open Database dialog box opens.

3 Select a database and click OK.

To repair a removed mainline branch, click Browse to select the database.

4 You return to the analyze utility, which is populated with the selected database information.
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5 Click Repair to repair the selected database.

You are prompted to confirm that you want to repair the database.

6 Click Yes.

The utility repairs the selected database. The Results area includes information about the database and 
any fixed errors.

7 Click Print Results to print the results.

You can also copy the text and paste it into another program.

8 Click Close to close the utility.

Compacting databases
1 On the Start menu, choose Programs > Seapine Software > Surround SCM > Surround SCM Analyze Utility.

The analyze utility opens.

2 Choose File > Open Database to select the database you want to compact.

The Open Database dialog box opens.

3 Select a database and click OK.

To compact a removed mainline branch, click Browse to select the database.

4 You return to the analyze utility, which is populated with the selected database information.

5 Click Compact to compact the selected database.

You are prompted to confirm that you want to compact the database.
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6 Click Compact.

The utility compacts the selected database.

7 Click Print Results to print the results.

You can also copy the text and paste it into another program.

Click Close to close the utility.

Converting databases
After you upgrade Surround SCM you may have server databases that need to be converted to the 
current format. Backup the files in the SCMServDb directory before converting the database.

Note:  If you need to upgrade mainline branches see Upgrading mainline branches, page 26 
for more information.

1 On the Start menu, choose Programs > Seapine Software > Surround SCM > Surround SCM Analyze Utility.

The analyze utility opens.

2 Choose File > Open Database to select the database you want to convert.

To convert a removed mainline branch, click Browse to select the database.

3 You return to the analyze utility.
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4 Click Convert to convert the selected database.

You are prompted to select the license server database.

5 Enter the full path to the license server database or click Browse to select a database.

6 Click OK.

The conversion starts. During the conversion, existing Surround SCM users (with usernames) and valid, 
non-expired licenses are added to the license server. Users that do not have usernames are converted as 
local users.

7 The results window is updated when the database conversion finishes.

Note:  If you use Surround SCM and TestTrack Pro, you may be prompted about user 
conflicts during the conversion process. For example, you convert Surround SCM before 
TestTrack Pro. A few users were setup using their full name (e.g., Deborah or William) in 
Surround SCM and using their nicknames (e.g., Debbie or Bill) in TestTrack Pro. If conflicts 
are detected, you are prompted to either use the current user information on the license 
server or the user information from the database you are converting. If users have trouble 
logging in after the conversion, ask them to try both username/password combinations.

8 Click Close to close the analyze utility.
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This section provides definitions for terms used in Surround SCM.
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Definitions
Ancestor branch
Branch a baseline, snapshot, or workspace branch is created from.

Baseline branch
Public branch that all users can access. Changes made to the baseline branch affect everyone who 
accesses that branch.

Branches
A branch uses an existing repository, and the files in that repository, as a starting point to enable 
concurrent development. When a repository is branched, the files in both branches are initially identical. 
As file contents change, the branched files become dissimilar. Use branches when you need to make 
changes to source files without affecting the existing repository.

Branch security
You can override the server security and enable/disable file commands for a specific branch in a 
repository. The security you set only affects one branch in the selected repository.

Diff
The diff command opens a utility that lets you quickly see if there are differences between server files 
and files in your working directory.

Email triggers
Triggers that use a standard email template, which can be customized, to inform users when an event 
occurs to a file or a set of files. Each email template is stored with the trigger on the server.

File types
You can add text, binary, and Mac binary files to Surround SCM.

Keywords 
Case sensitive placeholders that can be inserted into text files and expanded upon check in. Keywords 
cannot be expanded for binary files. The following keywords are supported:

$Author$ - Name of the user who checked in the last revision

$Date$ - Date and time of the last revision

$Header$ - File, Revision, Date, Author

$File$ - Unqualified name of the file

$Revision$ - Revision number

$Log$ - File history in RCS-style format



173Chapter 17
Surround SCM Glossary

Labels
Used to mark a specific version of a file or repository. Assigning labels allows for easy identification of 
all components with the same label.

Mainline branch
The highest-level branch that contains all source files, labels, other branches, and repositories. All files 
saved to a specific Surround SCM server are stored in a corresponding mainline branch.

Merge
The merge command opens a utility that lets you easily merge changes between server files and files in 
your working directory. You can merge changes into a new file.

Pre-event triggers
Triggers that are run after a client requests a command but before the event is complete. These trigger 
types let a server script perform additional checks on a file before the event completes. Pre-event triggers 
are for validation and custom text entry.

Post-event triggers
Triggers that run after a command is successfully completed on the server. These triggers can either run 
a script or send email. Post-event triggers are for logging and synchronization.

Triggers can only be fired from events on files, no triggers exist for branch-level or repository-level 
events. Files can be specified with a wildcard or a regular expression search so one trigger can affect a 
group of files. Each trigger is run once per file that it is associated with. Triggers can attach to the 
following file events:

Promote
Updates the ancestor branch with changes made in the selected branch, repository, or file.

Rebase
Updates the selected branch, repository, or file with changes made in the ancestor branch.

Recursive
If this option is selected, the command is applied to a repository and all files and subrepositories of that 
repository. For example, recursive check in simultaneously checks in all files and subrepositories of the 
selected repository.

Repository
A collection of files and/or subrepositories that helps you organize Surround SCM. Repositories are 
generally mapped to a directory on your hard drive.
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Repository security
You can override the server security and enable/disable file commands for a selected repository. The 
security you set affects all branches in the selected repository.

Server security
Server security applies to all repositories in the mainline branch. Many companies will only set this type 
of security.

Shadow folder
Contains a “reference copy” of the current files in a branch. Files are automatically updated when 
changes are checked in to Surround. Shadow folders can provide read-only access to non-Surround 
users or provide a central location to build releases from.

Snapshot branch
A static branch of a baseline or workspace branch that generally corresponds to a project milestone, such 
as a QA build or final release build. Most Surround SCM commands are disabled in snapshot branches.

Timestamp
The recorded date and time of an event.

Triggers
Enhance and expand Surround by letting you run a script or send an email before, or after, a specific 
event. Triggers can be used for notifications, validation, custom text entry, logging, and synchronization.

Working directory
The local path where Surround SCM files are stored and changes are made to them.

Workspace branch
A private branch that is created by an individual user. Other users are not affected by changes made 
because the work is being done in a private branch. When a user finishes making changes, changes can 
be promoted from the workspace branch to the baseline, or ancestor, branch. Changes can also be 
rebased from the baseline branch to a workspace branch.
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